bit-tech.net

Go Back   bit-tech.net Forums > Technology > Tech Support

Reply
 
Thread Tools
Old 9th Dec 2007, 00:06   #1
Gambler
Multimodder
 
Join Date: Jun 2006
Location: One Mile High
Posts: 90
Gambler has yet to learn the way of the Dremel
Apache (in Xampp) wont start.

Hey all!

I am having more trouble than usual with my local test server.

I recently set up a new virtual server and noticed that apache would refuse to start. It stalls on "Apache is starting port 80...Busy".

I tried deleting only the new virtual host, but there was no change. I deleted all of the virtual hosts, and now it does work. Adding a single virtual host (even ones that had worked before) cause apache to become a pissy 3yr old.

Any help?
__________________
Play with fire and you get burned, play with a Dremel and you end up in debt...
Gambler is offline   Reply With Quote
Old 9th Dec 2007, 01:11   #2
Fophillips
Hypermodder
 
Fophillips's Avatar
 
Join Date: Oct 2006
Location: Great Britain
Posts: 948
Fophillips has yet to learn the way of the Dremel
Which operating system are you using, if you’re not using Windows I wouldn’t suggest using Xampp at all.
Fophillips is offline   Reply With Quote
Old 12th Dec 2007, 02:25   #3
OleJ
Me!
 
OleJ's Avatar
 
Join Date: Jul 2007
Location: Copenhagen, Denmark
Posts: 2,024
OleJ has yet to learn the way of the DremelOleJ has yet to learn the way of the Dremel
If you're on Mac you could try MAMP
Linux... LOL you should know what to use.
Windows: Running XAMPP myself on my server. I've had Apache bug my a lot earlier because of the XAMPP control panel. It refused to start and wouldn't load as a service and was behaving oddly.
The solution (for me) was simply using the XAMPP Control Panel to remove Apache as a service. Stop Apache. Reboot. Add Apache as service and then reboot once more. Dunno if it will solve it for you but I recommend giving it a go.
Otherwise I'd recommend using the XAMPP forums ;-) As there are probably more XAMPP users with some good tips on what to do.

Edit: When you say "new virtual server" what are you then referring to? If you're running a virtual machine (VMWare, Microsoft Virtual Machine etc.) try setting Apache up on a random port other than 80. Or at least try defining port 80 in your conf to see if that helps.
__________________
Quickr! Clickr to my Flickr!
Canon camera stuff. Some aluminium PC, a Mac Mini and a last-gen MBP 17"..
OleJ is offline   Reply With Quote
Old 17th Apr 2008, 23:20   #4
Michele
What's a Dremel?
 
Join Date: Apr 2008
Posts: 1
Michele has yet to learn the way of the Dremel
Heya

i had a similar problem. seems that port 80 which is the default port for apache in my case was being used by skype. it said it was busy and just wouldnt run. you can try to change the port or go into the xampp folder and click xampp-portcheck.exe that will tell you if the port is already being used that is using it. uninstall that program and you should be ok. i was anyhow. otherwise try to change the port apache listens to.
Michele is offline   Reply With Quote
Old 15th Nov 2009, 00:00   #5
Kaemon
What's a Dremel?
 
Join Date: Nov 2009
Posts: 1
Kaemon has yet to learn the way of the Dremel
If XAMPP Apache won't start...
and your not running IIS...
and you're not running Skype...


Continue reading. Solution below (Windows)

First, open C:\xampp\apache\logs\error.log and see what the error is.

If the error says that a port is already in use, the instructions below will explain how you can determine which application is using that port (Windows).

My error log entry said that Port 443 was already being used (and I wasn't running IIS or Skype)

(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down

To determine which application is using Port 443 (or port 80), do the following (Windows)

1. Open a DOS window - Start | Run | "CMD"
2. Type the following: netstat -aon
3. Find the local address using :443 (example: 127.0.0.0:443)
4. Now find the PID associated with that active connection (last column) - This is the application that's using that port.

To figure out what application is associated with that PID, do the following:
5. Open Task Manager (Ctrl+Alt+Del) and select the Processes tab.

By default, you will only see the following columns in the Process Tab:
- Image Name
- UserName
- CPU
- Mem Usage

6. From the dropdown menu, Click "View" and then "Select Columns..."
7. Place a check next to PID (Process Identifier) - you will now be able to see the PID for each application running
8. Find which process is associated with the PID

You have now identified which application is screwing up your Apache Service.

btw, my problem was PMB.EXE, which is Pando Media Booster. Pando Media Booster is the Peer-to-Peer downloader client for Dungeons and Dragons Online. As soon as I uninstalled it, Apache started no problem.

I hope that helps someone.
Kaemon is offline   Reply With Quote
Old 15th Jan 2012, 04:25   #6
seamoh
What's a Dremel?
 
Join Date: Jan 2012
Posts: 2
seamoh has yet to learn the way of the Dremel
Thank you very much , it helps me lot

Quote:
Originally Posted by Kaemon View Post
If XAMPP Apache won't start...
and your not running IIS...
and you're not running Skype...


Continue reading. Solution below (Windows)

First, open C:\xampp\apache\logs\error.log and see what the error is.

If the error says that a port is already in use, the instructions below will explain how you can determine which application is using that port (Windows).

My error log entry said that Port 443 was already being used (and I wasn't running IIS or Skype)

(OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down

To determine which application is using Port 443 (or port 80), do the following (Windows)

1. Open a DOS window - Start | Run | "CMD"
2. Type the following: netstat -aon
3. Find the local address using :443 (example: 127.0.0.0:443)
4. Now find the PID associated with that active connection (last column) - This is the application that's using that port.

To figure out what application is associated with that PID, do the following:
5. Open Task Manager (Ctrl+Alt+Del) and select the Processes tab.

By default, you will only see the following columns in the Process Tab:
- Image Name
- UserName
- CPU
- Mem Usage

6. From the dropdown menu, Click "View" and then "Select Columns..."
7. Place a check next to PID (Process Identifier) - you will now be able to see the PID for each application running
8. Find which process is associated with the PID

You have now identified which application is screwing up your Apache Service.

btw, my problem was PMB.EXE, which is Pando Media Booster. Pando Media Booster is the Peer-to-Peer downloader client for Dungeons and Dragons Online. As soon as I uninstalled it, Apache started no problem.

I hope that helps someone.
seamoh is offline   Reply With Quote
Old 15th Jan 2012, 04:31   #7
seamoh
What's a Dremel?
 
Join Date: Jan 2012
Posts: 2
seamoh has yet to learn the way of the Dremel
Thank you Kaemon , you help me a lot
seamoh is offline   Reply With Quote
Old 11th Feb 2012, 15:16   #8
adilpak47
What's a Dremel?
 
Join Date: Feb 2012
Posts: 1
adilpak47 has yet to learn the way of the Dremel
Quote:
Originally Posted by Gambler View Post
Hey all!

I am having more trouble than usual with my local test server.

I recently set up a new virtual server and noticed that apache would refuse to start. It stalls on "Apache is starting port 80...Busy".

I tried deleting only the new virtual host, but there was no change. I deleted all of the virtual hosts, and now it does work. Adding a single virtual host (even ones that had worked before) cause apache to become a pissy 3yr old.

Any help?
BEST SOLUTION:

Do you have skype?

If you answerd yes, Go into skype options > Advanced > Connection, You'll see a box ticked, beside that it will say Use port 80 and 443 for incomming connections, What you need to do it UNTICK that box, and click okay. close skype, like quit it so it isn't running. After you quit it once, you can re-open it again. That should solve your issue if you have skype.
adilpak47 is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +1. The time now is 11:43.
Powered by: vBulletin Version 3
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.