1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

News AMD confirms bugs in Catalyst 14.9 driver bundle

Discussion in 'Article Discussion' started by Gareth Halfacree, 3 Oct 2014.

  1. Gareth Halfacree

    Gareth Halfacree WIIGII! Staff Administrator Super Moderator Moderator

    Joined:
    4 Dec 2007
    Posts:
    12,130
    Likes Received:
    1,667
  2. Corky42

    Corky42 Where's walle?

    Joined:
    30 Oct 2012
    Posts:
    9,163
    Likes Received:
    303
    So much for WHQL preventing these types of things.
     
  3. r3loaded

    r3loaded Well-Known Member

    Joined:
    25 Jul 2010
    Posts:
    1,095
    Likes Received:
    31
    Not had any issue with my 7970 so far *touch wood*
     
  4. Dave Lister

    Dave Lister Member

    Joined:
    1 Sep 2009
    Posts:
    868
    Likes Received:
    10
    I've not had any problems with my trusty 5870 and I just checked CCC and it opens fine.
     
  5. runadumb

    runadumb New Member

    Joined:
    20 Jan 2010
    Posts:
    424
    Likes Received:
    5
    Upgraded last night and it so far hasn't given me any trouble on my 5800k
     
  6. sandys

    sandys Well-Known Member

    Joined:
    26 Mar 2006
    Posts:
    3,022
    Likes Received:
    86
    Business as usual then :D :wallbash:

    Sorry I couldn't resist, I did get the hang but it worked fine when I uninstalled the old driver and then installed 14.9, just assumed it was a quirk of installing over the top and the complexities when you many cards installed which lead to so many devices having to be uninstalled/reinstalled.
     
    Last edited: 3 Oct 2014
  7. loftie

    loftie Well-Known Member

    Joined:
    14 Feb 2009
    Posts:
    2,854
    Likes Received:
    123
    Also had no issues with C14.9 as of yet. The article is doing a 502 dance, click link 502, click link get article, click link 502, now it refuses to work again.
     
  8. RichCreedy

    RichCreedy Hey What Who

    Joined:
    24 Apr 2009
    Posts:
    4,699
    Likes Received:
    172
    I had an issue with 14.9 in that playing a game of BF4, I could play for say 3 or 4 rounds (around 40-60 Mins) and the machine would totally hang
     
  9. TreeDude

    TreeDude New Member

    Joined:
    12 May 2007
    Posts:
    270
    Likes Received:
    0
    BSODs have been a common occurrence on all the 14.x drivers with the R series when video acceleration turned on. This driver does nothing to fix that. Luckily I have an R9 270X which is NGC 1.0 and not 1.1 like the effected cards.

    AMD needs to do some serious reworking of how they handle driver updates. Stability and bugs should be top priority, then performance. You can pretty much label all 14.x drivers as beta because they have far too many bugs.
     
  10. NoiseBoySSL

    NoiseBoySSL New Member

    Joined:
    10 Sep 2014
    Posts:
    3
    Likes Received:
    0
    Are you using Mantle? Try switching back to DX11. There is a memory leak with Mantle that Dice are refusing to acknowledge.
     
  11. RichCreedy

    RichCreedy Hey What Who

    Joined:
    24 Apr 2009
    Posts:
    4,699
    Likes Received:
    172
    I had heard, i'll have a look later to see if I enabled it or not (getting old can't remember, lol)



    edit: yes had mantle enabled
     
    Last edited: 4 Oct 2014
  12. mi1ez

    mi1ez Active Member

    Joined:
    11 Jun 2009
    Posts:
    1,428
    Likes Received:
    17
    BT seems to be riddled with these errors at the moment. Hopefully it settles down soon.
     

Share This Page