1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Graphics Anyone else having games crash on nVidia cards?

Discussion in 'Hardware' started by mikeyman198, 2 Aug 2013.

  1. mikeyman198

    mikeyman198 Lets pretend this is hilarious.

    Joined:
    12 May 2011
    Posts:
    596
    Likes Received:
    21
    For about a week I've been having multiple games crash due to what I can only imagine is the drivers. I was using the 320.49 WHQL drivers, so I did a driver sweeper and reinstalled them, still no luck. So I rolled back to the 320.18 WHQL drivers, but the problem persists. Whats going on?
     
  2. The_Crapman

    The_Crapman Don't phone it's just for fun.

    Joined:
    5 Dec 2011
    Posts:
    4,145
    Likes Received:
    891
    What are your temps like? I have updated my drivers from the 314.xx whql after that issue with the beta driver that supposedly killed some cards.
     
  3. Cei

    Cei pew pew pew

    Joined:
    22 Mar 2008
    Posts:
    4,712
    Likes Received:
    122
    Go back to 314.xx, far better than the current 320.xx crop of drivers.
     
  4. mikeyman198

    mikeyman198 Lets pretend this is hilarious.

    Joined:
    12 May 2011
    Posts:
    596
    Likes Received:
    21
    Temps are always below 70.
     
  5. mikeyman198

    mikeyman198 Lets pretend this is hilarious.

    Joined:
    12 May 2011
    Posts:
    596
    Likes Received:
    21
    I'll try that, thanks.
     
  6. Elton

    Elton Officially a Whisky Nerd

    Joined:
    23 Jan 2009
    Posts:
    8,575
    Likes Received:
    189
    Just stick with the 314.xx drivers. I'm still on them and it's served me mightily well.
     
  7. Teelzebub

    Teelzebub Up yours GOD,Whats best served cold

    Joined:
    27 Nov 2009
    Posts:
    15,796
    Likes Received:
    4,484
    Using the latest drivers with no problems at all
     
  8. Stanley Tweedle

    Stanley Tweedle NO VR NO PLAY

    Joined:
    3 Apr 2013
    Posts:
    1,625
    Likes Received:
    28
    The crap I had months ago from my Nvidia drivers led me to believe it was a problem with the waterblock I fitted a year ago not cooling all parts. So I took the waterblock off and sold it. Now back on air cooling. Problems returned a few weeks after being back on air so again I thought it must be a GPU fault. Turns out it was no such thing. For me it was Speedfan causing the problems. Some utils accessing the GPU temp sensor can cause the problems you're having.

    I'm sure you're not using speedfan but if you have any utility that monitors and displays GPU then try removing it completely from startup.

    It could just be driver issues though since many people seem to have had issues with 320.49 and other 320 drivers.

    Since ditching speedfan my GPU has been perfect. No drivers crashes.
     
  9. Jester_612

    Jester_612 "Jammy..."

    Joined:
    14 Nov 2011
    Posts:
    1,139
    Likes Received:
    30
    I was stuck on 306.97, until a BIOS update.
     
  10. RedFlames

    RedFlames ...is not a Belgian football team

    Joined:
    23 Apr 2009
    Posts:
    11,206
    Likes Received:
    1,347
    Had no issues with the the 326.41 ones I'm using [or any others tbh]
     
  11. The_Crapman

    The_Crapman Don't phone it's just for fun.

    Joined:
    5 Dec 2011
    Posts:
    4,145
    Likes Received:
    891
    Another one i had was the nvidia hd audio drivers causing crashes in fc3. Uninstalled them and was fine.
     
  12. damien c

    damien c Mad FPS Gamer

    Joined:
    31 Aug 2010
    Posts:
    2,716
    Likes Received:
    97
    Tried all the latest versions, and get nothing but game crashes and the stupid display driver stopped responding message.

    Will be sticking with 314:22 drivers for quite a while as I don't really want to mess around with video drivers causing games and windows to mess up.
     
  13. mrbens

    mrbens New Member

    Joined:
    15 Aug 2009
    Posts:
    511
    Likes Received:
    4
    All drivers after 314.22 can cause random lock up/freezes and more problems.

    I've just wasted the whole weekend trying to diagnose what was wrong with my PC until I stumbled upon an nVidia forum thread stating my exact symptoms.

    Rolled back to 314.22 and things are much better, no more lock ups, but still get an occasional black screen for a few seconds and some 1080p playback is still not fully smooth.
     
  14. Darkwisdom

    Darkwisdom Level 99 Retro Nerd

    Joined:
    27 Aug 2011
    Posts:
    2,675
    Likes Received:
    62
    I'm on the 326.41 drivers. I've had no problems on these ones. The last few driver updates have been awful and I had been experiencing crashing, stuttering and one frightening BSOD, which turned out to be the drivers. These new ones seem to be the most stable for a while.
     
  15. AlienwareAndy

    AlienwareAndy New Member

    Joined:
    7 Dec 2009
    Posts:
    3,421
    Likes Received:
    70
    You shouldn't need Driver Sweeper any more. Just check "Perform a clean install" and it does the same thing.
     
  16. GeorgeK

    GeorgeK Swinging the banhammer Super Moderator

    Joined:
    18 Sep 2010
    Posts:
    8,200
    Likes Received:
    351
    I'm on the latest beta drivers (for the Splinter Cell SLI profile mainly) and I haven't had any issues (*touches wood*) but if you don't need stuff like that then the 314.xx drivers are plenty good enough & mainly issue-free.
     
  17. mattyh1995

    mattyh1995 Active Member

    Joined:
    1 Oct 2011
    Posts:
    791
    Likes Received:
    25
    I'm on the latest beta drivers with a 770 and all is fine with me.
     
  18. mrbens

    mrbens New Member

    Joined:
    15 Aug 2009
    Posts:
    511
    Likes Received:
    4
    That's good to hear guys. I've just had a nice new 760 delivered today for my new build. I've heard some people have also had the random freeze/lock ups on the newer cards too but hope I get lucky. The latest drivers completely screwed by 460.
     
  19. WhiteKnight226

    WhiteKnight226 Member

    Joined:
    2 Mar 2011
    Posts:
    281
    Likes Received:
    3
    I see you have the MSI GTX 670 and an MSI MoBo. I had the same problem. I had a GTX 670 PE by MSI. After about a month of use, the card was causing random shut offs of my PC. I RMA'd the card 3 times to MSI and they denied all problems with the card. You're not the only person who is experiencing this issue. A lot of people are having issues with MSI 670's pared with MSI Mobo's. All driver and BIOS updated fixed nothing. I recommend selling the card. I took a $200 loss because of MSI when I recently sold my 670PE. Go with an AMD card with a MSI MoBo, they seem to work well together.
     
  20. mrbens

    mrbens New Member

    Joined:
    15 Aug 2009
    Posts:
    511
    Likes Received:
    4
    Uhoh, I have an MSI 760 and MSI socket 1150 mobo sitting on my table. Just waiting for some more parts to be delivered before I upgrade my PC. My current setup is Zotak 460 with Asus socket 1366 mobo.
     

Share This Page