Booting in BIOS

Discussion in 'Asus UK' started by AllanRoy, 25 Jan 2016.

  1. AllanRoy

    AllanRoy New Member

    Joined:
    16 Jul 2009
    Posts:
    33
    Likes Received:
    0
    Hi,

    Maximus Vlll Hero. rev. 1.01
    OS Win 10 Pro 64 bit
    i7 6700K
    Samsung SSD 840 500GB
    GeForce GTX 770

    I've just finished building my system this last week - with a clean install of Windows 10 Pro 64bit and for the most part it seems to be working OK, except for one problem - the system will often boot into the UEFI BIOS rather than Windows. This happens particularly if, from within Windows, you select "Restart" - it will restart, but will boot into the BIOS, not the OS. Also, when exiting the BIOS, it will often boot straight back into the BIOS again. The workaround is to press the case reset button and it will then boot it back into Windows. Booting from cold will usually take you into Windows as normal, but not always. Also, when the computer wakes from Sleep Mode, the BIOS splash screen/logo appears, and the system will enter the BIOS, not the OS.

    I only noticed this behaviour after I upgraded the BIOS from 0802 to 1402. I have since gone back to 1302 in the hope of curing the problem, but it hasn't helped. I don't really believe the BIOS version is the problem here, but I really do need to get to the bottom of this and sort it.

    The system is not overclocked and currently all BIOS settings are currently set to default.

    Also, I've noticed that the EFI in EzMode shows my three drives: P1.DVD; P2. 2TB HDD; P3. SSD. (The OS is on the SSD). However, in the "BOOT" menu, under "Boot Option Priorities" the DVD is not listed and is not available as an option, it lists only #1. SSD; #2. USB; #3 2TB HD. Why is the DVD drive missing? And why does it list a USB drive as option 2? (The DVD drive seems to work fine). Is this somehow related to the "booting into the UEFI" problem?

    Also, the system is completely ignoring the Power & Sleep Settings. It is currently set to power down the screen after 5mins, and system to Sleep after 15mins. These settings are being completely ignored and the system will stay on all day if I let it.

    I'm running out of ideas now, but I urgently need to fix this "Booting into BIOS" behaviour, so if anybody can help, I'm listening.

    Many thanks,
    AllanRoy.
     
  2. Ryan@ASUS

    Ryan@ASUS New Member Moderator

    Joined:
    23 Oct 2015
    Posts:
    38
    Likes Received:
    1
    Have you tried unplugging things to narrow down the problem? To me it sounds like the keyboard is jammed or a key is stuck so its automatically entering the BIOS upon keypress.

    Or it could potentially be something else. But either way something is keeping the PC awake (hence why a stuck keyboard seems likely). It could be something else though, just start removing things and see if it solves the problem. E.g. you could try unplugging the DVD drive too if you think that's causing the problem.

    Sorry I can't be of more specific help, it's a very vague problem at the moment so we need to narrow it down to something more specific.
     
  3. AllanRoy

    AllanRoy New Member

    Joined:
    16 Jul 2009
    Posts:
    33
    Likes Received:
    0
    No, no actually that's more helpful than you might think. One thing that did happen a couple days ago, (about the same time as I upgraded the BIOS) whilst installing the software etc. onto the new build, the pet rabbit got into the office and chewed through the keyboard cable! I had to bring out an old keyboard and use that as a backup until I can buy a new backlit gaming keyboard.

    The old keyboard I'm using, had been laying around for a couple of years - had suffered coffee damage - but it seems to be working well enough and certainly got me out of a tight spot. Using MS Word doesn't show up any unwanted key-presses and so far I haven't detected any odd behaviour in my other programmes. But nevertheless, you could be onto the problem here. I'll try to get the keyboard replaced asap and see what happens - it may well be the problem.

    Cheers AllanRoy.
     
  4. dancingbear84

    dancingbear84 error 404

    Joined:
    16 Oct 2010
    Posts:
    2,189
    Likes Received:
    73
    Pressing shift key and reboot will boot to recovery. You can confirm this by unplugging the keyboard when in Windows and trying a reboot and seeing what happens.
     
  5. AllanRoy

    AllanRoy New Member

    Joined:
    16 Jul 2009
    Posts:
    33
    Likes Received:
    0
    Hi,

    It's not the keyboard - have got hold of a new one, but still have same problem. Neither is it the DVD drive - unplugged that and still no change.

    What I have noticed is that, when the system booted normally, once the ROG logo/screen has disappeared the blue Windows logo appeared pretty much straight away. But now that's not happening at the moment; after the ROG logo disappears there is a period when the screen is black and all you see is the occasional flash of what appears to be a cursor, first in the top left corner, then in various places on the screen, then the UEFI BIOS appears and it always opens at the "Extreme Tweakers" page.

    Now as I've said, the system is not overclocked and the BIOS settings are set to their default, so why when it is booting into the BIOS (instead of the OS) is it opening at the Extreme Tweakers page? Is that a possible clue?

    Cheers, AllanRoy.
     
  6. Ryan@ASUS

    Ryan@ASUS New Member Moderator

    Joined:
    23 Oct 2015
    Posts:
    38
    Likes Received:
    1
    Hi Allan,

    Sounds like it could be a corrupted BIOS of sorts. Try a clear CMOS the old fashioned way (remove the CMOS battery, unplug from the wall, leave the system for about 30 seconds to a minute to totally drain of power and go cold). If that doesn't work, Can you reflash your BIOS again? Better still update it to a newer version if there is one, let me know if it still has the problem.

    Also try unplugging everything except cpu, 1 stick of memory, run off the onboard gpu, no keyboard, no mouse. See if it will POST past the BIOS and give you a hard drive error. If it does then something else is causing the problem. If not, it's possible your motherboard is faulty.

    Ryan
     
  7. AllanRoy

    AllanRoy New Member

    Joined:
    16 Jul 2009
    Posts:
    33
    Likes Received:
    0
    Hi Ryan,

    This problem of booting into the BIOS rather than the OS, appeared around the same time I actually upgraded the BIOS to the latest version 1402 - something that is supposed to improve system stability, not destabilise it! And, as I said in my OP, I re-flashed it back to version 1302, but that didn't help, either. In desperation yesterday I re-flashed the BIOS back to the original version it shipped with - 0802 and this does seem to have helped.

    I have since followed your advice and cleared the CMOS the "old fashioned way" to reset the BIOS. At the moment the system does seem to be behaving itself, but I've still got my fingers crossed. I'm very wary of upgrading the BIOS again back to the latest version (1402) as that seemed to set off the whole problem in the first place.

    Cheers, Allan.
     
  8. Ryan@ASUS

    Ryan@ASUS New Member Moderator

    Joined:
    23 Oct 2015
    Posts:
    38
    Likes Received:
    1
    Hi AllanRoy,

    That's somewhat good news if the stability persists.

    In regards to BIOS versions, unless you are specifically having stability or performance issues, there's no genuine need to be on the latest BIOS version.

    When we use an annotation like "Improves system stability", it just means we've fixed an issue, or maybe several, with some particular hardware/software/BIOS configuration that caused stability issues with some customers. It could be tweaking settings for when a particular memory kit is installed, when a particular arrangement of storage drives is used, or fixing/changing something else "under the hood" to fix problems made known to us.

    In reality, as seems to be the case with all computers, you end up playing a game of wack-a-mole. Where you fix one problem and something else pops up, so not to be old fashioned but..... "if it ain't broke, don't fix it"

    Ryan
     
  9. AllanRoy

    AllanRoy New Member

    Joined:
    16 Jul 2009
    Posts:
    33
    Likes Received:
    0
    Hi Ryan,

    System has definitely settled down and haven't yet had a recurrence of the "Booting into BIOS" problem since clearing CMOS and reverting to 0802, which I'll stick with for now. May try upgrading again later, but right now I need to get some work done!

    However there is still one problem outstanding, that hasn't been fixed and I'd appreciate your help. The system still won't go into Sleep Mode by itself. The Power & Sleep setting are being completely ignored. It doesn't matter what I setting I put in there - it won't make the slightest bit of difference. As I said before, the computer will stay on all day and all night if I let it.

    This problem started at the same time as the BIOS issues when I upgraded to rev. 1402, but hasn't been cured by reverting back to 0802. I'd appreciate your advice.

    Cheers Allan.
     
  10. Ryan@ASUS

    Ryan@ASUS New Member Moderator

    Joined:
    23 Oct 2015
    Posts:
    38
    Likes Received:
    1
    Hi Allan,

    Strange problem. Firstly, is the sleep option actually available to you, or is it "greyed" out in the menus?

    Typically sleep problems are a problem with software, effectively not communicating with the hardware properly. The relevant drivers here would be Intel Chipset + other MB drivers, the Intel Management Engine driver (if you have that for your board) and potentially VGA.

    How much diagnosis have you done in terms of identifying what is preventing the sleep mode? See for example, this? In short, it's more likely to be a recent software or driver change than MB/BIOS related, but I think we can get it solved nonetheless!

    http://www.cnet.com/uk/how-to/find-out-what-program-is-interrupting-windows-sleep-mode/

    Ryan
     
  11. AllanRoy

    AllanRoy New Member

    Joined:
    16 Jul 2009
    Posts:
    33
    Likes Received:
    0
    Hello Ryan,

    Thanks for the reply. Yes 'Sleep' is available and I can put the system into Sleep Mode manually, by using the Sleep option in the Start/Power menu. And since we fixed the booting problem, it comes out Sleep Mode nicely when required. It's just ignoring the Sleep/Power Settings in Settings Menu, so if left alone, the System will never go to sleep by itself.

    I've done little by way of diagnostics myself, as frankly I'm not sure where to start, but I'll follow the link you gave me, and see where that leads. But I would be delighted to pin this one down and find out what or who the culprit really is.

    Cheers, Allan.
     
  12. AllanRoy

    AllanRoy New Member

    Joined:
    16 Jul 2009
    Posts:
    33
    Likes Received:
    0
    Hi Ryan,

    Followed the thread from your earlier posting, and it led me to a webpage that showed how you could use "Command Prompt" to query the system (using the 'powercfg -requests' command) to show you what program or driver is interfering with Windows Sleep.

    Unfortunately, this method is far from fool-proof and will often draw a blank, as it did in my case. So no luck there. I would have been extremely impressed had that method highlighted the culprit - but it was not to be.

    I have since been busy removing unwanted stuff - even though my system is only 10 days old it's already littered with unwanted programs etc that have wormed their way onto the hard drive. I've also disabled everything I can in "Startup". I've even removed my Logitech Setpoint Mouse driver and am using the generic Microsoft one. Still the system absolutely refuses to go into Sleep Mode according the Power/Sleep Settings.

    My chipset drivers are up-to-date (10.1.1.7). I can't remove my GeForce driver or essential programs like Norton System Security, so at present I'm no further forward.
     
  13. Ryan@ASUS

    Ryan@ASUS New Member Moderator

    Joined:
    23 Oct 2015
    Posts:
    38
    Likes Received:
    1
    Hi Allan,

    I still think there is something preventing the PC from sleep in terms of software, it's unlikely to be a hardware problem. It's most likely a display adapter, USB controller or device or network controller with troublesome config settings or a troublesome interaction with Windows power management options. If you find your PC wakes up after you force it to sleep then you could try powercfg -lastwake. For powercfg -requests make sure the command prompt is running in administrator mode.

    Also try these threads for some more suggestions/info:

    http://www.bleepingcomputer.com/forums/t/591240/windows-10-wont-go-into-sleep-mode/
    http://superuser.com/questions/532993/why-wont-my-computer-go-to-sleep-automatically

    Also consider the "Event Viewer" tool as your best friend in troubleshooting. It contains a lot of system logs and if the system sits idle for the sleep timeout but doesn't go to sleep there should be something in the log that gives this way.

    Ryan
     
  14. AllanRoy

    AllanRoy New Member

    Joined:
    16 Jul 2009
    Posts:
    33
    Likes Received:
    0
    Hi Ryan,

    I think you're right. I don't think it is a hardware issue, but most likely a software problem along the lines you suggest, but tracking it down, that's the real problem and it is proving extremely difficult to pinpoint. I've never had problems with the computer waking once it's been put to sleep manually. I've stopped all devices and events from waking the machine - it only comes back to life now when pressing the Power button.

    I ran the "PowerCfg - ENERGY" command and it analysed my system producing a html report. It did discover some errors and problems, put I don't know how to interpret it. Would you be willing to look at it as it may hold the key as to what is preventing the system going into Sleep Mode. Really appreciate your help given that this isn't a motherboard problem.

    Cheers, Allan.
     
  15. Ryan@ASUS

    Ryan@ASUS New Member Moderator

    Joined:
    23 Oct 2015
    Posts:
    38
    Likes Received:
    1
    Sure Allan,

    Feel free to share it, not sure what would work best, maybe dropbox or a google drive share depending on how big the file is.

    Although I'm not sure that command is necessarily the right one to track down this problem. PowerCfg -Energy is about what applications are using the most battery power/system resources, normally, but maybe it does hold some useful info.
     
  16. AllanRoy

    AllanRoy New Member

    Joined:
    16 Jul 2009
    Posts:
    33
    Likes Received:
    0
    Hi Ryan,

    I've used Event Manager as you suggested, and I think it may actually have highlighted the problem. EM is flagging up an 'Error' at about the same time as the System is due to go to Sleep. It appears to be doing this each time, so there does seem to be some correlation here. If this is the case then the culprit is - according to EM - "DistributedCOM event ID 10016". The error description says:

    I'm not sure what this means and neither do I know how to use the "Component Services administrative tool" to alter the relevant permissions, although I'll look into this, but I have to say this is a little beyond my abilities.

    Anyway, what do you think - does this seem to be the problem?

    Allan.
     
    Last edited: 5 Feb 2016
  17. Ryan@ASUS

    Ryan@ASUS New Member Moderator

    Joined:
    23 Oct 2015
    Posts:
    38
    Likes Received:
    1
    Hi Allan,

    I've not come across it before, either, but these instructions seem pretty clear and promising.

    ""

    1. Click Start -> Run -> Type -> dcomcnfg, expand Component Services -> Computers -> My Computer -> DCOM Config.
    2. Click View -> Detail -> Now you will get Application Name and Application ID in right side.
    3. Scroll down and find the application ID {AD65A69D-3831-40D7-9629-9B0B50A93843} -> Right Click -> Properties and select the Security tab.
    3. Click Customize under "Launch & Activation Permission" -> click Edit -> Add in the account NT AUTHORITY\SYSTEM and set local launch and local activation.
    4. Restart the application Service linked to this Application ID or restart the server and monitor

    ""

    Maybe give that a go and see if it fixes the problem

    Ryan.
     
  18. AllanRoy

    AllanRoy New Member

    Joined:
    16 Jul 2009
    Posts:
    33
    Likes Received:
    0
    Hi Ryan,

    Thanks for your help. I got Component Services up and running OK. However, there is no application ID {AD65A69D-3831-40D7-9629-9B0B50A93843}, listed under the "DCOM Config" section. And interestingly, neither the CLSID or APPID refs quoted in the Event Viewer (see my previous posting) are listed in "DCOM Config", either. Not sure where to go from here.

    Cheers, Allan.
     
  19. AllanRoy

    AllanRoy New Member

    Joined:
    16 Jul 2009
    Posts:
    33
    Likes Received:
    0
    Hi Ryan,

    Update to my above posting - the CLSID and APPID keys are both to be found in Registry under:
    HKeyClassesRoot\CLSID and
    HKEYLocalMachine\AppID - respectively.

    Edit: Following up the Registry Keys, and their description, the problem seems to be with 'RuntimeBroker', which is listed in Component Services under DCOM Config. But if I right-click on that and open its Properties, the permissions in the Security tab, are all disabled/greyed-out.

    Edit (2): I've since discovered that to make changes in Component Services, I first need to change ownership of 'RuntimeBroker' via the Permissions dialog in the Registry in order to Full Control. But negotiating the Permissions protocol is far from straightforward. The main problem I've encountered is that it won't let me enter the Desktop\Administrators Group as the owner.

    Don't know if this helps?

    Allan.
     
    Last edited: 10 Feb 2016
  20. Ryan@ASUS

    Ryan@ASUS New Member Moderator

    Joined:
    23 Oct 2015
    Posts:
    38
    Likes Received:
    1
    Well this is all getting a bit technical! To be honest, RuntimeBroker is unlikely to be preventing your PC from sleeping since it handles application permissions and such, no power management or anything like that. If it's greyed out then that's totally normal. I've checked three Windows PCs that are working fine and it's greyed out on them all.

    Your problem sounds more symptomatic of missing updates, outdated drivers or damaged windows files, rather than permissions problems.

    Have you tried something like SFC /scannow to check the health of your Windows files. Are all your Windows updates installed? Have you used Intel's driver tool to make sure all your Intel drivers are on the latest versions? Have you ensured all your network controllers are on the latest driver versions? The same for your graphics drivers? Have you tried running something like CCleaner to clear old temp files, dud/broken registry entries and other junk system files that could be causing problems? Also a thorough virus/malware scan to check some kind of hostile remote connection isn't keeping your PC awake (Malware Bytes is good for this).

    Like I said, without access to the system it's really difficult to pinpoint the problem. And short of a fresh install I don't really know what would be a "guaranteed" fix!

    Ryan
     

Share This Page