1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Windows Deus Ex Human Revolution steam - FPS issues

Discussion in 'Gaming' started by qndzi, 22 Jun 2012.

  1. qndzi

    qndzi New Member

    Joined:
    22 Jun 2012
    Posts:
    10
    Likes Received:
    0
    Hey there fellow techies,

    Just wanted to say Hi, as i'm newly registered user but long time reader, now to the point :)

    So i bought fore mentioned game on steam sale, well now. My PC is beefy, boasting GTX 670 windforce (304.48 drivers), 2500k @ 4.6, Gene-Z and 8 GB of corsair vengance however running this game broght me some unexpected problems...

    First startup with every eye candy it had to offer in 1080p welcomed me with 0.7 FPS just on logo screens and after having enough time for a sandwich the intro to the game didn't get any better, doodling around with settings and resetting to default and running to intro sequence fixed the issue, after exiting and cranking it up to maximum again it worked perfectly that is untill 10 minutes in the game when my framerate was jumping like bunnies on crack cocaine from 0.7 while staring at the wall to 60 (V-sync) while jumping around shooting inside a burning room

    That leaves me baffled, anyone else with similar problems?
     
  2. Bubblejunk

    Bubblejunk New Member

    Joined:
    26 Jun 2012
    Posts:
    1
    Likes Received:
    0
    Having same problem, too lazy to wait for intros to go over.
     
  3. Da_Rude_Baboon

    Da_Rude_Baboon What the?

    Joined:
    28 Mar 2002
    Posts:
    4,082
    Likes Received:
    135
    That happened to me with Sniper V2 on Steam I had to leave it to slide show through the splash screens and it was fine once it reached the menu. Never did it again afterwards.
     
  4. DeckerdBR

    DeckerdBR Well-Known Member

    Joined:
    9 Mar 2011
    Posts:
    1,522
    Likes Received:
    29
    sadly i get this issue with human revolution. i am playing happy as larry and all of a sudden it drops to 1-2 fps. oddly if i alt tab out and then click back in via the task bar it clears. it happens at very radom intervals but can be frequent.

    i have had this issue on two different gpus and 2 different drivers versions so my guess is a dodgy patch from the developer. did all the standard steam integrity checks etc. very annoying.
     
  5. silky

    silky New Member

    Joined:
    25 May 2012
    Posts:
    105
    Likes Received:
    2
    My first suspicion would be somethiong running in the background. YouTube often is a culprit. You got anything running in the background?

    p.s. 4.6ghz!! wow! You use water cooling? Wish I could go that far.
     
  6. bdigital

    bdigital Is re-building his PC again

    Joined:
    10 Aug 2010
    Posts:
    6,696
    Likes Received:
    249
    With that chip, 4.6 is easily acheivable on air with a decent cooler.

    Have you checked if you av scan is running in the background?

    Do you have the latest drivers? If so, perhaps try the previous set of drivers to rule them out
     
  7. Draksis

    Draksis New Member

    Joined:
    21 Oct 2009
    Posts:
    1,235
    Likes Received:
    50
    That is just say one thing to me: Windows CPU priority. There's a background app that's demands more from your CPU (or technically memory or GPU) that kills the game. When you alt+tab, this reshuffles the priority list. Used to happen with Prototype until I set the priority in task manager to "Above Normal"

    Also check whats running as well as the game (AV scans, backups, etc). Also check if you can the same issue less/more than before if you run the game just after the boot, as opposed to much later on when you've played other games/programs,etc

    /2cents :thumb:
     
  8. DeckerdBR

    DeckerdBR Well-Known Member

    Joined:
    9 Mar 2011
    Posts:
    1,522
    Likes Received:
    29
    Will that CPU priority be permanently set to above normal or only while the EXE is running, am I going to set to set the priority every time? I did wonder if its AV related, Avast has been fairly finicky recently however normally I can see from the console if it's scanning or holding an EXE or other file.

    I have been wondering if Avast has been picking up on the in-game advertising that was said to have been patching in, although I confess despite looking both in game and at the load screens I have never seen any so wondered if that was only for certain countries.

    I’ll give both a try, it’s annoying because no other game I have does this, and DEHR never used to either.
     
  9. rollo

    rollo Well-Known Member

    Joined:
    16 May 2008
    Posts:
    7,792
    Likes Received:
    117
    Got steam version

    I7950 + 680 sli get 0 problems game runs flawlessly on latest drivers

    Not heard of any issues like this

    Only thing I'd suggest disable overclock and see how it plays then.
     
  10. Dwarfer

    Dwarfer New Member

    Joined:
    30 Mar 2011
    Posts:
    1,039
    Likes Received:
    29
    This game is very sensitive to overclocks, can you set it to default clocks and see how it goes?
     

Share This Page