1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Networks Disconnected network drive causing explorer to freeze

Discussion in 'Tech Support' started by azazel1024, 29 Mar 2011.

  1. azazel1024

    azazel1024 What's a Dremel?

    3 Jun 2010
    Likes Received:
    I am just digging up all of the fun network issues lately.

    One of the ones I am having is that when Windows 7 is disconnected from a network drive, when it attempts to reconnect file explorer freezes, I can't shut it even using taskmgr and if I try to reset or shutdown my machine it hangs on "logging off" and I have to do a hard reset.

    I've found a couple of threads of people experiencing similar problems and it seems isolated to Win7 64bit. No real solutions, though I've heard rumors of changing your network to Home instead of Work, though I am pretty sure mine is already set to home (checking when I get out of work).

    Any other suggestions? Based on those threads and what I know this is because the file server is set to sever the network connection if idle for more than 5 minutes (I reduced from the default autodisconnect setting of 15 min). However, my wife's Vista laptop reconnects no problem, Win7 64 bit...just locks up if it sees that the connection was severed.

    I don't want to have to set it so that the connection never times out on idle (which also means leaving the server up 24/7, or at least 16/7 to account for up time all day long and down late at night). Its a low power server (less than 40w at idle), but it isn't THAT low power (that is still ~$50 a year in electric bill to run it 24/7).

  2. theskirrid

    theskirrid What's a Dremel?

    15 Dec 2009
    Likes Received:
    Is this a password protected share?
    If it is assuming your share path is ourdomain\shares\whatever:
    In TCPv4 settings/advanced/DNS put local and ourdomain.local into the domain suffix search list
    The same in the Group Policy Editor: Group policy->Computer Configuration-> Administrative Templates/network/DNS Client/ DNS Suffix Search List
    Obviously substitute ourdomain with the correct share name.

    If this does not work try setting your MTU for the network connection you use to 1450

    In an elevated CMD prompt window enter:
    netsh interface ipv4 set subinterface "Your Network Connection Name" mtu=1450 store=persistent

    Replace Your Network Connection Name with the correct name, natch.

Share This Page