1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Networks Dual network help needed

Discussion in 'Tech Support' started by Tuthmose, 21 Sep 2016.

  1. Tuthmose

    Tuthmose Member

    Joined:
    24 Feb 2005
    Posts:
    113
    Likes Received:
    4
    Hey all,

    I find myself needing some networking assistance, if anybody is able to lend a suggestion.
    Here is the set-up: I teach high school, and our schools infrastructure, frankly sucks. I’ve cobbled together my own dual-projector A/V setup so my classes and I can join the 21st century; the whole rig is powered by a desktop I built and my laptop. The printer is, by necessity, across the room, as is a shared back-up drive, both hooked up to an Asus RT-AC68r wireless router.

    There-in lies the rub. Since these are all MY machines, I am not permitted to put them on the school’s secure network. I must access the interwebz over the “guest” wireless network. As a result, I cannot access both the RT-AC68 AND the internet at the same time. I have to switch over between them, which kinda sucks.

    My solution was to hardwire the RT-AC68, and run dual networks. Wireless through the school for internet, wired LAN for printing and fileshare.

    BUT . . . I cannot for the life of me get my machines to do that. I’m running Windows 10 Pro on all of them, and as soon as I connect the Ethernet cable, the machines make it the default, and cannot connect to the web. It’s a well-known flaw that in W10 you can no longer manually re-order network priority using the GUI. I have tried to do so by manually setting the interface metrics of both adapters, but that didn’t work either. I’m no network pro by a LONG shot, so I’m out of ideas :-(

    Does anybody have any suggestions on how I can get Windows to connect to both a wired and a wireless network simultaneously, and give priority to the wireless for internet connectivity? Has Micro$oft rendered this impossible in W10, or is there some secret-sauce way to force it to work?

    Any help is greatly appreciated!
     
  2. saspro

    saspro IT monkey

    Joined:
    23 Apr 2009
    Posts:
    9,283
    Likes Received:
    231
  3. Tuthmose

    Tuthmose Member

    Joined:
    24 Feb 2005
    Posts:
    113
    Likes Received:
    4
    Thank you for the suggestion, saspro, but sadly that actually doesn't work in Windows 10.

    Although that settings page remains from previous versions of windows, any changes you make to the order doesn't "take", or have any impact. Exit out after making the changes, and go back again and you'll find the order reverted back. That settings box is purely cosmetic in W10.
     
  4. saspro

    saspro IT monkey

    Joined:
    23 Apr 2009
    Posts:
    9,283
    Likes Received:
    231
    Tested it on the dev boxes here and it seems to work.

    If not you can apply static routes using a cmd line.

    I'm assuming of course the "guest" network and the production network are on completely different subnets
     
  5. Tuthmose

    Tuthmose Member

    Joined:
    24 Feb 2005
    Posts:
    113
    Likes Received:
    4
    Really? That's very interesting. Not only does it reset for me and produce no effect, but my research on line found a ton of complaints from others that it did the same thing.

    I wonder, is there some "secret sauce" method of getting it to work? Are your dev machines just windows 10 pro boxes, or are they different in some way? Is there some elevated permission or something I should look into? Any suggestions?

    As for static routes, unfortunately you are beyond my pathetically limited network ability there. Can you point me to a place where I might educate myself on that?

    In any event, I do appreciate the help!
     
  6. phuzz

    phuzz This is a title

    Joined:
    28 May 2004
    Posts:
    1,700
    Likes Received:
    24
    If you can give us some more information about the networks we can help you with the command line to set static routes.
    What is the ip range of the wirelss network? (eg 192.168.1.1/24 or 10.0.1.1 255.255.0.0)
    What's the default gateway for the wireless network?
    What's the ip range and default gateway of the wired network?
     
  7. Tuthmose

    Tuthmose Member

    Joined:
    24 Feb 2005
    Posts:
    113
    Likes Received:
    4
    Phuzz,

    I'm home now, but I'll look up those ip ranges when I get back to school tomorrow. From screwing around with it this morning, I do know that the school's wireless network was in the 10.0.1.1 range, and the Asus was at its default 192.168.1.1 address. I can get more specifics tomorrow.

    If I can get the desktop set to run both networks by statically defining the paths, that'd be awesome. I'm assuming my laptop, needing to operate both there *and* at home, would be more complicated, since any static path I set at work would screw stuff up when I brought the machine home? Even so, getting at least the desktop sorted would be a huge step in uncomplicating my workflow.

    I did try manually assigning interfact metrics to the two adapters - I gave a 10 to the wireless and a 20 to the ethernet - but that made no difference. Some posts I saw indicated that would work . . . but no. Any idea why that wouldn't have made Windows pick the wireless first?

    For what it's worth, I did try to get clever and set the Asus router to repeater mode, having it rebroadcast the school's guest network. I figured I could thus connect to it and get the wireless AND access to the attached drive and printer. No dice. The router said it found the network and was rebroadcasting it, but while I could connect and print, I got no internet. Figuring the barrier was probably on the school's side of things designed to prevent just such shenanigans, I gave up on that and set it back to wireless router mode.

    Sorry if I come across as a noob at this stuff; at my age, I've got a pretty wide knowledge base about a lot of things, but networking isn't one of them. I probably should find time to fix that, but with essay tests piling up on my desk as we speak, finding the time to learn such a complex field has eluded me. :-(
     
  8. Tuthmose

    Tuthmose Member

    Joined:
    24 Feb 2005
    Posts:
    113
    Likes Received:
    4
    I *may* have solved the issue. After doing more reading, on a hunch I went back in to the metric assignment settings, and just gave the Wireless adapter an even *lower* setting. 2 this time, down from 10. I left the ethernet at 20. Viola! It works. Apparently the original metric I gave the wireless just wasn't low enough, for whatever reason.

    If this stands the test of time, I'm through here. If not, I'll return begging more advice. Thank you Saspro and Phuzz for taking time out to offer your advice and help - it is appreciated!
     
  9. play_boy_2000

    play_boy_2000 It was funny when I was 12

    Joined:
    25 Mar 2004
    Posts:
    1,417
    Likes Received:
    48
    A slightly more elegant solution would be to use a wireless bridge to connect to the guest network and plug it into the wan port on the asus router. For an additional geek points (and probably a large headache), load DD-WRT onto the router and do it all in one box.
     
  10. Tuthmose

    Tuthmose Member

    Joined:
    24 Feb 2005
    Posts:
    113
    Likes Received:
    4
    That would indeed be far more elegant, but I'd need to buy a wireless bridge or another router to set as such. I've already sunk enough of my meager paychecks into this already. I've got it working nicely now, so I think the dual networks will do.
    My cludged-together multi-homed setup does have the advantage of keeping my printer and shared drive off of the guest network, which given our IT department is probably a good thing . . .
     
  11. RichCreedy

    RichCreedy Hey What Who

    Joined:
    24 Apr 2009
    Posts:
    4,699
    Likes Received:
    172
    another solution may be getting getting yourself a wifi access point setup up as an ethernet client side access point, connect that to guest wifi, feed the asus rt the ethernet on the wan side, and you should be able to connect to interwebz without swapping networks
     

Share This Page