1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Networks Dual WAN help? suggestions?

Discussion in 'Tech Support' started by Mr Meltdown, 7 Sep 2009.

  1. Mr Meltdown

    Mr Meltdown Minimodder

    Joined:
    26 Jul 2003
    Posts:
    804
    Likes Received:
    20
    I know my basics on networking, not much beyond that....

    I have just had my own broadband finally enabled after many years waiting, ... in the meantime in desperation I was (with their permission) sharing via wifi a neighbors broadband.

    Now then The setup for my accessing the neighbours wifi was a gateway PC in the loft with shared internet on the wireless card and the PC linked to my others via a switch (simple shared internet access). I used remote desktop to keep tabs on the loft PC from my main rig.

    Now i have on my main rig the new broadband router and my main rig is doing the sharing and the loft pc is switched off and basically redundant (as you cant have two internet connection sharing pcs on the same LAN as they have the same 192.168.0.1 IP and dont work on any other as a shared internet PC).

    I have a DUAL WAN router thing by HAwking but it starts to get too complicated for me to set up, plus the fact the wizard expects you to plug in your modems into WAN 1 and 2, no allowance for me plugging in a gateway PC (the loft PC) into the WAN socket?!? or is there?

    Suggestions?

    Heres what I want to happen:

    I want my new existing shared broadband to stay as it is.
    I want the loft PC to access the neighbours wifi as before (but not shared internet)
    I want to be able to remote desktop the loft PC (i.e connect, download, copy to share etc)

    I dont want load balancing or extra speed, just the above will be fine.

    Cheers
     
  2. Zoon

    Zoon Hunting Wabbits since the 80s

    Joined:
    12 Mar 2001
    Posts:
    5,707
    Likes Received:
    723
    Put two network cards in your loft PC, running on two different IP ranges, and leave the default gateway blank for the network it will NOT connect to the internet with, eg:

    NIC1 - neighbour's wifi, include default gateway
    NIC2 - your wifi, do NOT include default gateway

    As long as you use different IP ranges, you'll be able to access it on your wifi, and it will access you as you're in its IP range on that wifi, and it'll default out your neighbour's link for internet.
     
  3. Mr Meltdown

    Mr Meltdown Minimodder

    Joined:
    26 Jul 2003
    Posts:
    804
    Likes Received:
    20
    Thanks, loft PC has wifi card and LAN, ..... wifi card connects to neighbours wifi, LAN card connects to my switch via long LAN cable.

    PC running XP Pro, wifi card is set to obtain IP address and DNS automatically from neighbours router.

    LAN normally has IP of default gateway as it was internet connection sharing pc,...

    So, leave that alone but unplugged and install another LAn card and assign different IP range? How will my main rig see that? do i need another card in that as well on the same range?

    Cheers
     
  4. Zoon

    Zoon Hunting Wabbits since the 80s

    Joined:
    12 Mar 2001
    Posts:
    5,707
    Likes Received:
    723
    I'm assuming your new broadband came with a router, or at least, you purchased one for use with it!

    This device will assign IP addresses dynamically via DHCP and give itself as the default gateway. It will also usually only give DHCP addresses in a certain block.

    You should tweak your config so you've got something like this:

    Loft PC:
    NIC1 - WIFI - leave it on automatic and it'll get a default gateway etc
    NIC2 - Wired - put a static IP on it, with no default gateway (see below)
    Make sure you DISABLE internet sharing as it will try and DHCP on your wired, and conflict with your router.

    Other PCs should be set up for your new Wifi network on your new router.

    Router:
    If the IP range overlaps with that of your neighbour's wifi, you'll need to wire or wireless into it from a PC which is NOT your loft PC, and configure it via the web interface of the router to a different one. Generally home routers use 192.168.0.1, 192.168.1.1, 192.168.10.1, 192.168.100.1 or 192.168.254.1 - but you can use any value in the third octet between 0 and 254. Just choose something that doesn't clash. Edit your DHCP settings so it gives out 192.168.x.100 - 200 automatically.

    Resultant addressing:

    Neighbour's wifi 192.168.y.1 - DHCP - your loft PC gets IP automatically
    Your router 192.168.x.1 - DHCP .100-.200 - your loft PC has .2 or .10 or whatever you want OUTSIDE .100-.200 with no default gateway, and your other PCs have automatic.

    If this is still a bit confusing, please tell me what router you're using, and what IP address your loft PC has on your neighbour's wifi and I'll write in some IP addresses you can use.
     
  5. Mr Meltdown

    Mr Meltdown Minimodder

    Joined:
    26 Jul 2003
    Posts:
    804
    Likes Received:
    20
    Looking....
     
  6. Mr Meltdown

    Mr Meltdown Minimodder

    Joined:
    26 Jul 2003
    Posts:
    804
    Likes Received:
    20
    Neighbours router is 192.168.2.1, loft PC is assigned 192.168.2.2.

    Loft pc LAN card given static IP of 192.168.100.2 no default gateway.

    My router I changed to 192.168.100.1 with IP range of 100 - 200 on the end.

    Loft PC see the internet via neighbours wifi, but cant see my network. (it sees itself though) yes all on same workgroup...

    My rig connects to the internet via my router but cant see or ping the static IP on the loft PCs lan card. (card and cable works fine btw). Yes reboots have been done.

    Now what?
     
  7. Zoon

    Zoon Hunting Wabbits since the 80s

    Joined:
    12 Mar 2001
    Posts:
    5,707
    Likes Received:
    723
    Can your loft PC ping your router?

    If that cannot, then there's something else wrong there.

    If it can, you need to fiddle with your firewall settings :)
     
  8. Mr Meltdown

    Mr Meltdown Minimodder

    Joined:
    26 Jul 2003
    Posts:
    804
    Likes Received:
    20
    Nope cant ping my router from the loft pc and firewall is OFF on both machines (just to be sure)...

    Im sorry but i really dont see why it would work anyway unless im missing something?

    Connections are:

    Loft PC: PCI wireless to neighbours router, LAN to my switch. (by setiing LAN IP on Auto assign i connect to MY network and internet, it works)

    My rig: My router to LAN port (wired). 2nd PCI LAN card to my switch.

    Cheers
     
  9. Zoon

    Zoon Hunting Wabbits since the 80s

    Joined:
    12 Mar 2001
    Posts:
    5,707
    Likes Received:
    723
    There's no reason if by setting your IP address and Subnet Mask manually that your loft PC wouldn't talk to your router.

    Are you setting your subnet mask to 255.255.255.0 on the wired NIC?

    What you should have is:

    --internet--
    Neighbour
    --wifi--
    Loft PC
    --wire--
    Router --wire-- Your_PC
    --internet--

    A default gateway only comes into play when you are leaving the subnet. As 192.168.100.1 and 192.168.100.2 - with a subnet mask of 255.255.255.0 - are on the same subnet, there is no reason they shouldn't be able to ping.
     
  10. Mr Meltdown

    Mr Meltdown Minimodder

    Joined:
    26 Jul 2003
    Posts:
    804
    Likes Received:
    20
    Yes manual entries are on 255.255.255.0 subnet mask.

    OK My main rig has internet connection sharing going on so the NIC into the switch has the default IP for that of 192.168.0.1 so that anything connected to the switch can use my internet connection. Is that the problem?

    Here it is again then:

    My PC:

    NIC1 into my router, auto assigned. (192.168.100.100) default gateway = NIC2 IP
    NIC2 into my switch, internet connection shared (192.168.0.1)

    My Router: 192.168.100.1 (range .100 - .200)

    Loft PC:

    WIFI NIC Auto assigned 192.168.2.2 from neighbours router
    NIC2 Static IP 192.168.100.2 (no gateway) wired into my switch.

    Same subnet 255.255.255.0

    Technically i dont need internet connection sharing as my 360 is wired into the back of my router and the laptop uses wifi... but other pcs, testing OS's etc go thru my switch and need internet, but i could wire that into the back of my router if needs be...
     
  11. Zoon

    Zoon Hunting Wabbits since the 80s

    Joined:
    12 Mar 2001
    Posts:
    5,707
    Likes Received:
    723
    Yeah, basically that's the problem. When using ICS you HAVE to accept DHCP. It just doesn't seem to work otherwise. At least, I've found this to be true historically.

    Your Xbox, PC and Loft PC's wired NIC, should all be wired into your router - even if it needs to go through your switch first.

    With a router, you should ideally avoid ICS like the plague. Its never been a good solution to anything :)

    You should end up with something like this - physically cable your Loft PC into your router instead and kill ICS.

    Router 192.168.100.1
    --wired or wireless--
    Loft PC (static IP .2 no d/g), Your_PC (auto, only one NIC needed), Xbox (auto), etc
    --wifi--
    Neighbour 192.168.2.x

    What you've currently got is this:

    Router 192.168.100.1
    --wire-- (outside NIC)
    Your_PC running ICS 100.x on the outside, 0.x on the inside
    --wire-- (inside NIC)
    Switch 192.168.0.x
    --wire--
    Loft PC trying to use 192.168.100.2 but can't because thats on the other side of Your_PC.
     
  12. Mr Meltdown

    Mr Meltdown Minimodder

    Joined:
    26 Jul 2003
    Posts:
    804
    Likes Received:
    20
    OK last problem i think....

    Got the PCs seeing each other and pinging etc :)

    Connections:

    My Rig, LAN into SWITCH, (no 2nd LAN)
    My Router into SWITCH,

    Loft PC, LAN into SWITCH / WIFI to neighbour Ips as above except my Rigs LAN is just the on Auto assign.

    However .......Remote desktop just asks for user name and password and then does jack **** when i enter it, no error, no incorrect details just the log in box disappears and it sits there looking at me waiting for me to press connect and enter it all again ....repeat ad nausium.

    Confused dot com i am. Once thats fixed im a happy camper as that is kind of the whole key to this exercise to operate the 2nd connection from my main Rig.

    Thanks for your kind help and patience :D

    Cheers
     
  13. Zoon

    Zoon Hunting Wabbits since the 80s

    Joined:
    12 Mar 2001
    Posts:
    5,707
    Likes Received:
    723
    Check event viewer on your loft PC and check for any error messages?

    Try doing it in the reverse direction?

    If that doesn't work, grab Wireshark and monitor the traffic from you to the loft PC, and check you're getting packet replies. Lemme know if you need help on that.

    And as for giving the help - you're very welcome :D I like designing and building networking solutions (its my current job) so I enjoyed it!! If you feel so inclined the rep button is that a way <-- ;)
     
  14. Mr Meltdown

    Mr Meltdown Minimodder

    Joined:
    26 Jul 2003
    Posts:
    804
    Likes Received:
    20
    Looks like an issue with dotnet 3.5SP1, uninstalled.... reboots makes no difference though... will try your suggestions or else just use a different client type software, Ive turned the loft pc off now in disgust :)

    Cheers
     
  15. Zoon

    Zoon Hunting Wabbits since the 80s

    Joined:
    12 Mar 2001
    Posts:
    5,707
    Likes Received:
    723
    VNC would do the trick mate, or you could use Logmein.com's free service, with the added benefit that anywhere on the interwebs you can get in and control your Loft PC :)
     
  16. MarkW7

    MarkW7 Total Noob

    Joined:
    30 Nov 2008
    Posts:
    1,795
    Likes Received:
    32
    OK, i think i get what you mean - i have drew a picture to make it easier :)

    [​IMG]

    The concept:


    1. You only want the Loft PC to be able to access your neighbours wifi?
    2. You also want the Loft PC to be on your broadband
    3. You want your main rig and any other PCs you may have to be on your broadband.
    4. You want your rig and the loft PC to be able to talk.

    The above picture should allow you to do this :)
     

Share This Page