1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FahCore21 entry point not found

Discussion in 'bit-tech Folding Team' started by desertbaker, 4 Aug 2015.

  1. desertbaker

    desertbaker Steady Eddie

    Joined:
    21 Sep 2013
    Posts:
    83
    Likes Received:
    11
    Any ideas?

    I am receiving the following message on a very regular basic:

    The procedure entry point clRetainDevice could not be located in the dynamic link library OpenCl.dll

    I had a quick look at the folding forum at Stanford and the answer may well be in a membership only beta forum and to do with Nvidia drivers and a minimum requirement. I am not a member of that forum and wondered if anyone here had access so I can sort it out?

    The GPU is a 970 with NV 347.88 drivers and with 'client type betas' option - I have removed this option for the moment.

    Thanks in the meantime for any help or just background information
     
  2. Scorpuk

    Scorpuk Minimodder

    Joined:
    10 Jan 2012
    Posts:
    724
    Likes Received:
    9
  3. desertbaker

    desertbaker Steady Eddie

    Joined:
    21 Sep 2013
    Posts:
    83
    Likes Received:
    11
    Scorpuk

    I'm using win 7 64 bit and will leave the win 10 for several months for the inevitable snags to be sorted.

    Just had a look at my system and the GPU had finished it's last assignment and the dreaded box was there in the middle of the screen. clicked it and it cleared but reappeared several times until a core 17 had been allocated. ppd are suffering n the meantime.

    Thanks for the links, I'll do some more investigation today and perhaps put a message on the Stanford board as I am not now a beta user. I'll also go back to an older NV driver and see if that makes a difference.
     
  4. desertbaker

    desertbaker Steady Eddie

    Joined:
    21 Sep 2013
    Posts:
    83
    Likes Received:
    11
    These are the log entries:

    06:50:26:WU04:FS00:Starting
    06:50:26:WU04:FS00:Running FahCore: "C:\Program Files (x86)\FAHClient/FAHCoreWrapper.exe" C:/Users/Malcolm/AppData/Roaming/FAHClient/cores/web.stanford.edu/~pande/Win32/AMD64/NVIDIA/Fermi/beta/Core_21.fah/FahCore_21.exe -dir 04 -suffix 01 -version 704 -lifeline 4252 -checkpoint 15 -gpu 0 -gpu-vendor nvidia
    06:50:26:WU04:FS00:Started FahCore on PID 10092
    06:50:27:WU04:FS00:Core PID:6316
    06:50:27:WU04:FS00:FahCore 0x21 started
    06:50:29:WARNING:WU04:FS00:FahCore returned an unknown error code which probably indicates that it crashed
    06:50:29:WARNING:WU04:FS00:FahCore returned: UNKNOWN_ENUM (-1073741511 = 0xc0000139)
    06:50:29:WARNING:WU04:FS00:Too many errors, failing
     
  5. Scorpuk

    Scorpuk Minimodder

    Joined:
    10 Jan 2012
    Posts:
    724
    Likes Received:
    9
    What version of windows are you using and 32bit or 64bit?
     
  6. DocJonz

    DocJonz Another CPC refugee .....

    Joined:
    24 Apr 2009
    Posts:
    1,146
    Likes Received:
    64
    As you noticed, it's related specifically to Core 21 - delete the core from your folder, and also stick with the beta flag off, and restart the client.
     
  7. desertbaker

    desertbaker Steady Eddie

    Joined:
    21 Sep 2013
    Posts:
    83
    Likes Received:
    11
    Apologies for the lack of information - been away for a few days working.

    I changed the driver and ensured the beta flag was removed before I went away and all seems to have worked well. Thanks for the help and advice. Any idea on how to get the core-21's working?
     
  8. DocJonz

    DocJonz Another CPC refugee .....

    Joined:
    24 Apr 2009
    Posts:
    1,146
    Likes Received:
    64
    Best bet is to wait till it's gone to full release, as it's a Beta-only Core at the moment and therefore can be prone to failure till the code is smoothed out.
     

Share This Page