1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Peripherals Fanatec pedal problem.

Discussion in 'Hardware' started by b1g-d0g, 21 Sep 2020.

  1. b1g-d0g

    b1g-d0g Well-Known Member

    Joined:
    30 Sep 2001
    Posts:
    2,659
    Likes Received:
    77
    I feel really sorry for my daughter she love playing F1 and had a few wheel pedal set go on her so she saved up and bought a decent set that cost her over £800 from Fanatec,now she got a problem with her CSL Elite pedals not working at all,thought it was the rj12 cable from the pedal to Base,replaced it today and still no output.
    I have also updated the firmware on the Base as it was out of date and when the screen came up to configure the wheel that worked find but nothing happened when both pedals where pressed and contact from Fanatec is very slow.
    Forgot to say she is on xbox 1s
     
  2. Sentinel-R1

    Sentinel-R1 Chaircrew

    Joined:
    13 Oct 2010
    Posts:
    2,095
    Likes Received:
    253
    Maybe @true_gamer can have some input on this? I seem to recall he went down the Fanatec route.
     
  3. Guest-44432

    Guest-44432 Guest

    Yeah, I had Fanatec, but it was the Clubsport range. The high end V3 Pedals uses Hall sensors on the clutch and throttle, as well as a load cell for the brake. So they will last a long time.
    The CSL range is Fanatec's budget range, so depending on how old they are, you could get a replacement under warranty.
    If out of warranty, then you can pick up the CSL Brake and Throttle pedals for €99 https://fanatec.com/eu-en/pedals/csl-elite-pedals
     
  4. b1g-d0g

    b1g-d0g Well-Known Member

    Joined:
    30 Sep 2001
    Posts:
    2,659
    Likes Received:
    77
    It's under warranty so no problem there thanks for the imfomation she's in contact with support now but they seem to be dragging their heels a bit.
     
  5. b1g-d0g

    b1g-d0g Well-Known Member

    Joined:
    30 Sep 2001
    Posts:
    2,659
    Likes Received:
    77
    Just thought I would update the thread, my daughter got her rma for the pedals and sent them off they tested and we're working so they asked her for the Base unit and that was the problem in the end but they also changed the control box on the pedal's.
    At last he's happy again took a while but it's down to covid I think that's why they took so long getting this sorted.
    Thanks for your help on this .
     
    Bloody_Pete and enbydee like this.
  6. Guest-44432

    Guest-44432 Guest

    Awesome news. :)
     
  7. b1g-d0g

    b1g-d0g Well-Known Member

    Joined:
    30 Sep 2001
    Posts:
    2,659
    Likes Received:
    77
    Well same problem yet once more rma time again.
     

Share This Page