1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Displays Fuzzy colour's on my laptop

Discussion in 'Tech Support' started by The Monk, 4 May 2011.

  1. The Monk

    The Monk Minimodder

    Joined:
    15 Dec 2010
    Posts:
    254
    Likes Received:
    9
    Hello there I've been meaning to post this on here for a while but have only just got round to it. Just interested to see if anyone knows what causes it/what exactly is wrong and if they know how to fix it.

    Basically my screen shows messed up colours on my laptop :waah:.

    I have had this problem on and off for several years now and I can guarantee it is not a software problem as I have done several re-installs of windows and the problem persists.
    The laptop isn't the greatest spec in the world I know, but for general web browsing and a bit of office work there isn't anything wrong with it and don't want to have to spend several hundred pounds getting a new laptop.

    Things I've tried:
    • I have tried updating the graphics drivers however can't find any to update too, although I'm fairly certain its hardware based.
    • I have tried changing the inverter board, didn't change anything.

    • I have tried pushing all connections in and it doesn't change anything. Even removed the plastic shroud around the screen and pushed all those connections in and it still no luck.

    • I have probably tried some other things but can't remember at the mo.

    The laptop outputs correctly onto an external monitor so I reckon the GPU is OK?

    Sometimes it will display correctly for a while, could be a few minutes or could be a few weeks.

    Laptop spec:
    Toshiba Satellite M100-165
    Intel T2300 1.66Ghz Centrino Duo
    1.5GB Ram
    14.1 inch screen at 1280 * 800
    ATI Mobility Radeon X1400
    80GB HDD
    Windows XP SP 3

    Pics of the offending machine

    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]


    If you have any ideas then post away even if its completely wrong as I'm stumped :wallbash:

    Thanks in advance :thumb:
     
  2. RichCreedy

    RichCreedy Hey What Who

    Joined:
    24 Apr 2009
    Posts:
    4,699
    Likes Received:
    172
    cable or screen would be my guess
     
  3. The Monk

    The Monk Minimodder

    Joined:
    15 Dec 2010
    Posts:
    254
    Likes Received:
    9
    Hmm it is about £70 minimum for a replacement screen. But with it sometimes deciding to work properly I think it could be the cable? It does

    I have removed the bezel from around the screen and reconnected the video cable connections with no improvement.

    Looking on the video cable connection there is a product code "DC020007K00". Am unable to find a supplier in the UK for this cable however and have never really trusted international sellers. :wallbash:
     
  4. RichCreedy

    RichCreedy Hey What Who

    Joined:
    24 Apr 2009
    Posts:
    4,699
    Likes Received:
    172
    found this on ebay, it's from hong kong, but fairly cheap, so not a worry
     
  5. The Monk

    The Monk Minimodder

    Joined:
    15 Dec 2010
    Posts:
    254
    Likes Received:
    9
    Ordered one of them was £16 so no great loss if it doesn't work. Thanks for your help, will leave a message when I get the new one in. Hopefully it works...
     
  6. kenco_uk

    kenco_uk I unsuccessfully then tried again

    Joined:
    28 Nov 2003
    Posts:
    9,696
    Likes Received:
    308
    I think you've pretty much pinned it down. It's hopefully the cable or the connector on the back of the screen.
     

Share This Page