1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Watercooling GTX 580 + Swiftech MCW60

Discussion in 'Hardware' started by Zurechial, 9 Apr 2011.

  1. Zurechial

    Zurechial Elitist

    Joined:
    21 Mar 2007
    Posts:
    2,045
    Likes Received:
    99
    I've been searching for a few weeks in an attempt to find clear and decisive results from using a Swiftech MCW60 block on a GTX 580, but my Google Fu hasn't turned up much. Instead, I got lots of results for other cards or the MCW80.

    I went through the same process with my GTX 275, as I like to re-use waterblocks as much as possible, rather than dropping €75 on a new block for every new card I get; and the MCW60 worked out great on my GTS512 and GTX275, so I was eager to try it again with my new card.

    In the end I decided to take the plunge and try fitting my MCW60 to my EVGA GTX 580 SC myself using the G80 holdown bracket.
    I'm posting the results so far here so that someone else wondering the same might find this through Google or whatever.
    No pics this time.

    So far, so good - Temps dropped from 89C at load to ~54C; Idle temps dropped by roughly the same amount.
    I left the stock board-plate and fan assembly in-place to provide cooling for the PCB, memory and power components; meaning I only needed to remove 10 screws, the plastic shroud and the main heatsink unit from the card.

    For those wondering about the lack of contact observed with MCW80 blocks on the GTX580 due to the raised screw holes on the board-plate; it doesn't seem to affect the MCW60's contact at all, due to the raised portion of the block contact-plate reaching the GPU heatspreader just fine.
    I was a little worried that the raised portion is too small to make enough surface contact with the heatspreader, but it seems fine so far and hopefully it'll remain okay in the long-term.

    Using a fan speed/temperature curve I set the fan to remain at 40% until 70C, after which point it ramps up to 100% at 100C; but I did that more as a safety precaution and as an indicator of something going seriously wrong (since the noise of a GTX 580 fan at full whack is as loud as any BIOS alarm :hehe:) than out of necessity.
    I haven't tried running the card in this arrangement with the fan unplugged as the overall airflow through my case is quite low and the fan is fairly quiet at 40%.
    I might flash the card with EVGA's fan-unlocked BIOS to get the fan down to 30% as I really can't see the PCB getting too hot when idling anyway.

    Hope this helps someone else!
     
  2. brave758

    brave758 New Member

    Joined:
    16 Apr 2009
    Posts:
    1,142
    Likes Received:
    29
    Got any pics mate sounds great
     
  3. Zurechial

    Zurechial Elitist

    Joined:
    21 Mar 2007
    Posts:
    2,045
    Likes Received:
    99
    I didn't take any pics while I was attaching the block as I was doing so with the block already attached to the loop from my previous card out of laziness and it almost took 3 hands just to do that. :p
    Here are some phone-camera shots of the system installed:

    [​IMG]
    [​IMG]

    I used the MCW60's long screws from the ATI mounting kit and some springs to cushion the mount. It's not ideal, nor does it look good - But it works.
    Also visible is the 'warranty void if removed' sticker that EVGA places on the card but without covering any of the screws. Strange, but I guess it fits with their policy of allowing HSF-changes.
    [​IMG]
     
  4. DieselPower

    DieselPower Member

    Joined:
    9 Apr 2011
    Posts:
    34
    Likes Received:
    1
    Looks complicated dude, but as long as it works it's all good.
     
  5. llamafur

    llamafur WaterCooled fool

    Joined:
    27 Jul 2009
    Posts:
    859
    Likes Received:
    21
    They allow you to change the heatsink without voiding the warranty. EVGA is my favorite brand for this reason.
     

Share This Page