1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Windows Have to run games twice to make them open

Discussion in 'Tech Support' started by Draksis, 9 Mar 2011.

  1. Draksis

    Draksis New Member

    Joined:
    21 Oct 2009
    Posts:
    1,235
    Likes Received:
    50
    Been trying to figure this one out for a long while now. Didn't find anything on bit-tech, and only found one other forum where someone had ask about this:

    Everytime I want to run an older game on my PC, I need to run it once, wait for about 5 seconds then run it again. The first time doesn't fail, or through an error - it just doesn't open. If I open Task Manager, I can see it working but nothing else.

    Now when I say old games, I mean Oblivion does it (through vanilla launcher, mod manager, or OBSE), but fallout 3 is fine, or any newer game (Fallout NV, C&C 3, Dead Space 1)

    my specs are:
    Windows & 64-bit(ultimate)
    I7 - 950
    Corsair Dominator 6GB
    Geforce GTS 250 1GB

    Has anyone heard anything like this, or know of a cause? At least the games are older, so strain on the system is not soooo bad (yes, the first run consumes similar resources to the second run of the game)

    My HDDs are not failing, have defragged, uninstalled, reinstalled the games, graphics drivers, etc. Basically - already done all the standard 'go to' changes/fixes

    Thanks to all for any help! :thumb:
     
  2. Nicho133

    Nicho133 New Member

    Joined:
    22 Feb 2005
    Posts:
    160
    Likes Received:
    0
    Find the .exe file for the game and right click, select Properties, and click the Compatibility tab, and then tick Disable Desktop Composition. (That disables the Aero interface while playing the game) also play around with the other compatibility mode settings. You never know it might fix the problem.
     
  3. Deders

    Deders Well-Known Member

    Joined:
    14 Nov 2010
    Posts:
    4,053
    Likes Received:
    106
    How long was it since you freshly installed windows?
     
  4. Draksis

    Draksis New Member

    Joined:
    21 Oct 2009
    Posts:
    1,235
    Likes Received:
    50
    Some of the really old games (Dungeon Kepper 2) I anyway have to play around with those settings, and I haven't seen the issue fixed. It might be more of a per game issue. I'll play around with those settings for Oblivion as see where I get - Thanks

    It was been some time since I did, truth be told - though I see how this would be a Windows issue? Newer games work fine. Wouldn't a Windows glitch affect all games? worth a look in that directions though - Thanks
     
  5. Deders

    Deders Well-Known Member

    Joined:
    14 Nov 2010
    Posts:
    4,053
    Likes Received:
    106
    Could be a recent update affecting older directx games? Or even a seperate program that intercepts files as they run like antivirus.

    I've had to do this a couple of times myself but the symptoms never stuck for long. As far as I know I don't have any issues at the moment, but I'm mostly playing newer games.
     
  6. BentAnat

    BentAnat Software Dev

    Joined:
    26 Jun 2008
    Posts:
    7,231
    Likes Received:
    219
    download and installt he latest DirectX runtimes, Graphics and audio drivers, etc.

    I believe if this is with older games only, this (my logic at least says so) points to DirectX as a potential point of failure...
     
  7. IvanIvanovich

    IvanIvanovich будет глотать вашу душу.

    Joined:
    31 Aug 2008
    Posts:
    4,870
    Likes Received:
    252
    probably just need to run them as administrator and or xp compatibility mode. i find that to be the case with the majority of pre 2007 games.
     
  8. Varun Mashru

    Varun Mashru New Member

    Joined:
    8 Jul 2012
    Posts:
    1
    Likes Received:
    0
    Its because the system file "rundll32.exe" runs for the first time you open it....along with an instance of the game which doesnt open and just simply modifies the system environment (as in disabling aero effects and stuff) ......

    And then for the next you run the game....it will open successfully....

    So to avoid this glitch you can try the above mentioned solutions....

    But if this doesnt work you can just simply close the process "rundll32" from the taskmanager......:)
     

Share This Page