1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Windows having problems installing latest Nvidia Graphics driver

Discussion in 'Software' started by Whitlog, 4 Jan 2005.

  1. Whitlog

    Whitlog What's a Dremel?

    Joined:
    26 Jul 2004
    Posts:
    82
    Likes Received:
    0
    i was having problems with Rome total war and HL2 on my New Pc which had worked fine on my old Pc,so i gave the games tech support a ring to get help.

    they said that getting the latest driver for my graphics card would probaly help(my card is a geforce 6800 GT). the driver i had was 6.14.0 and dated from 15/11/04.so they said i should save and Download the 66.93 version and then go to add/remove programs and remove the nvidia disply driver then reboot and install the new driver.

    i did all this and as soon as i did i went to control pannel and put the disply back to 1024 by 768 pixels and then i though i would check the directX diagnostic tools to seee that the new driver had been installed,but a older version is installed dating from 29/10/04.

    so could anyone help me with this please? :wallbash:
     
  2. kergareth

    kergareth What's a Dremel?

    Joined:
    6 Jul 2004
    Posts:
    366
    Likes Received:
    0
    Try reinstalling. if this doesnt work either you got an older download, or go get a beta driver.
    Clicky
     
  3. Whitlog

    Whitlog What's a Dremel?

    Joined:
    26 Jul 2004
    Posts:
    82
    Likes Received:
    0
    ok thanks for that link,i downloaded that driver and it has updated my Driver to version 6.14.0/ date:15/11/04 which is a further on one from the last one i had.

    but for some reason when i try to install the latest one from the website,66.93. it keeps taking it back to the older one which is dated 29/10/04

    i deleted the driver i saved and downloaded to my desktop and saved and downloaded it again to make sure i had the right one but it still keeps installing a older drive and not the 66.93 i should have.
     
  4. ShogunLord

    ShogunLord What's a Dremel?

    Joined:
    5 Jan 2005
    Posts:
    1
    Likes Received:
    0
    nVidea Problems...

    I had the same problem when installing Albatron 5750 PCI Express ( nVidea ) card....

    This is what I had to do...
    1st Get a good reg cleaner installed... I use TuneUp Utilities 2004.
    2nd Copy all files from installation Cd into a Temp Dir, unpack any that need it, into their own folders..
    3rd Thru Contol Panel, to Hardware, highlight and click to remove card...dont reboot yet...
    4th Uninstall any drivers for the Grafx Card.. Dont Reboot yet...
    5th Run your RegCleaner ( TuneUp Utils takes Care of everything )

    6th Reboot now...when XP tells you, new hardware found, tell it to look into temp folder you unpacked CD files too.

    This is what worked for me..I dont gaurantee it will for you..but I`m 99% certain it will..

    Regards
     
Tags:

Share This Page