1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Networks Internet access always requires a restart?

Discussion in 'Tech Support' started by Xonar, 29 Sep 2010.

  1. Xonar

    Xonar New Member

    Joined:
    2 Nov 2009
    Posts:
    676
    Likes Received:
    33
    Hi guys,

    Basically, I've had this problem for just over a week now and I was hoping it might just fix itself but it seems to be persisting no matter what I do.

    The problem is, whenever I boot up my computer for the first time on any given day I can never connect to the internet via my network cable which is plugged directly into my router, I always get the little red cross over my network connection and 'No internet access'.

    However as soon as I restart the internet seems to magically begin working again as it normally would have, what could be the problem?

    I have tried -

    - Changing network cables
    - Changing routers
    - Uninstalling both controllers and letting windows automatically install them again.
    - Making sure the controllers are enabled fully in the BIOS

    I have no idea what could be wrong so any info or ideas on what to try to remedy it would be greatly appreciated.
     
  2. Phalanx

    Phalanx Needs more dragons and stuff.

    Joined:
    28 Apr 2010
    Posts:
    3,712
    Likes Received:
    156
    Xonar, when you boot up and get the red cross, does your PC have an IP address from the router at all or is it APIPA-based (autoassigned by Windows)?

    The only thing you've not tried are two I can see:

    1. Check for newer drivers for the network interface.
    2. Try another network interface (PCI-E card, perhaps).

    If your computer doesn't have an IP from the router, then it must be something from the hardware side of things. Does it only occur when the machine is booted from a shutdown state? You mention you restart and it works, but this means the NIC has power through the whole thing.

    Try doing it, getting the error, then shut down and boot up from the start again. Does it happen again?
     
  3. Xonar

    Xonar New Member

    Joined:
    2 Nov 2009
    Posts:
    676
    Likes Received:
    33
    Hi mate, thanks for getting back to me.

    I'm sure my IP-address is auto assigned.

    The troubleshooting link in windows tells me the drivers need updated but when I go to do it I just get a message saying the latest drivers are up to date, I'll have a look on the MSI website and see if I can update them there.

    Ye it's booted from a completely shutdown state when it refuses to work. I'll try shutting down fully and trying again later tonight after work and let you know if I've come further on with it.

    Thanks again dude, I appreciate the advice.
     
  4. Phalanx

    Phalanx Needs more dragons and stuff.

    Joined:
    28 Apr 2010
    Posts:
    3,712
    Likes Received:
    156
    If the NIC is built-in to the motherboard, then yes you go to the board manufacturer's site and find the webpage for the board you have. There should be a drivers section to get the drivers for specific parts. It might also be an all-in-one file with all the mobo drivers included.

    Update the drivers and give it another try.
     
  5. J05H11E

    J05H11E Fujitsu Technical Analyst

    Joined:
    5 Aug 2010
    Posts:
    61
    Likes Received:
    2
    APIPA address will start *169.254...

    Could possibly be an issue with DHCP or static IPs (depending on how your router is set up)

    Do an ipconfig (run>CMD> ipconfig /all

    and post the results


    Josh
     
  6. Xonar

    Xonar New Member

    Joined:
    2 Nov 2009
    Posts:
    676
    Likes Received:
    33
    Ok, I tried doing a full shutdown and booting back up again and I had the same problem.

    I downloaded the latest Gigabit PCI-E driver for my network controller which has changed the troubleshooting result from 'Update driver' to 'Check cables etc' which obviosuly isn't the case as they work fine after a restart.

    JO5H11E, I ran ipconfig and here is what I got back, I ran it whilst the internet was working ok, if you need it to be run whilst the internet isn't connecting let me know.

    Cheers guys.

    [​IMG]
     
  7. Phalanx

    Phalanx Needs more dragons and stuff.

    Joined:
    28 Apr 2010
    Posts:
    3,712
    Likes Received:
    156
    Xonar, can you put up the following command's details please?

    Code:
    ipconfig /all
    Can you paste a copy of the command results when you HAVE internet access and when you DON'T have access.

    Also, do you have any other machines on the network, and do they have the same issue?
     
  8. Xonar

    Xonar New Member

    Joined:
    2 Nov 2009
    Posts:
    676
    Likes Received:
    33
    Hi mate, That's the result of the /ipconfig all command posted above, I'll come back with the non-working one in a sec.

    I have my flatmates laptop and 360 and 3 mobile phone which are all run off the network wirelessly and these have had no issues whatsoever, the router stays on 24/7 and I've never been disconnected from any of these devices.
     
  9. Xonar

    Xonar New Member

    Joined:
    2 Nov 2009
    Posts:
    676
    Likes Received:
    33
    Here's the Ipconfig /all for when I'm disconnected.

    [​IMG]
     
  10. Phalanx

    Phalanx Needs more dragons and stuff.

    Joined:
    28 Apr 2010
    Posts:
    3,712
    Likes Received:
    156
    From what I can see, the adapter is actually moving itself to a new LAN allocation, which could make the PC think it is missing when you're disconnected, as if the hardware wasn't even detected in the first place.

    This would lead me to think it's either a driver issue or a fault with the hardware. The fact it never works from a cold boot (read: From Power-off state) but does work from a reboot makes me lean towards the hardware.

    Have you tried a PCI NIC? Another option would be to update the BIOS to the latest version to see if this is addressed in a more recent version.

    Also, those tunneling adapters, are you using something like VMWare or similar? Could it be the problem started when you installed that?
     
    thehippoz likes this.
  11. Xonar

    Xonar New Member

    Joined:
    2 Nov 2009
    Posts:
    676
    Likes Received:
    33
    Hi again, I'm starting to think it's a hardware problem myself, same problem occurred this morning from cold boot so I clicked the troubleshooting tab again and it asked me to update drivers so I opened up the latest ones I downloaded and it simply said the Network controller could not be found.

    I Haven't tried a PCI NIC but I'll definitely update the BIOS later and see if that fixes the issue.

    As for the tunneling adapters, I couldn't even tell you what those were I wouldn't know how to use VMware or anything like that so I haven't a clue.
     
  12. Phalanx

    Phalanx Needs more dragons and stuff.

    Joined:
    28 Apr 2010
    Posts:
    3,712
    Likes Received:
    156
    Give the BIOS update a go if you're OK with doing that. After that, it might be worth getting hold of a PCI NIC and seeing if the problem persists.
     
  13. RichCreedy

    RichCreedy Hey What Who

    Joined:
    24 Apr 2009
    Posts:
    4,699
    Likes Received:
    172
    i was going to suggest a hardware issue, and to try a pci card, ph4lanx beat me to it
     
  14. AstralWanderer

    AstralWanderer New Member

    Joined:
    17 Apr 2009
    Posts:
    749
    Likes Received:
    34
    Xonar,

    Your (working) IPConfig printout suggests that you have 2 Gigabit Ethernet connections, with only the second one being listed in the non-working config. If you actually do have 2 connections on your PC, have you tried moving your cable to the second one? (I believe Ph4lanx suggested this above).

    Another thing to try would be to uninstall the problematic network card in Device Manager (right-click on it and select uninstall) and restart Windows - it should be detected and the drivers re-installed which should fix any driver-related problems (third-party software like some firewalls may add their own minidrivers which could result in compatibility issues).
     
  15. Xonar

    Xonar New Member

    Joined:
    2 Nov 2009
    Posts:
    676
    Likes Received:
    33
    Hi Astral, That's right I have 2 ethernet connections on my mobo. Switching the cable was one of the first things I did, I also tried uninstalling both of them under device manager and I let windows automatically re-install however I may try that again and specify the correct drivers I got from the MSI website and see if that fixes it.

    If not i'll attempt a BIOS update and see how it goes.

    Thanks for the suggestions guys.
     
  16. AstralWanderer

    AstralWanderer New Member

    Joined:
    17 Apr 2009
    Posts:
    749
    Likes Received:
    34
    If the problem persists, try the following:
    • Ping your router address (192.168.1.254 from your screenshot) and see what error message you get;
    • Try to force an IP address lease renewal with the commands ipconfig /release followed by ipconfig /renew. Take note of any error messages;
    • The auto-tuning feature in Vista/7 may cause problems with some routers - use netsh interface tcp show global to check its current level (normal by default) and try netsh interface tcp set global autotuninglevel=disabled to switch it off (repeat that statement, changing the last part to the value shown previously to undo this change if it doesn't help).
     
  17. Votick

    Votick My CPU's hot but my core runs cold.

    Joined:
    21 May 2009
    Posts:
    2,233
    Likes Received:
    76
    I used to have this issue with my Mobo. (ASROCK)
    When I was on Vista.

    When I upgraded to Win 7 I haven't had the problem since :/
     
  18. Xonar

    Xonar New Member

    Joined:
    2 Nov 2009
    Posts:
    676
    Likes Received:
    33
    Just thought I'd update, I have tried re-installing software again with no luck and applied the latest BIOS from MSI and I'm still getting the same issue.

    I'm almost positive it's a hardware issue and not a problem with the router or line.

    When I boot up the light's on both my network controller are off at all times where as after I've restarted whichever one has the network cable plugged in will be flicking away the whole way through boot up.

    I just can't understand why it wouldn't be waking up with the first boot then have no problems after that?

    EDIT: Just tried to recreate the problem there and he light's do actually flash on the network controllers however they don't show up under device manager which I can probably guarantee is the reason why I'm not getting net access.
     
    Last edited: 2 Oct 2010
  19. MarkW7

    MarkW7 Total Noob

    Joined:
    30 Nov 2008
    Posts:
    1,795
    Likes Received:
    32
    I've not used Windows in a while but from what i can see there, the (Preferred) next to your IP means it's using or looking for a static signed IP.

    What happens when you flush your connection.

    start > run > cmd:

    ipconfig /flushdns
    ipconfig /release *Con*
    ipconfig /renew

    :)
     
  20. Chicken76

    Chicken76 Active Member

    Joined:
    10 Nov 2009
    Posts:
    943
    Likes Received:
    31
    The red cross on a network interface means no ethernet link. If there were an IP problem (couldn't obtain one from the DHCP server) you would get "the lemon" (the exclamation mark in a yellow triangle).
    Try the following:
    After booting windows, open the network thingy from control panel (MS naming schemes are so ... sophisticated let's say, that I gave up remembering how things are called a long time ago), the one that lists all your network interfaces, which will probably show:
    Local area connection
    Local area connection #2
    both with a red cross, although you have a cable connected to one of them.

    First check the network connectors on the back of your PC. The one that has a cable plugged in should have the link LED lit (if the interface has one, but most do nowadays).
    Then check on the router the status of the port your PC is connected to. Is it up?
    Probably the answer to both questions is no.

    Unplug the cable, and plug it again after a few seconds. Check the status of the link-indicating leds. If they come up this time, since you checked the ethernet patch cord already, then there's a link negotiation problem. Try setting the link speed from "automatic_detection/auto_negotiated/whatever_it's_called" to 100 mbps full duplex (probably you don't have a gigabit router, and even if you do, the 100 mb link should be more stable).

    Remember, sometimes Windows doesn't update the icons of network interfaces when their status changes. If the link goes up after reconnecting you may have to refresh the Network blabla window that you opened from Control Panel (hit F5 or right click in that window and click "refresh") to see the change.

    Let us know what the result is.
     
    Last edited: 3 Oct 2010

Share This Page