1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Windows KotOR II on Steam on WIN10, graphics issues

Discussion in 'Gaming' started by Xir, 7 Jul 2020.

  1. Xir

    Xir Well-Known Member

    Joined:
    26 Apr 2006
    Posts:
    5,311
    Likes Received:
    93
    So, i've freshly installed KotOR II from my steam account.

    When the game switches from in game rendering to cut-scene movies and back, I get a black screen.
    Win-D'ing to desktop then going back in via the task bar solves this, but it means I miss the firs 10 sec of each cut scene. :rollingeyes:

    Iv'e tried:
    on the .exe in windows:
    • Setting the compatibility mode to WIN7, no luck
    • Setting the compatibility mode to WINXP SP3, no luck
    • Setting the High-DPI setting to "Program DPI", no luck
    Within the game:
    • turning all settings (AF/AA) down (or up) no luck.
    • Frame buffer effects, ditto
    • V-Sync ditto
    when changing these in game settings the screen goes black and i need to alt-tab in- and out multiple times to see anything at all. Setting then works.

    Help?
     
  2. Anfield

    Anfield Well-Known Member

    Joined:
    15 Jan 2010
    Posts:
    5,843
    Likes Received:
    592
    Are you using any mods to add widescreen support? Those can cause quite a lot of issues with cutscenes from what I remember.
     
  3. Xir

    Xir Well-Known Member

    Joined:
    26 Apr 2006
    Posts:
    5,311
    Likes Received:
    93
    no, bog standart fresh off steam, i figured this would work best.

    think I'll try the TSLRCM mod though, it seems to fix a lot of issues
     
  4. Xir

    Xir Well-Known Member

    Joined:
    26 Apr 2006
    Posts:
    5,311
    Likes Received:
    93
    Tried some different settings

    this is the only thing that really helps, means it runs in Windowed moda, showing a small bar on top of the screen, i guess that's worth it.

    1. Open the "swkotor2.ini" file (found in C:\Program Files (x86)\Steam\steamapps\common\Knights of the Old Republic II\).
    2. Under both [Graphics Options] AND [Display Options], change "Fullscreen=1" to "Fullscreen=0".
    3. After that, add the following line under just [Graphics Options]:AllowWindowedMode=1
    4. Save and close the file.*

    * Running the game from the RunGameID icon or Steam desktop shortcut will undo these changes -- so run the game with the "swkotor2.exe" file from now on (found in C:\Program Files (x86)\Steam\steamapps\common\Knights of the Old Republic II\).
     

Share This Page