1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Networks NAS running slowly on one computer

Discussion in 'Tech Support' started by wolfticket, 27 Jun 2013.

  1. wolfticket

    wolfticket Downwind from the bloodhounds

    Joined:
    19 Apr 2008
    Posts:
    3,116
    Likes Received:
    321
    For some reason accessing my NAS drive is very slow on a Windows 8 PC.

    It was fine until about a week ago, but then suddenly it dropped from ≈30MB/s to ≈100KB/s. The internet is working fine (a lot faster than it is possible to access the NAS). All other systems on the network are connecting normally through the same ethernet switch.

    I've be troubleshooting like crazy but I can seem to make any sense of it.

    I've tried:
    - Reinstalling drivers.
    - Firmware.
    - New ethernet cable
    - Plugging a different system into the same port on the switch (worked fine)
    - Connecting it directly to the router rather than the switch (still slow).
    - Connecting NAS directly to the NIC (suddenly worked at normal speed (?))
    - Running a linux live CD (still slow (??))
    - Probably some other stuff.

    As far as I can tell I've more or less ruled out settings/drivers (by finding the same problem on a different OS), but I've also kind ruled out most hardware issues (including the switch) by playing with different configurations and systems. Ahhhh! :wallbash:

    I realise the fact I've tried loads of stuff isn't exactly conducive to lots of responses, but any ideas before I throw in the towel and by a new NIC would be much appreciated.
     
  2. deathtaker27

    deathtaker27 #noob

    Joined:
    17 Apr 2010
    Posts:
    2,115
    Likes Received:
    135
    have you updated your chipset drivers?

    Disable TCP Offloading on the NIC?
     
  3. YEHBABY

    YEHBABY RIP Tel

    Joined:
    22 May 2010
    Posts:
    3,635
    Likes Received:
    1,640
    I'm not an expert, someone like Margon would know better.

    But, have you tried to see if the jumbo settings is set or another setting like 1500 etc. check nas and PC network card have the same setting.
     
  4. wolfticket

    wolfticket Downwind from the bloodhounds

    Joined:
    19 Apr 2008
    Posts:
    3,116
    Likes Received:
    321
    I tried disabling TCP Offloading, and there's no jumbo settings option in device config.

    Drivers were changed/updated, and moreover I've had the same system running linux with exactly the same issues.

    It's a pretty old system, so I figure the onboard NIC is crapping out. It's just odd that it's only one aspect of it and everything else is working fine.
     
  5. Big_malc

    Big_malc Well-Known Member

    Joined:
    7 Sep 2010
    Posts:
    1,619
    Likes Received:
    80

    MTU ??
     

Share This Page