1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HTPC New AM2 Media Centre - HDMI quality sucks at 1080p

Discussion in 'Hardware' started by JamesRC, 21 Oct 2012.

  1. JamesRC

    JamesRC Member

    Joined:
    5 Oct 2012
    Posts:
    272
    Likes Received:
    8
    I've built a new Media centre based around the new FM2 socket, it has:

    Gigabyte GA-F2A75M-D3H
    AMD 5600K FM2 (APU - 7560D GPU)
    2x4Gb Crucial Ballistix 1600

    I've hooked the HDMI up to a TV and the display output quality is awful!

    I'm trying to run the TV at full 1080p (yep it's a full HD TV!) and it looks far better at say 1600x900 (most notably text and colour reproduction).

    It makes no sense - no zooming/scaling is enabled, and the colour profile is set to full RGB.

    I've checked there is zero overscaling too and the setup works fine via HDMI to my monitor.

    Searched lots for similar issues and i've tried the fixes I've seen, any other ideas?
     
    Last edited: 21 Oct 2012
  2. rollo

    rollo Well-Known Member

    Joined:
    16 May 2008
    Posts:
    7,809
    Likes Received:
    117
    Most issues outputting to tv revolve around the text scaling and windows explorer not showing everything. All of these issues usually resolve themselves in vlc media player for example.

    Most monitors will display a better picture than a tv ( unless its a high end set that can be setup for computer output.) my old hd tv ( some no name brand from asda) struggled with text from a computer but was fine for videos or games. Brought an up to date Samsung those issues dissapeared.

    Text reproduction issues are a scaling problem. Colour is probably the tv itself most don't display as many colours as a high end monitor does.

    Does the tv support 32bit colour or is it 16 bit is the monitor 32bit as that's going to show a massive difference straight away.
     
  3. modd1uk

    modd1uk Well-Known Member

    Joined:
    4 Sep 2006
    Posts:
    3,415
    Likes Received:
    330
    Somethings not right, my HTPC/MEDIA server is the FM1 socket and 1080p films look fine.
     
  4. Tichinde

    Tichinde Active Member

    Joined:
    1 Sep 2010
    Posts:
    878
    Likes Received:
    33
    I had the same issue but it was fixed by changing a setting on the TV.

    All I had to do was set the label on the input to be a PC input and the TV set a load of settings itself :)
    A friend had to turn off overscan on the TV in order for it to fit properly and be in focus.

    What TV are you connecting to?
     
  5. JamesRC

    JamesRC Member

    Joined:
    5 Oct 2012
    Posts:
    272
    Likes Received:
    8
    Cheers for input guys.

    The TV is a Samsung UE32EH5000, new for 2012 - link below.

    http://www.amazon.co.uk/Samsung-UE3...1?s=electronics&ie=UTF8&qid=1350893958&sr=1-1

    I used the machine to watch video last night and at 1600x900 60Hz it looks good - full colour, clear text and the image fills the screen. I obviously want to run native for Blu-rays though!

    TV has 2 inputs: HDMI or HDMI/DVI and both give the same results. Even a DVI-HDMI gives the same problem, it can't be the cable.

    I seem to recall when first setting 1080p the image was too large for the screen though - can't remember if that was before I turned under/overscan off - will check tonight.
     
  6. saspro

    saspro IT monkey

    Joined:
    23 Apr 2009
    Posts:
    9,429
    Likes Received:
    268
    You need to turn the overscan down
     
  7. Cei

    Cei pew pew pew

    Joined:
    22 Mar 2008
    Posts:
    4,717
    Likes Received:
    122
    Turn all processing off in the TV menus.
     
  8. saspro

    saspro IT monkey

    Joined:
    23 Apr 2009
    Posts:
    9,429
    Likes Received:
    268
    Also try looking at creating a custom resolution.

    My TV needed a profile setup as 1920x1080 @ 59Hz for it to look correct
     
  9. sandys

    sandys Well-Known Member

    Joined:
    26 Mar 2006
    Posts:
    3,615
    Likes Received:
    213
    As has been mentioned put it in the HDMI/DVI one and label the device PC. on your TV on the sources page you will see HDMI1/DVI ------, HDMI2 -------

    That ------ is the label, you can set that to PC so it should reader HDMI1/DVI PC

    Alternatively you can have a cable issue, as the TV is likely to be the latest HDMI standard and at 1080p might require more bandwidth than your cable can handle resulting is poor quality signal, I experienced this when I moved my PS3 from my monitor to TV, TV kept getting spots etcs and blanking, new cable with 1.4 spec I had no issue.

    You may also have to set a custom res depending on driver but it would surprise me if 1080p is not supported.

    You may have another issue that I experience on my 27" 2560x1440 screen, when I use the latest Nvidia drivers for my Quadro 1440 looks like a horrid analog signal, all blurry and out of focus, no custom resolution I tried sorts that out but an old version of the driver works flawlessly so I continue to use that, not ideal but as its not a games machine it is not a problem.
     
  10. JamesRC

    JamesRC Member

    Joined:
    5 Oct 2012
    Posts:
    272
    Likes Received:
    8
    Thanks all - cracked it. Sandy's tip to "label" the input as PC sorted it - must adjust the pixel mapping to 1:1 or something similar, perfect picture now!
     

Share This Page