1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Case Mod - In Progress Project Iced Blood - Mayhems/Primochill Sponsored - COMPLETE 15/02/16

Discussion in 'Project Logs' started by stealth80, 5 Feb 2015.

  1. stealth80

    stealth80 Minimodder

    Joined:
    1 Feb 2015
    Posts:
    343
    Likes Received:
    8
    Yup and it's white to boot :naughty:

    Finally got the order in with Sharkmodz so hopefully I will have these next week:

    [​IMG]
     
  2. stealth80

    stealth80 Minimodder

    Joined:
    1 Feb 2015
    Posts:
    343
    Likes Received:
    8
    The Stealth Cable Combs arrived today, so I could finally get to work with depinning and combing these cables!

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    Think i'm done for now, until I get permission to buy/get donated another 970GTX to SLI this thing!

    Thanks for viewing
     
  3. rrmitko

    rrmitko Minimodder

    Joined:
    14 Jun 2014
    Posts:
    131
    Likes Received:
    2
    Looks complete now :thumb:
     
  4. stealth80

    stealth80 Minimodder

    Joined:
    1 Feb 2015
    Posts:
    343
    Likes Received:
    8
    Yup almost, I don't like the vast space in front of the 240mm rad, and the modder in me wants to SLI cuz can lol
     
  5. rrmitko

    rrmitko Minimodder

    Joined:
    14 Jun 2014
    Posts:
    131
    Likes Received:
    2
    Exactly :D
     
  6. stealth80

    stealth80 Minimodder

    Joined:
    1 Feb 2015
    Posts:
    343
    Likes Received:
    8
    Still thinking of some ideas to utilise that space in front of the 240mm radiator without obscuring the ICED BLOOD text, anyone got any suggestions?

    Considered a second 970 down there on a PCIE ribbon but the SLI bridge would be the stumbling block
     
  7. stealth80

    stealth80 Minimodder

    Joined:
    1 Feb 2015
    Posts:
    343
    Likes Received:
    8
    Finally got around to ordering the second 970 GTX, waterblock and Ek Terminal block, should all be here next week. As note the red pastel coolant has gone murky again, does anyone know what causes this ?
     
  8. stealth80

    stealth80 Minimodder

    Joined:
    1 Feb 2015
    Posts:
    343
    Likes Received:
    8
    Got the second card installed last week and fully flushed both loops and had a bit of a clean up:




    The EKWB FC Terminal Bridge. Took me a while to work out how the hell this would fit, got there in the end!


    [​IMG]

    [​IMG]

    [​IMG]
     
  9. stealth80

    stealth80 Minimodder

    Joined:
    1 Feb 2015
    Posts:
    343
    Likes Received:
    8
    New ram installed, some good results for 4k gaming (had some low memory crashes :huh:)








    [​IMG]








    [​IMG]








    [​IMG]








    [​IMG]







    [​IMG]
     
  10. stealth80

    stealth80 Minimodder

    Joined:
    1 Feb 2015
    Posts:
    343
    Likes Received:
    8
    Thanks to the guys over at Primochill who have kindly agreed to sponsor my venture into hard line tubing!

    [​IMG]
     
  11. stealth80

    stealth80 Minimodder

    Joined:
    1 Feb 2015
    Posts:
    343
    Likes Received:
    8
    Got shipping confirmation today, standby for some interesting/annoyed updates during my first time PETG Tubing!
     
  12. stealth80

    stealth80 Minimodder

    Joined:
    1 Feb 2015
    Posts:
    343
    Likes Received:
    8
    Hurray, Parcelforce finally picked up my shipment from UK customs, a nice little box of modding kit for this build!

    Thanks to Primochill for providing the following products:

    [​IMG]

    So 2x Flow Meters, A Rigid Bender, a whole bunch of the new Primochill RSX fittings and a whole bunch of Primochill 12/10mm PETG tubing

    [​IMG]

    Rigid Bender, seems like a nice piece of kit, used it this evening and it definitely works, good job Primochill! 

    [​IMG]

    [​IMG]

    [​IMG]

    2x Flow Meters - During the last 6 months or so my rig has been pretty damn quiet, too quiet. At times I wasn't sure if the pumps were actually running, so these should hopefully aid that issue:

    I really like the amount of different tubing configs you can use with these:

    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]

    Next up are the 2x sets of Primochill RSX rigid tubing fittings. These are very new and they seem like a massive improvement over the Monsoon fittings I was using previously

    Particularly liked the packaging!

    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]

    I eventually ended up spending around 6 hours making some progress tonight. Most of that time was actually used to strip all the radiators and tubing out and flushing all the old coolant out and cleaning the CPU/Chipset blocks.

    I made a few bends and got to grips with using the Rigid Bender, which is pretty useful!

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]
     
    Last edited: 13 Feb 2016
  13. stealth80

    stealth80 Minimodder

    Joined:
    1 Feb 2015
    Posts:
    343
    Likes Received:
    8
    Some more work done yesterday prior to a heavy night on the town!

    First piece of bending today was a pain in the ass, trying to get the bends correct for the pump outlet that drops below the partition wall and into the 240mm radiator

    [​IMG]

    [​IMG]

    [​IMG]

    Once that one was done (5 attempts later!!!)  it was pretty much plain sailing to complete the CPU loop and most of the GPU loop

    [​IMG]

    I changed the old GPU layout a little to allow for cleaner looking bends and adding the Flow Meter

    [​IMG]

    Then onto some leak checking for the CPU loop, early signs all good

    [​IMG]
     
  14. stealth80

    stealth80 Minimodder

    Joined:
    1 Feb 2015
    Posts:
    343
    Likes Received:
    8
    Finally finished the loop and did some leak checking and all seemed good ....

    Had a leak from the Parallel Terminal (only part not disturbed!) which leaked in between the 2x GPU's where I can't see ....

    Turned PC on, pc restarted twice then I switched off at mains and eventually found the issue. On the plus side both GPU's are fine as I've tested those in another rig and I've dried the motherboard out and blown it through with compressed air. Will wait till tomorrow to test the board, but fingers crossed ...
     
  15. stealth80

    stealth80 Minimodder

    Joined:
    1 Feb 2015
    Posts:
    343
    Likes Received:
    8
    Update 15/02/16

    Disaster averted, she lives!!

    So after the panic last night I figured whilst I have the loops drained I would swap all the Fittings around, aka white on red and red on white, I suspected it would look much better.


    Did all those last night and rebuilt the loops and waited until this morning to power up the PC.


    So back to leak checking!! (although I was pretty certain there were no leaks this time!)

    [​IMG]

    [​IMG]

    [​IMG]

    I left it running like that a little whilst bleeding the loops and leak checking all the fittings and especially that Parallel Terminal, had half of a toilet roll stuffed between those gpus today!!
     
  16. stealth80

    stealth80 Minimodder

    Joined:
    1 Feb 2015
    Posts:
    343
    Likes Received:
    8
    So it's now complete, it works and more good news, my RMA replacement for my Asus RoG Swift Gsync monitor shall arrive tomorrow!!





    I decided to do a little stress testing whilst finishing off the flushing and making 100% sure there is no leaks, AIDA 64 full stress test without any issues, so I guess I really did get lucky with that leak!





    I followed the AIDA64 with a run of 3dmark Firestrike on default settings, just to see what kind of scores I could get and how the temps are:





    This was the second run, I'm pretty sure I can get 1500mhz on these cards and I know the CPU does 4.9ghz. This one was ran at 1468/1856 on the cards and the CPU at 4.8ghz




    http://www.3dmark.com/fs/7571570




    Graphics score 25816, I'm plenty happy with that, more impressive were the temps:





    [​IMG]





    Next weekend I'm gonna try for 5ghz on the CPU and 1500/2000 on the cards, probably going to need a bios flash, but I will see how I feel at the time.





    Onto the final pics, thanks for reading so far!





    [​IMG]





    [​IMG]





    [​IMG]





    [​IMG]





    [​IMG]





    The RoG front base still isn't working as my man that is lengthening my loom is out of the country with work, that will be added in a couple of months





    [​IMG]





    [​IMG]





    [​IMG]
     
    Last edited: 15 Feb 2016
  17. stealth80

    stealth80 Minimodder

    Joined:
    1 Feb 2015
    Posts:
    343
    Likes Received:
    8
    I decided that (should have done this when I went SLI) the GPU's were kicking out a lot more heat than the CPU loops, so I stripped half of each loop and spent around 4 hours flushing and cleaning the 240mm rad and added it to the GPU loop, temps dropped 2 - 3C which aint too bad and now I get a foot heater whilst i'm gaming!!

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]
     
    GaryP likes this.

Share This Page