1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PSU PSU crackling

Discussion in 'Hardware' started by dipzy, 19 Jun 2014.

  1. dipzy

    dipzy Minimodder

    Joined:
    5 Jan 2013
    Posts:
    495
    Likes Received:
    53
    Hi guys,

    i have a Silverstone ST-1500 PSU. I seem to get static like crackling noise from it. It only happens when playing games.
    When playing movies or just browsing the net, all is fine

    It doesn't sound normal but can this sort of thing happen on load?

    :eeek:
     
  2. Impatience

    Impatience Minimodder

    Joined:
    6 Apr 2014
    Posts:
    1,212
    Likes Received:
    34
    I would get it RMA'd ASAP! Any static buildup in a PSU is baaad news IMO, especially since electricity can and will arc across ppcb traces if enough static is present, potentially blowing it!
     
  3. RagingMadman

    RagingMadman What's a Dremel?

    Joined:
    6 Oct 2012
    Posts:
    189
    Likes Received:
    4
    That sounds like bad mojo man.
    It's understandable you only hear it when gaming as this is when the psu would most likely be under load. I 2nd the RMA suggestion as there isn't much you can do to a PSU without voiding the warranty.
     
  4. veryevil

    veryevil Minimodder

    Joined:
    14 Aug 2005
    Posts:
    1,228
    Likes Received:
    34
    sure its not the mains cable loose round back?
     
  5. dipzy

    dipzy Minimodder

    Joined:
    5 Jan 2013
    Posts:
    495
    Likes Received:
    53
    At first i thought it was my STX sound card then i opened my case door and put my head right inside the case and heard it was the psu.

    This will be my 2nd RMA with silverstone as the first one had a terrible crackling and lighting sparks from the fan. If it does get approved then it will also be my 3rd Silverstone PSU :(

    Here's the Video in case you guys want to hear it: Link
     
  6. dipzy

    dipzy Minimodder

    Joined:
    5 Jan 2013
    Posts:
    495
    Likes Received:
    53
    Nope, i checked this, pushed all the way in PSU, not loose at all
     

Share This Page