1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Graphics Sapphire 6870 BSOD atikpmag.sys

Discussion in 'Hardware' started by hm1992, 17 Dec 2011.

  1. hm1992

    hm1992 What's a Dremel?

    Joined:
    28 May 2009
    Posts:
    34
    Likes Received:
    0
    Bought brand new Sapphire 6870 1GB from Amazon.
    Did the usual, removed all previous drivers, added card and installed newest ati cat from website.
    Here are my symptoms:
    I start up the pc and reach my desktop.
    From here I can open my computer and control panel etc absolutely fine.
    When I open firefox or catalyst control centre screen goes black with just image (not moving) or mouse pointer on left side of screen.
    BSOD citing atikpmag.sys as the problem.

    I have tried the earlier driver from the cd and witht his driver it still crashes when opening firefox but not with catalyst control centre.

    Help?

    EXRA INFO:
     
    Last edited: 17 Dec 2011
  2. aLtikal

    aLtikal 1338-One step infront of the pro's

    Joined:
    7 May 2008
    Posts:
    943
    Likes Received:
    27
    What PSU are you using to run it?

    Have you tried it in someone elses PC to see if the results are the same?
     
  3. hm1992

    hm1992 What's a Dremel?

    Joined:
    28 May 2009
    Posts:
    34
    Likes Received:
    0
    PSU is a brand new antec high current gamer 520W. Both pcie connectors are fitted.
    And o havent got another pc to test in as all other pcs are dells with their crazy backwards motherboard so dual slot cards dont fit.
     

Share This Page