1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Windows SATA hates me?

Discussion in 'Software' started by Malvolio, 12 Feb 2005.

  1. Malvolio

    Malvolio .

    Joined:
    14 Dec 2003
    Posts:
    4,632
    Likes Received:
    178
    I'm not sure what exactly I'm doing wrong, but I'm sure doing it right...


    Anyway, I just got two new samsung spinpoint 120GB SATA HDD's, and I've got them installed, partitioned, and formatted - that wasn't a problem, went surprisingly smooth. Now, when I open Norton Ghost and select "Disk Backup," then choose to copy C: to one of the partitions on a new SATA drive, it goes through; no problems.

    The problem I'm having is when I change the drive letters around to where the "copy" of my old C: drive (on the new SATA drive) is the new C: drive, and I then disconnect my old HDD, windows refuses to boot!

    Alright, it almost boots... Basically what happens is I get the striped down log-in screen (not the one where you choose which user, but the other one where you type in the user/password) instead of my normal one. Now, I could probably live with this, but what really kicks it is when I go to log in, it comes up "Logging In," then "Saving Settings," and finally "Logging Off."

    When I boot into safe mode it comes up with the same log-in screen, does the same log-in procedure, but this time it kicks me back onto the log-in screen.


    Help!
     
  2. Sveneric

    Sveneric What's a Dremel?

    Joined:
    11 Jan 2005
    Posts:
    4
    Likes Received:
    0
    Not sure if this will work using ghost. You may have to do a clean install of windows on to the raid drives, this is because windows needs the raid drivers installed during the install process. Windows setup asks you to press F6 during install process, when F6 is pressed it then asks for drivers which are usually supplied on a floppy disk with your motherboard. The version of windows you have on your original hard drive will not have these drivers so therefore it won't work on the raid array you have set up. I'm not aware of any way of adding the drivers so that your ghost image will work.
     
  3. ch424

    ch424 Design Warrior

    Joined:
    26 May 2004
    Posts:
    3,112
    Likes Received:
    41
    Yeah, sveneric's right: windows doesn't have the boot drivers for your sata controller (raid or not, it doesn't matter). What are the drives connected to (what mobo? or a controller card?)

    ch424
     
  4. kenco_uk

    kenco_uk I unsuccessfully then tried again

    Joined:
    28 Nov 2003
    Posts:
    9,696
    Likes Received:
    308
    Try doing a repair install and having the raid driver on a floppy so you can hit F6 near the beginning of the install.
     
    Last edited: 14 Feb 2005
  5. Malvolio

    Malvolio .

    Joined:
    14 Dec 2003
    Posts:
    4,632
    Likes Received:
    178
    Asus K7N8X-E. The drives are booting with windows right now, but yeah, I'm probably just going to do a fresh install of windows - seems to be the smartest thing to do. Actualy had to make my own RAID driver install disks as this mobo didn't come with them... ******* ASUS...
     
  6. ch424

    ch424 Design Warrior

    Joined:
    26 May 2004
    Posts:
    3,112
    Likes Received:
    41
    sounds about right... btw, the drivers are on the cd that came with the mobo: they just assume you have an old computer to make the floppy from....


    ch424
     
  7. Feline

    Feline What's a Dremel?

    Joined:
    17 Dec 2004
    Posts:
    191
    Likes Received:
    0
    I recently upgraded to a Samsung SATA hard drive as my C: drive. I used Acronis TrueImage, because Ghost refused to work properly (wouldn't see the full drive size after I imaged the new drive. It still thought it was a 40Gb drive, even though the new one is 160Gb's.) Anyways, I did have to do a Windows repair install before it would boot (my SATA is onboard.) Once I did that, everything was smooth.

    Also, if you're using onboard SATA, make sure it's enabled in the BIOS. I've noticed a lot of mobo's with onboard SATA have it disabled by default in the BIOS, so make sure you turn it on. In my case, once I enabled it, I had to restart the computer, go into the BIOS a second time and then select the new drive as the boot disk.
     
  8. Malvolio

    Malvolio .

    Joined:
    14 Dec 2003
    Posts:
    4,632
    Likes Received:
    178
    Alright, sounds good, will try :thumb: And my mobo just has a jumper to enable/disable SATA, which was set on by default (I disabled it untill I got these drives though). In my BIOS there's actualy no option to boot from SATA, just an option to boot from "other devices," still boots from them though, so whatever. Thanks for the advice.
     
Tags:

Share This Page