1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Windows Security certificate issues in Firefox

Discussion in 'Software' started by koli, 22 Feb 2015.

  1. koli

    koli Member

    Joined:
    19 May 2010
    Posts:
    31
    Likes Received:
    0
    Hi guys, I am hoping you can help me with something.

    Couple of weeks ago I started having problems with certificates in Firefox under W8.1. Initially it was just with internet banking websites but now it is also social media and online shopping. This is what I get when I try to log in to youtube:
    [​IMG]

    I don't have this problem on Chrome on the same pc EDIT: Kaspersky is now also giving me the message bellow on Chrome with Amazon website. Firefox running under Mint Linux that I run on Vmware on my pc is also ok.

    This morning is got this error from my Kaspersky AV:
    [​IMG]

    This is the said certifcate:
    [​IMG]

    Does anybody know what the problem is and how to fix it?
    Thanks
     
    Last edited: 22 Feb 2015
  2. IvanIvanovich

    IvanIvanovich будет глотать вашу душу.

    Joined:
    31 Aug 2008
    Posts:
    4,870
    Likes Received:
    252
    You could try resetting your profile. Help menu, troubleshooting, reset firefox. It will move your old profile to the desktop so you won't loose your bookmarks but you will have to import them to your new profile. Or if you use sync it will do that for you and reinstall your extensions too.
     
  3. koli

    koli Member

    Joined:
    19 May 2010
    Posts:
    31
    Likes Received:
    0
    Thanks Ivan,

    I reset the FF as advised and it didn't make any difference. I completely uninstalled it, same result.
    Then I switched off my Kaspersky AV and now everything works as normal, i.e. no FF warnings about certificates.

    In the past I had some warnings from AV that my network is not secure but I can't do anything about it (i rent my landlord looks after wifi). I guess I need to find out if my AV is overly cautious or I actually should be worried about the network security.
     
  4. aramil

    aramil One does not simply upgrade Forums

    Joined:
    10 Jul 2012
    Posts:
    961
    Likes Received:
    56
    Install the Kaspersky Certificate manually.

    Here is how to do:

    1.Open the main browser window.

    2.Open the Options window depending on the browser options:
    (Guessing you are using one of the latest versions of Firefox)

    click ALT button to open menu barIn the menu select Tools > Options.

    3.Click the Advanced icon
    4.Go to the Certificates tab
    5.Click the View Certificates button

    6.In the Certificate Manager window go to the Authorities tab
    7.Click the Import button

    8.Browse the path to the certificate file. The default folder is:
    C:\ProgramData\Kaspersky Lab\AVP15.0.1\Data\Cert\ (have to show hidden files/folders set in explorer)

    9.Select and Click Open:
    (fake)Kaspersky Anti-Virus Personal Root Certificate.cer


    10.In the Downloading Certificate window select the purposes which you trust the certificate should perform (web)

    11.Click OK to close each window


    12.In the Certificate Manager window make sure Kaspersky Lab’s certificate is installed and click OK
     
    Last edited: 22 Feb 2015
    koli likes this.
  5. koli

    koli Member

    Joined:
    19 May 2010
    Posts:
    31
    Likes Received:
    0
    Thanks Aramil,

    that helped. I haven't realised that I set AV to scan secure connections as well. I am not sure it is a good idea either as I presume it can see data (including passwords?) being transmitted between me and banks. I will need to do some research on this and have a think if I am comfortable with it.
     
  6. creative

    creative 500rwhp

    Joined:
    23 May 2014
    Posts:
    438
    Likes Received:
    30
    is the computers date correct?
     
  7. gosh

    gosh Member

    Joined:
    20 Oct 2009
    Posts:
    171
    Likes Received:
    3
    exact same problem i'm having with my PC, ended up reinstalling windows and it still persists.

    suspect my issue is something to do with system clock - windows is right but will have to check the bios.

    <edit> reset bios to default settings and problems seem to have stopped, must have something to do with my unlocking of the 2 extra cores on my phenom 2
     
    Last edited: 12 Mar 2015
  8. lcdguy

    lcdguy Active Member

    Joined:
    25 May 2004
    Posts:
    2,336
    Likes Received:
    19
    I would also keep in mind that when copying the certificate to install locally make sure you check off "Include all certificates" in case the web service is using chained certificates. (ie: root > chain root > chain > server certificate)

    You could also you a ssl checker to verify a site. SSL Shopper has a free one which works pretty good.

    Also if you are browsing SSL traffic through a proxy this can sometimes provide false positives as well.
     

Share This Page