1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

what Do i do next ?

Discussion in 'Tech Support' started by Ryu_ookami, 31 Jan 2008.

  1. Ryu_ookami

    Ryu_ookami I write therefore I suffer.

    Joined:
    11 Mar 2004
    Posts:
    3,326
    Likes Received:
    128
    Hi, all I have 2 PC'S the first is connected to a speedtouch modem/router and connects directly to the internet. The second connects to the internet via a linksys usb adaptor which connects to the wireless network. All of that is fine what I want to do however is share files between the 2 Pc's. Does anyone know how I do that, because although both connect to the internet the first PC has a shared drive but the second Pc can not see the shared drive any ideas ?
     
  2. pranks7er

    pranks7er mange tout

    Joined:
    25 Dec 2002
    Posts:
    3,515
    Likes Received:
    0
    run the network setup wizard,
    check firewall not blocking file sharing
     
  3. skpstr

    skpstr New Member

    Joined:
    9 Feb 2004
    Posts:
    119
    Likes Received:
    1
    I'm assuming you are using XP Home, I'm also assuming that the router is allocating IP addresses to the 2 pcs.

    Try checking what each machines workgroup is set to. As far as I am aware XP Home boxes have to be in the same workgroup to see each other.
     
  4. Ryu_ookami

    Ryu_ookami I write therefore I suffer.

    Joined:
    11 Mar 2004
    Posts:
    3,326
    Likes Received:
    128
    Both are running XP professional with service pack 2 and yes the router is allocating the ip addresses but i'll check the workgroup
     
  5. MilkMan5

    MilkMan5 Yeah man...

    Joined:
    11 Jul 2007
    Posts:
    183
    Likes Received:
    0
    Check your Domain names, needs to be the same
     
  6. johnmalc

    johnmalc That shouldn't happen....

    Joined:
    7 Jul 2007
    Posts:
    51
    Likes Received:
    1
    I had occasion to ask the very same question on a forum last year ( www.deviantforums.com ) and got a swift and accurate reply, meaning it worked... So if I just tell you what I did, you can substitute names and drives as appropriate, yes? Okay, here goes.

    We all share internet access through the Thomson Speedtouch Router. We all want to access the connected server called "Office". We are not, and do not want to be, a network as such. On "Office" there is a shared drive containing all the stuff we all need to access (in our case all the media files). So I go to:

    Start>run>\\office

    This will show the shared drive, nothing more, but give full access to that drive. Then right click on that drive and "map network drive", this will make it available at all times.

    It is that simple, if that is all you want to do, ie share a drive /folder, no domains/workgroups etc.

    LMK if that works for you.
     
  7. Ryu_ookami

    Ryu_ookami I write therefore I suffer.

    Joined:
    11 Mar 2004
    Posts:
    3,326
    Likes Received:
    128
    Ok I tried it and its sort of worked sort of didn't work.

    I'll explain

    computer with shared drive = A

    computer with no shares = B

    if I type the name of computer "A" into start>run> on computer "B" the result i get is Printers and Faxes and also Scheduled tasks

    If I type the name of computer "A" into start>run> on computer "A" the result I get is Printers and Faxes and also Scheduled tasks AND the assigned letter of the shared drive.

    Computer "A" has windows xp firewall running and is also running AVg but i can not see either of these stopping it sharing especially as it allows Computer "B" to access the net.
     
  8. johnmalc

    johnmalc That shouldn't happen....

    Joined:
    7 Jul 2007
    Posts:
    51
    Likes Received:
    1
    That's strange, I do this a few times a week for customers and have never had it not work, so some questions and clarifications.

    First, you say

    "Computer "A" has windows xp firewall running and is also running AVg but i can not see either of these stopping it sharing especially as it allows Computer "B" to access the net."

    No problem with the XP firewall/AVG combo, same as I use, but as I understood you both pcs access the internet through the router, not through each other eg Internet Connection Sharing (ICS)? If you are using ICS then my method doesn't work.

    If through the router then:

    Have you entered the correct name of machine A into machine B, ie the name given in system properties>computer name?

    Are you trying to share the root drive of A? XP can get arsey about this.

    Are you trying to share a drive, folder or partition, and do you have Network Sharing and Security enabled on the target (check in properties>sharing)?

    I suspect the problem is in the latter.

    Oh, always remember to reboot both machines after changes.

    Post back.
     
  9. Ryu_ookami

    Ryu_ookami I write therefore I suffer.

    Joined:
    11 Mar 2004
    Posts:
    3,326
    Likes Received:
    128
    ok I'll try and answer you questions one at a time hopefully with the right answer :)

    I understood you both pcs access the internet through the router, not through each other eg Internet Connection Sharing (ICS)?

    Pc A has a speedtouch modem/router installed the cable to the phone socket is plugged into this this it also has a cable going to the network socket on the motherboard from a network port on the back of the router.

    Pc B has a usb network adaptor which searches for available wireless networks and then when i've entered the password it connects to the one I set up.

    Have you entered the correct name of machine A into machine B, ie the name given in system properties>computer name?

    umm I think so under system>properties of Pc A it says the computers name is "pal." I've tried it as pal and i get the scheduled tasks etc if i try it with the "." in place it goes to a blank screen with the words no objects at the bottom of the screen.

    Are you trying to share the root drive of A?

    Nope I'm trying to share the route of drive "F" which is my anime drive.

    Are you trying to share a drive, folder or partition, and do you have Network Sharing and Security enabled on the target (check in properties>sharing)?

    Yes, I'm trying to share a drive and network sharing is enabled. its set to allow all and its set to read only.

    Oh, always remember to reboot both machines after changes.

    both machines have been rebooted after the changes still nothing seen though.

    Post back.

    have done :) would have posted back sooner but the GF decided that she wanted to go see a few films yesterday at the cinema.

    Hint to everybody "Sweeny Todd" is nowhere near as good as its hyped up to be. "Enchanted" is corny but kinda funny and "St trinians" is excellent.
     
  10. johnmalc

    johnmalc That shouldn't happen....

    Joined:
    7 Jul 2007
    Posts:
    51
    Likes Received:
    1
    A comprehensive answer that leaves me scratching my head.....

    So some more questions:

    If you access the Speedtouch through your browser there is usually a page called Home Network. Can you see both PCs in there?

    Just to test a theory is it possible to also connect PC B by wire? And then try to access A in the same way as suggested before.

    The Speedtouch has a firewall, which setting have you applied.

    One other thing I always do is assign each PC a static IP address in the router, this simply avoids clashes and seems more reliable.

    Apart from that I'm stumped at the moment. You can of course set up a network using the wizard but this simple method should work....:wallbash:
     
  11. Ryu_ookami

    Ryu_ookami I write therefore I suffer.

    Joined:
    11 Mar 2004
    Posts:
    3,326
    Likes Received:
    128
    If you access the Speedtouch through your browser there is usually a page called Home Network. Can you see both PCs in there?

    yep first PC is called pal, Second pc is called Lycissa

    pal is connected to the net and shows the connection as an ethernet connection

    Lycissa shows that its connected wireless to the Wlan

    decided to take screenshots I thought it might be slightly easier to see what I mean

    [​IMG]

    Just to test a theory is it possible to also connect PC B by wire? And then try to access A in the same way as suggested before.


    unfortunately this is not possible as the Pc's are in two different rooms (hence the need for wireless) :)

    The Speedtouch has a firewall, which setting have you applied.

    pass I'll take another screenshot to be honest I didn't even realise it had a built in firewall.

    [​IMG]

    One other thing I always do is assign each PC a static IP address in the router, this simply avoids clashes and seems more reliable.

    umm not sure how to do this.
     
  12. johnmalc

    johnmalc That shouldn't happen....

    Joined:
    7 Jul 2007
    Posts:
    51
    Likes Received:
    1
    Quote "One other thing I always do is assign each PC a static IP address in the router, this simply avoids clashes and seems more reliable.

    umm not sure how to do this."

    Just click on each PC shown on the Speedtouch, this will take you one page deeper and allow you to "always use this IP". I don't think this is your problem, but worth doing anyway.

    As for the router firewall, just disable it for now, I have a sneaking suspicion that might be the problem. Go Firewall>configure>disable (you have a much later interface than mine, but that's where it should be).

    If that doesn't work then...... I don't know????:confused: Try removing the share on A, reboot, reset the share, reboot try again?

    One other thing, reboot the router! Amazing the number of problems this solves!

    Good luck.
     
  13. lworbey

    lworbey New Member

    Joined:
    23 Nov 2007
    Posts:
    130
    Likes Received:
    0
    If you look at the properties for your network connection you should have a protocol installed NWLink NetBIOS... don't remember the exact name but it isn't installed by default normally and I've found I struggled to get file sharing working without it!
     

Share This Page