windows 10 recoognising intenal hdd as removable drive

Discussion in 'Software' started by Dreamcometru, 2 Dec 2017.

  1. Dreamcometru

    Dreamcometru Member

    Joined:
    11 May 2009
    Posts:
    289
    Likes Received:
    1
    hi again so ive updated every driver i can think of but the problem persists...what now?
     
  2. RedFlames

    RedFlames ...is not a Belgian football team

    Joined:
    23 Apr 2009
    Posts:
    8,308
    Likes Received:
    417
    Find the BIOS setting i mentioned earlier and turn off Hot-swap for the SATA ports. According to MSI the setting is the same on the B350 and X370 'Krait' borads. [Pg46 of the manual].
     
  3. Dreamcometru

    Dreamcometru Member

    Joined:
    11 May 2009
    Posts:
    289
    Likes Received:
    1
    ok i ve chekced and that setting is disabled. but still same problem :(
     
  4. phuzz

    phuzz This is a title

    Joined:
    28 May 2004
    Posts:
    1,700
    Likes Received:
    24
    Sometimes Windows will just decide to do that.
    It is possible to fix with a registry key, from the instructions on this page.
    However I followed those instructions to stop my NVMe drive from showing up as removable (no windows stahp). The instructions worked, but instead all of my other drives showed up as removable when they hdn't been before. I couldn't be arsed to fix that so they're still there.
     

Share This Page