1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Other Ati 10.3 drivers

Discussion in 'Software' started by J!n, 1 Apr 2010.

  1. J!n

    J!n That's aperture science

    Joined:
    7 Nov 2009
    Posts:
    153
    Likes Received:
    4
    Hey

    I just got a 5870 Monday because my 8800gt died when playing bad company 2

    I have now installed the 10.3 drivers but i keep getting loads of problams like flickering ground textures and when i get in game 80% of the time the sceen is black but all the flag markers are visible along with the HUD i can fix this issue sometimes by Ctrl Alt Del out then back in the game but sometimes the game freazes and even bluescreens at times with the message along the lines of your drivers are crap.

    Anyone else having these problams and also how do i get the older 10.2 drivers im looking all over the site for them but cant find them, on the nvidea site its simple you type in your card OS and the newest official one pops up and also loads of beta and you can even download old ones.

    Has anyone got a link to 10.2 drivers please will give them a go thanks :blah: see if those work if not BC2 gets shelved for the time being. thanks
     
  2. Seeks

    Seeks Minimodder

    Joined:
    13 Feb 2010
    Posts:
    367
    Likes Received:
    32
    I have the 5870 and updated recently. it all works fine for me on all games including BC2. What graphics settings do you have in BC2? That may be the issue. The other thing I would suggest is trying to reinstall 10.3
     
  3. Baz

    Baz I work for Corsair

    Joined:
    13 Jan 2005
    Posts:
    1,810
    Likes Received:
    92
    We benched the HD 5870 with 10.3 in BC2 with no issues, although did encounter the flickering ground textures you're talking about with the HD 5970. Quitting to the menu and then loading back into the game sorted it.

    Consider reinstalling the game?
     
  4. theskirrid

    theskirrid What's a Dremel?

    Joined:
    15 Dec 2009
    Posts:
    192
    Likes Received:
    17
    Actually the bluescreen code tells you more than that. What's the code you get?
     
  5. wyx087

    wyx087 Homeworld 3 is happening!!

    Joined:
    15 Aug 2007
    Posts:
    11,509
    Likes Received:
    503
    re-install the driver, definitely driver issue.

    does the problem only happen in 1 game?
     
  6. masterjonny

    masterjonny What's a Dremel?

    Joined:
    5 Mar 2010
    Posts:
    316
    Likes Received:
    23
    There are acutally preview drivers on the site. I've got 2 blue screen's, one saying the graphics card scheduler had died, and the other saying there was a fault in managed DirectX, which since installing the beta driver has gone away.

    There is a preview driver here you could try which might help you some:

    http://sites.amd.com/us/underground/tips/Pages/catalyst-10-3-preview.aspx

    When installed the driver is dated the 24/03.

    Last night I found on the site:

    http://support.amd.com/us/kbarticles/Pages/Catalyst-OpenGL-preview-driver.aspx

    Which has actually been there a while, but got sneakily updated at some point when I wasn't looking. It contains a driver dated 29/03, and updates the driver version from 8.712.3.0 (in the preview driver) too 8.712.3.1000, huge upgrade :lol:

    Since installing the preview I've not had any BSOD's, but I have only been using them for 2 days, so early days to judge yet :)
     
  7. J!n

    J!n That's aperture science

    Joined:
    7 Nov 2009
    Posts:
    153
    Likes Received:
    4
    Ok tryed reinstalling the game it worked for 2 rounds but then crashed had to hard restart

    I did try reinstalling the drivers before and tryed again after the above fault and it appears the bsods and crashes have gone for about 4 rounds then i got a VPU recovery saying somthing was wrong with the accelirator of some sort :worried:

    I do have the card over clocked by ATI overdrive (ATI tool dosnt work with this card) and let it OC its self and after the VPU reset i noticed the activity clock in OD has got stuck at 99%

    When running the game OD shows my max temp of 69c and activity of max 64% (untill BC2 crashed) and fan speed max 30% does all that seem normal, was very suprised with this card how cool it runs.

    And the Bsod code you request was

    0x000000EA (0X885F6DA8,0X888A9748,0XB856BCBC,0X00000001)

    Ok jonny will look into that thanks
     
    Last edited: 1 Apr 2010
  8. Showerhead

    Showerhead What's a Dremel?

    Joined:
    11 Jan 2010
    Posts:
    1,110
    Likes Received:
    33
    Just a thought but you did uninstall the nvidia drivers first? Even then might be worth giving it a run with driver sweeper.
     
  9. wyx087

    wyx087 Homeworld 3 is happening!!

    Joined:
    15 Aug 2007
    Posts:
    11,509
    Likes Received:
    503
    i've got nVidia drivers AND AMD video drivers installed here no problem. yes, it is best to uninstall it, but it should not cause any problems

    does other game crash like this?

    the fan speed and temperature seems about right, but card activity should be 100%..... for my Dx11 and everything maxed with 4xAA.

    EDIT:
    was browsing OCn and noticed you wasn't the only one having this problem.
    http://www.overclock.net/ati/699135-ati-drivers-bad-company-2-im.html
     
    Last edited: 1 Apr 2010
  10. J!n

    J!n That's aperture science

    Joined:
    7 Nov 2009
    Posts:
    153
    Likes Received:
    4
    Yeah i uninstalled all drivers and ran driver cleaner pro after and isntalled the new drivers

    Nope this is the only game played dirt 2 maxed and gta 4 yesterday with no problems after 2 hours play each :rock:

    I installed the new drivers and i still get the same black screen and a CTD and i also got a blue screen today aswell, but i have found when i get the black screen if i press ESC key to bring up the games menu then ctrl alt del out and wait 5 seconds and go back in game most of the time the problem goes wich can increase my gaming time upto one hour.

    I think the only option for me is to shelf the game untill the next patch or ATI driver release :thumb:

    Or get windows 7
     
  11. J!n

    J!n That's aperture science

    Joined:
    7 Nov 2009
    Posts:
    153
    Likes Received:
    4
    Just a quick question if i wanted to ocerclock the 5870 what overclocking software and temp monitoring software do people use. thanks
     
  12. Xonar

    Xonar What's a Dremel?

    Joined:
    2 Nov 2009
    Posts:
    676
    Likes Received:
    33
    MSI afterburner for overclocking and voltage control, GPU-Z for temps.
     
  13. wyx087

    wyx087 Homeworld 3 is happening!!

    Joined:
    15 Aug 2007
    Posts:
    11,509
    Likes Received:
    503
    IMHO overclocking isn't worth it on the 5870. can only increase to 900Mhz, that's 5% increase compensating stability.
     
  14. Daytona178

    Daytona178 What's a Dremel?

    Joined:
    1 Apr 2010
    Posts:
    19
    Likes Received:
    0
    I just bought a ATI 5850 and i have installed the 10.3 drivers for it. My internet is being setup on Turesday so i will see how well BC2 plays then :) I cant wait!
     
  15. J!n

    J!n That's aperture science

    Joined:
    7 Nov 2009
    Posts:
    153
    Likes Received:
    4
    So what would you use to stress the card and to check for artifacts

    Edit just found the stress tool that came with it but whats the highest max safe temp for this card would you recommend thanks
     
    Last edited: 3 Apr 2010
  16. Xonar

    Xonar What's a Dremel?

    Joined:
    2 Nov 2009
    Posts:
    676
    Likes Received:
    33
    In my experience, it's the VRM's over the actual GPU core temperature that will hit their peak first.

    While I was on air I liked to keep the core below 80c during load and my VRM's below 100c (from what I've read they're good up to 120c but I didnt want to chance it.)

    As you're on a 5870 though and your card has a 4 phase power delivery over the 5850's 3 phase, the load being more evenly spread giving you lower VRM's temps, your result may vary from mine but I still wouldnt go over those temperatures pointed out to be safe. Hope this helps.
     
    Last edited: 4 Apr 2010
  17. wyx087

    wyx087 Homeworld 3 is happening!!

    Joined:
    15 Aug 2007
    Posts:
    11,509
    Likes Received:
    503
    well, my 5870 reference cooled reached 78c on shaders while VRM only reached 57c during a two hour BFBC2 game....... so i don't think there's anything to worry about for the VRM.

    there's a stress tool in Afterbuner?
     
  18. Xonar

    Xonar What's a Dremel?

    Joined:
    2 Nov 2009
    Posts:
    676
    Likes Received:
    33
    If you have version 1.5 or higher, there is a K on the left side of the window near the top which opens 'MSI Kombustor' and is similar to furmark.

    Have you tried upping the voltages at all wuyanxu? I found increasing the voltage at all had a much larger effect on my VRM temps as opposed to the core to the point where they became the limting factor but again this could simply be down to the differences between the 5850 and the 5870.
     
  19. wyx087

    wyx087 Homeworld 3 is happening!!

    Joined:
    15 Aug 2007
    Posts:
    11,509
    Likes Received:
    503
    my K is greyed out :( i was using Furmark for temperature stress, and huge Crysis loops that for stability test. should be fine?

    my card is also really strange, i've tested to be stock/1250 stable and 900/stock stable. but as soon as i put them together, it crashes. doesn't matter how much voltage i put through the core.
     

Share This Page