1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Build Advice Building new rig and looking for some advice - Updated with pictures

Discussion in 'Hardware' started by Sarneus, 30 Sep 2011.

  1. Sarneus

    Sarneus What's a Dremel?

    Joined:
    30 Sep 2011
    Posts:
    27
    Likes Received:
    0
    I tought I could wait till LITS, turns out I'm too impatient so I already ordered all the parts from Scan (free delivery thanks to bit-tech :D) and should be here tomorrow. Will post pics when I can.
     
  2. Ant1981

    Ant1981 Minimodder

    Joined:
    4 Dec 2008
    Posts:
    364
    Likes Received:
    0
    How do we get the free delivery?
     
  3. Blogins

    Blogins Panda have Guns

    Joined:
    3 Aug 2010
    Posts:
    4,883
    Likes Received:
    267
    theevilelephant likes this.
  4. Ant1981

    Ant1981 Minimodder

    Joined:
    4 Dec 2008
    Posts:
    364
    Likes Received:
    0
    Cheers me ole china.
     
  5. Sarneus

    Sarneus What's a Dremel?

    Joined:
    30 Sep 2011
    Posts:
    27
    Likes Received:
    0
    I know it took a few days, but as promised here are the pics from my new PC.

    The box everything came in:
    [​IMG]
    It as damn heavy, almost broke my back hauling it up the stairs :D

    [​IMG]

    [​IMG]

    [​IMG]

    All the parts together:
    [​IMG]

    The Case:
    [​IMG]

    [​IMG]

    [​IMG]

    Unboxing:
    [​IMG]

    [​IMG]

    [​IMG]

    Putting on the cooler:
    [​IMG]

    [​IMG]

    [​IMG]

    I cannibalized some HDDs from my old PC :p :
    [​IMG]

    [​IMG]

    Finished:
    [​IMG]

    [​IMG]

    And finally some horrible cable-tieing:
    [​IMG]
     
  6. Sarneus

    Sarneus What's a Dremel?

    Joined:
    30 Sep 2011
    Posts:
    27
    Likes Received:
    0
    The PC is working great, just have one problem i need to fix, for some reason the front audio jacks arent working at all. The from USBs work fine, but the audio jacks dont recognize anything, not sure how to fix it, I check connector on the mobo and it looks fine.
     
  7. murraynt

    murraynt Modder

    Joined:
    6 Jun 2009
    Posts:
    4,234
    Likes Received:
    128
    I can never get mine working either :L
    Build looks great. Needs a small bit of work in the cable tidying dept.
     
  8. pete*

    pete* Something witty here.

    Joined:
    29 Apr 2009
    Posts:
    1,000
    Likes Received:
    42
    Nice pics. Think i'm going to go for the MSI580 in my build. Although won't be for a few months.
     

Share This Page