1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Windows Abnormal high lag on Half-Life 2...

Discussion in 'Gaming' started by relix, 1 Mar 2005.

  1. relix

    relix Well-Known Member

    Joined:
    14 Nov 2001
    Posts:
    5,948
    Likes Received:
    41
    I'm having abnormal high lag on half-life 2 multiplayer games (CS, Deathmatch, ...). It's in the 250+ regions, which sucks. Reasons for it to be abnormal:

    • In Unreal Tournament 2004 I get a ping of <40 when playing on the same connection, with the same PC
    • Single player runs smoothly, so it isn't because my PC is too slow
    • LAN Games run smoothly as well, with very low ping

    I _am_ using a VPN connection because there's no other way to get internet over here at uni, but this shouldn't be a problem because it works fine in Unreal Tournament 2004.

    Does anyone has an idea why this might happen? I'm all out of ideas :(
     
  2. Lost.Soul

    Lost.Soul New Member

    Joined:
    26 Oct 2004
    Posts:
    339
    Likes Received:
    0
    It is caused by servers and their connections/performance...

    So let the Steam sort the games by ping from the lowest :thumb:, it is nearly impossible that you will have 250+ on every server
     
  3. relix

    relix Well-Known Member

    Joined:
    14 Nov 2001
    Posts:
    5,948
    Likes Received:
    41
    Lost_Soul, I (obviously ;) ) already did that, but every server I try gives me 200+ ping, and all of them are filled with players with a ping <30ms, and all of them have a so-called ping in the server browser of <20ms...
     
  4. Tim S

    Tim S OG

    Joined:
    8 Nov 2001
    Posts:
    18,881
    Likes Received:
    78
    you looked at your netcode?

    check the following:

    cl_updaterate
    cl_cmdrate
    rate
     
  5. Lost.Soul

    Lost.Soul New Member

    Joined:
    26 Oct 2004
    Posts:
    339
    Likes Received:
    0
    Well, I apologise if I affronted you :hehe: , I didnt understand you properly


    So open console and play with cl_rate, cl_updaterate and I think cl_cmdrate also affect connection. I have all of them around 2500 (or 25 000 :duh: , dont know right now)... Simply try to rise their values, maybe it will help.

    If not, I will try to find another solution :idea:


    EDIT: BigZ was faster :p
     
  6. relix

    relix Well-Known Member

    Joined:
    14 Nov 2001
    Posts:
    5,948
    Likes Received:
    41
    I'm unable to open the console, probably because I have an azerty keyboard... :wallbash:

    Can I change those values in my config file?
     
  7. dead_man

    dead_man Confucious say: WTF???

    Joined:
    4 May 2004
    Posts:
    1,195
    Likes Received:
    0
    i think you can change that in the normal options aswell iirc. ill look for it now
     
  8. Tim S

    Tim S OG

    Joined:
    8 Nov 2001
    Posts:
    18,881
    Likes Received:
    78
    cl_rate can't be changed in HL2 AFAIK.

    cl_cmdrate, cl_updaterate should be set to 101
    rate should be 25000 or 30000

    This is, of course, providing you are on broadband.
     
  9. Lost.Soul

    Lost.Soul New Member

    Joined:
    26 Oct 2004
    Posts:
    339
    Likes Received:
    0



    heh.... seems really strange to me. This is first time I heard that cmdrate and updaterate should be 101 :sigh:
     
  10. JuMpErFLY

    JuMpErFLY Member

    Joined:
    13 Mar 2003
    Posts:
    882
    Likes Received:
    1
    You might need the -console switch on your shortcut.
    If that fails create "userconfig.cfg" in your cstrike (or whatever game you require) folder and add the rate commands bigz suggested.
     
  11. relix

    relix Well-Known Member

    Joined:
    14 Nov 2001
    Posts:
    5,948
    Likes Received:
    41
    I tried doing that, and with rate set to 25000 there's no differince, but when using 30000 or 250000 (was a typo ;)) everything is really stuttering, far worse, yet I had a ping of 40 and 1 respectively...

    Very weird, but alas no solution :waah:
     
Tags:

Share This Page