1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Peripherals Asus Vulcan issues

Discussion in 'Hardware' started by cclement bled, 25 May 2012.

  1. cclement bled

    cclement bled New Member

    Joined:
    25 May 2012
    Posts:
    1
    Likes Received:
    0
    I got an asus vulcan about a month ago and the day i got it i was having trouble getting it to work. The audio jack has to literally be rammed into the headset for it to work and the mic stopped working altogether two weeks ago, so I send it back to get a replacement. A week later I received my replacement to find that the audio isnt working:sigh:. I'm extremely frustrated :wallbash: and I'm never buying asus peripherals again. I really want to know if anyone else is experiencing trouble and if they've found any solutions, thanks
     
  2. Parge

    Parge the worst Super Moderator

    Joined:
    16 Jul 2010
    Posts:
    12,931
    Likes Received:
    563
    Just found my Microphone/headset has broken too (doesn't seem to want to transmit my voice any how)

    Not great for an £80 set of headphones.

    Thomas or Bindi, Amazon suggest I should be contacting Asus over this issue. Is that correct? I bought these last November.
     
    Last edited: 30 Aug 2012
  3. Bloody_Pete

    Bloody_Pete Technophile

    Joined:
    11 Aug 2008
    Posts:
    7,563
    Likes Received:
    596
    Never had any issues with mine and they're well over a year old...
     
  4. ferret141

    ferret141 Well-Known Member

    Joined:
    18 Oct 2010
    Posts:
    1,311
    Likes Received:
    36
    No audio could be attributed to ANC. I found I had to turn ANC on & off with a battery in there.
     
  5. Parge

    Parge the worst Super Moderator

    Joined:
    16 Jul 2010
    Posts:
    12,931
    Likes Received:
    563
    Doesn't make a difference mate. Its defo broken.

    Also:

    The Asus support website is nicht su gut!!

    The website is pretty unintuitive, and I can't even work out where I am supposed to submit a claim to get an RMA number to.

    I called their customer helpline (which says it is charged at 6p per minute, but is actually 8p per minute) and all I got was a recording telling me to visit their website.

    I went back to the website to try Live Chat. Unfortunately there was no one there to chat with me at this time.

    Back to the website, and I find a page telling me that Step 2 (after confirming that I am within warranty period (I am under UK law), I should contact an Asus official partner, - click here to find the local number - ... sweet! Getting somewhere now...... oh no, I'm not because its the same customer service number that I just phoned.

    The only email address I can find, is one for their business clients. Emailed them anyway, to see if they could at least point me in the right direction but unfortunately they just directed me back to their support pages.

    In the end, I somehow ended up here

    Which I think is where I need to be. Jeeeeeze.
     
  6. towelie

    towelie How do I Internet!!

    Joined:
    1 Sep 2011
    Posts:
    399
    Likes Received:
    10
    Got this issue right now will troubleshoot more when i get home but have a feeling its an RMA issue.
     
  7. Guest-16

    Guest-16 Guest

    RMA time guys :(
    (And yes the plug into the headset does have to be inserted quite far, but it's not so far you can't do it??)
     
  8. towelie

    towelie How do I Internet!!

    Joined:
    1 Sep 2011
    Posts:
    399
    Likes Received:
    10
    Bindibadgi

    Opinion if you will, got the Microphone working had to turn off a few feature's and only a stable sound with the Microphone level a 100% seems excessive to me think i should proceed with the RMA?
     
  9. Ljs

    Ljs Well-Known Member

    Joined:
    4 Sep 2009
    Posts:
    2,217
    Likes Received:
    113
    Probably just another ASUS 'feature'.
     
  10. damien c

    damien c Mad FPS Gamer

    Joined:
    31 Aug 2010
    Posts:
    2,894
    Likes Received:
    173
    These are just some of the reasons I got rid of my Vulcans and will not get another set again.
     
  11. towelie

    towelie How do I Internet!!

    Joined:
    1 Sep 2011
    Posts:
    399
    Likes Received:
    10
    Damien C same issue as above?
     
  12. MrDomRocks

    MrDomRocks Well-Known Member

    Joined:
    5 Sep 2011
    Posts:
    4,993
    Likes Received:
    87
    So glad I didn't buy any Vulcans. I own a Blue Snowball Ice Mic and come pay day putting £160 into some HD 598's.

    The Mic is excellent and the headphones I have been told are amazing.
     
  13. damien c

    damien c Mad FPS Gamer

    Joined:
    31 Aug 2010
    Posts:
    2,894
    Likes Received:
    173
    Well I had a list of issues but the main ones were:


    Microphone only working when it wanted to.

    Microphone picking up the sound from the ear cups, regardless of settings used.

    No bass.

    Would not work with or without a battery, seemed to choose to want a battery and then not want a battery.

    ANC didn't work properly.


    I then also had similar issues with a few other headsets, but have never had any issues with my Creative X-FI headsets over the years and will continue to buy them until something better comes along.
     
  14. Slizza

    Slizza beautiful to demons

    Joined:
    23 Apr 2009
    Posts:
    1,738
    Likes Received:
    120
    Have not been able to get anything out the mic since i received my Vulcan headset. :(
    As headphones they are great though.
     
  15. Kovoet

    Kovoet New Member

    Joined:
    26 Aug 2009
    Posts:
    7,128
    Likes Received:
    348
    I thought it was me. I have been trying all day. Thank god i kept my Razer as spares
     
  16. Parge

    Parge the worst Super Moderator

    Joined:
    16 Jul 2010
    Posts:
    12,931
    Likes Received:
    563
    I had this issue too! So annoying. I have to say, great sound, but how they passed Q&A I'll never know.
     
  17. Kovoet

    Kovoet New Member

    Joined:
    26 Aug 2009
    Posts:
    7,128
    Likes Received:
    348
    I got it to work but do not ask me how but been on it in game and skype tonight no problems. Played with the driver for about a hour and boom it started to work. Rebooted and it is still working
     

Share This Page