1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PSU EVGA SuperNOVA G3 - Fan issues...?

Discussion in 'Hardware' started by TheMadDutchDude, 26 Mar 2018.

  1. TheMadDutchDude

    TheMadDutchDude The Flying Dutchman

    Joined:
    23 Aug 2013
    Posts:
    4,745
    Likes Received:
    522
    Hey guys,

    Do any of you here have an EVGA SuperNOVA G3 unit? Can you tell me how your fan behaves? Mine stays off for the most part, and when it comes on, it is full ball. It's very annoying!

    Is that how yours behaves as well, or have I got a lemon??

    Thanks!
     
  2. Sentinel-R1

    Sentinel-R1 Chaircrew

    Joined:
    13 Oct 2010
    Posts:
    2,095
    Likes Received:
    253
    I had two G3s. One DOA, the other failed after 4 months and my EVGA Z170 board died yesterday at less than 3yr old. I’m disappointed with EVGAs quality of late. Hope you don’t suffer the same!
     
  3. Goatee

    Goatee Well-Known Member

    Joined:
    19 Apr 2015
    Posts:
    1,732
    Likes Received:
    655
    Mine is super quiet. Have you got it set to Eco?
     
  4. TheMadDutchDude

    TheMadDutchDude The Flying Dutchman

    Joined:
    23 Aug 2013
    Posts:
    4,745
    Likes Received:
    522
    It is most definitely set to ECO as it only spins up every so often. It goes balls to the walls when doing so, though.

    I might ping them a message and see what they say.

    Sentinel, that doesn’t sound good - perhaps a bad luck spree? These units (I have two) were used for a mining rig and never missed a beat in three months of constant 80 to 95% load in anywhere from 30 to 45c ambient temps. I’m fairly confident that they ran like that in higher temps too. Hmmm...

    Edit: upon further investigation... I am not the only one with this issue. Leaving it with ECO turned off will make the fan constantly run, and it does so with minimal noise. I think I will leave it like that to avoid those annoying rapid speed increases on ECO mode.
     
    Last edited: 27 Mar 2018
  5. adidan

    adidan Guesswork is still work

    Joined:
    25 Mar 2009
    Posts:
    16,315
    Likes Received:
    2,918
    Got a very quiet G3 but have never had it on ECO, prefer to have it just running - not a fan of having things stop/start all the time.
     
  6. TheMadDutchDude

    TheMadDutchDude The Flying Dutchman

    Joined:
    23 Aug 2013
    Posts:
    4,745
    Likes Received:
    522
    Yeah, I’m now in the same boat. It’s super quiet, which leads me to believe that EVGA could have implemented this feature a lot better.
     
  7. modd1uk

    modd1uk Well-Known Member

    Joined:
    4 Sep 2006
    Posts:
    3,415
    Likes Received:
    330
    I've got 4x 750w G3's running in my mining rigs, no issues with noisy fans here :(
     
  8. TheMadDutchDude

    TheMadDutchDude The Flying Dutchman

    Joined:
    23 Aug 2013
    Posts:
    4,745
    Likes Received:
    522
    Have you got them on ECO mode or have you got that switched off? I'd imagine that's off given that they're in mining rigs.
     

Share This Page