1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Windows GTA IV slower after upgrade

Discussion in 'Gaming' started by bestseany, 27 Dec 2009.

  1. bestseany

    bestseany What's a Dremel?

    Joined:
    2 Jul 2009
    Posts:
    448
    Likes Received:
    6
    I know that GTA IV probably isn't the best game to judge a computers performance by, but I'm sure it feels slower since I've upgraded. If I'm driving a fast car in it, every few seconds the screen jerks slightly, like a slight pause.

    I've gone from a Intel Q6600 running at 3.4Ghz to a Intel Core i5 running at 3.8Ghz. I haven't changed the graphics card, a ATI 4870 1GB. I had to set to everything to medium, the shadows off and the draw distance and detail down to 15 or so anyway for it to run smoothly on the Q6600 and I haven't changed those settings.

    If anything, it should feel smoother after this so I'm not sure what's gone wrong. I've put the i5 back to stock settings in case my overclock was causing a problem but it runs the same. GTA has all the patches installed and WIndows 7 64-bit is fully updated, and I'm running the latest ATI catalyst drivers.

    I've even tried overclocking the 4870 in case it was that, but it started to get worse after it got to 815Mhz on the core speed.

    Anyone got any ideas as to what is causing this?
     
  2. nightblade628

    nightblade628 Minimodder

    Joined:
    10 Dec 2009
    Posts:
    263
    Likes Received:
    11
    I think it's the game. As far as ports go, that one isn't one of the better ones. The theory is that everything gets faster once you upgrade, so it would have been helpful to run benchmarks both before and after the upgrade just to reinforce this. This should show improved performance as you expected; how is your performance in other games now? Do you experience any problems with them now? If everything except GTA is faster, it's the game at fault.
     
  3. bestseany

    bestseany What's a Dremel?

    Joined:
    2 Jul 2009
    Posts:
    448
    Likes Received:
    6
    The problem with the GTA IV benchmarker is that it's not very accurate. I just go on how the game 'feels' usually, although it never felt 100% smooth with the Q6600. To be honest, it felt a bit smoother with my old nVidia 8800 GTX. Weird.

    I've not tried any other games yet as I've only just installed Windows and GTA on my new hard disk. I was worried in case my PSU wasn't up to the job or something and was throttling something back. Guess it must be OK though.

    I'll give a few other modern games a go and see how they fare.
     
  4. oasked

    oasked Stuck in (better) mud

    Joined:
    24 Aug 2005
    Posts:
    4,091
    Likes Received:
    74
    That's the game. Make sure you have the latest patch. I know that some of the patches cause this kind of lagging, so get the very latest version.

    One things for sure, that lag is a result of the game - not your hardware (as it was already pretty damned fast to begin with). :)
     
  5. Elton

    Elton Officially a Whisky Nerd

    Joined:
    23 Jan 2009
    Posts:
    8,577
    Likes Received:
    196
    I'm running it @ 1280x1024.

    I get about ~30FPS constant with 24 View, 50 Car Density, 35 Detail distance and all on high except textures because the 512mb Frambuffer.
     
  6. bestseany

    bestseany What's a Dremel?

    Joined:
    2 Jul 2009
    Posts:
    448
    Likes Received:
    6
    I'm starting to wonder if it's the latest November patch that's causing it, or WIndows 7.

    I'm running it at 1680x1050 at the moment, and it's unplayable with the shadows turned on, although they look pretty awful anyway.
     
  7. bestseany

    bestseany What's a Dremel?

    Joined:
    2 Jul 2009
    Posts:
    448
    Likes Received:
    6
    Tried Need for Speed Shift and that runs pretty much as it did before (smooth apart from juddery frame rates occasionally), so maybe it is GTA that's causing the lag.
     
  8. sp4nky

    sp4nky BF3: Aardfrith WoT: McGubbins

    Joined:
    15 Jul 2009
    Posts:
    1,706
    Likes Received:
    53
    Make sure you've got "Clip Capture" turned off in the settings and then you should be fine.

    I recently reinstalled the game and that was the single feature that turned the game from being unplayable to running soundly. I've got it set at 1680x1050 and I've got the 512MB version of the 4870, with a Core 2 cpu, so you should be more than fine to run it.
     

Share This Page