1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

GTX1070 OpenCL not detected, Failed to open... libOpenCL.so

Discussion in 'bit-tech Folding Team' started by 1Car1_Garforth, 4 Feb 2020.

  1. 1Car1_Garforth

    1Car1_Garforth New Member

    Joined:
    3 Feb 2020
    Posts:
    3
    Likes Received:
    0
    I have just bought an old Gigbyte GTX1070 for folding but it just sits idle. I have two PCs and I put it in the old one, FX-8350 CPU, as the new one (Ryzen 2600 CPU) gets about 65K ppd. I am using Linux Mint Mate 19.3 64-bit. Using nVidia's own drivers from the Mint drivers utility. Usually connected with HDMI to an old TV. Connecting to a DVI monitor instead made no difference. I re-installed Fahclient.
    The card has an RGB sign "fan stop" and this is on, indicating the fans are off. I have done some searching on the web and bit-tech but found postings from years ago.

    The pinned post, "How to get the most Folding Points from your Hardware" is from 2009 to 2014. Does anyone else think a new thread is in order? :)

    From log.txt:
    Code:
    *********************** Log Started 2020-02-03T09:06:42Z ***********************
    09:06:42:************************* Folding@home Client *************************
    09:06:42:      Website: https://foldingathome.org/
    09:06:42:    Copyright: (c) 2009-2018 foldingathome.org
    09:06:42:       Author: Joseph Coffland <joseph@cauldrondevelopment.com>
    09:06:42:         Args: --child --lifeline 1181 /etc/fahclient/config.xml --run-as
    09:06:42:               fahclient --pid-file=/var/run/fahclient.pid --daemon
    09:06:42:       Config: /etc/fahclient/config.xml
    09:06:42:******************************** Build ********************************
    09:06:42:      Version: 7.5.1
    09:06:42:         Date: May 11 2018
    09:06:42:         Time: 19:59:04
    09:06:42:   Repository: Git
    09:06:42:     Revision: 4705bf53c635f88b8fe85af7675557e15d491ff0
    09:06:42:       Branch: master
    09:06:42:     Compiler: GNU 6.3.0 20170516
    09:06:42:      Options: -std=gnu++98 -O3 -funroll-loops
    09:06:42:     Platform: linux2 4.14.0-3-amd64
    09:06:42:         Bits: 64
    09:06:42:         Mode: Release
    09:06:42:******************************* System ********************************
    09:06:42:          CPU: AMD FX(tm)-8350 Eight-Core Processor
    09:06:42:       CPU ID: AuthenticAMD Family 21 Model 2 Stepping 0
    09:06:42:         CPUs: 8
    09:06:42:       Memory: 15.67GiB
    09:06:42:  Free Memory: 15.16GiB
    09:06:42:      Threads: POSIX_THREADS
    09:06:42:   OS Version: 5.3
    09:06:42:  Has Battery: false
    09:06:42:   On Battery: false
    09:06:42:   UTC Offset: 0
    09:06:42:          PID: 1183
    09:06:42:          CWD: /var/lib/fahclient
    09:06:42:           OS: Linux 5.3.0-28-generic x86_64
    09:06:42:      OS Arch: AMD64
    09:06:42:         GPUs: 1
    09:06:42:        GPU 0: Bus:1 Slot:0 Func:0 NVIDIA:7 GP104 [GeForce GTX 1070] 6463
    09:06:42:CUDA Device 0: Platform:0 Device:0 Bus:1 Slot:0 Compute:6.1 Driver:10.1
    09:06:42:       OpenCL: Not detected: Failed to open dynamic library 'libOpenCL.so':
    09:06:42:               libOpenCL.so: cannot open shared object file: No such file or
    09:06:42:               directory
    09:06:42:***********************************************************************
    09:06:42:<config>
    09:06:42:  <!-- Client Control -->
    09:06:42:  <fold-anon v='true'/>
    09:06:42:
    09:06:42:  <!-- Network -->
    09:06:42:  <proxy v=':8080'/>
    09:06:42:
    09:06:42:  <!-- User Information -->
    09:06:42:  <passkey v='********************************'/>
    09:06:42:  <team v='35947'/>
    09:06:42:  <user v='1ca1_Garforth'/>
    09:06:42:
    09:06:42:  <!-- Folding Slots -->
    09:06:42:  <slot id='0' type='CPU'/>
    09:06:42:</config>
    09:06:42:Switching to user fahclient
    09:06:42:Trying to access database...
    09:06:42:Successfully acquired database lock
    09:06:42:Enabled folding slot 00: READY cpu:7
    09:06:42:WU00:FS00:Starting
    09:06:42:WU00:FS00:Running FahCore: /usr/bin/FAHCoreWrapper /var/lib/fahclient/cores/cores.foldingathome.org/v7/lin/64bit/avx/Core_a7.fah/FahCore_a7 -dir 00 -suffix 01 -version 705 -lifeline 1183 -checkpoint 15 -np 7
    09:06:42:WU00:FS00:Started FahCore on PID 1193
    09:06:42:WU00:FS00:Core PID:1197
    09:06:42:WU00:FS00:FahCore 0xa7 started
    
    config.xml:
    Code:
    <config>
      <!-- Client Control -->
      <fold-anon v='true'/>
    
      <!-- Network -->
      <proxy v=':8080'/>
    
      <!-- User Information -->
      <passkey v='xxxxxxxxxxxxxxxxxxxxxx'/>
      <team v='35947'/>
      <user v='1car1_Garforth'/>
    
      <!-- Folding Slots -->
      <slot id='0' type='CPU'/>
    </config>
    
    inxi -Fxzd:
    Code:
    inxi -Fxzd
    System:
      Host: Barney Kernel: 5.3.0-28-generic x86_64 bits: 64 compiler: gcc
      v: 7.4.0 Desktop: MATE 1.22.2 Distro: Linux Mint 19.3 Tricia
      base: Ubuntu 18.04 bionic
    Machine:
      Type: Desktop System: Gigabyte product: N/A v: N/A serial: <filter>
      Mobo: Gigabyte model: 970A-D3 v: 3.0
    
     serial: <filter>
      UEFI: American Megatrends v: FD date: 01/25/2013
    CPU:
      Topology: 8-Core model: AMD FX-8350 bits: 64 type: MCP arch: Bulldozer
      L2 cache: 2048 KiB
      flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
      bogomips: 64290
      Speed: 4081 MHz min/max: 1400/4000 MHz Core speeds (MHz): 1: 4110 2: 4083
      3: 4110 4: 4083 5: 4083 6: 4083 7: 4083 8: 4083
    Graphics:
      Device-1: NVIDIA GP104 [GeForce GTX 1070] vendor: Gigabyte driver: nvidia
      v: 435.21 bus ID: 01:00.0
      Display: x11 server: X.Org 1.20.5 driver: nvidia
      unloaded: fbdev,modesetting,nouveau,vesa resolution: 1920x1080~60Hz
      OpenGL: renderer: GeForce GTX 1070/PCIe/SSE2 v: 4.6.0 NVIDIA 435.21
      direct render: Yes
    Audio:
      Device-1: AMD SBx00 Azalia vendor: Gigabyte driver: snd_hda_intel
      v: kernel bus ID: 00:14.2
      Device-2: NVIDIA GP104 High Definition Audio vendor: Gigabyte
      driver: snd_hda_intel v: kernel bus ID: 01:00.1
      Sound Server: ALSA v: k5.3.0-28-generic
    Network:
      Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
      vendor: Gigabyte driver: r8169 v: kernel port: d000 bus ID: 03:00.0
      IF: enp3s0 state: down mac: <filter>
    Drives:
      Local Storage: total: 111.79 GiB used: 10.34 GiB (9.2%)
      ID-1: /dev/sda vendor: Crucial model: CT120BX500SSD1 size: 111.79 GiB
      Optical-1: /dev/sr0 vendor: ASUS model: DRW-24D5MT rev: 1.00
      dev-links: cdrom,cdrw,dvd,dvdrw
      Features: speed: 12 multisession: yes audio: yes dvd: yes
      rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
    Partition:
      ID-1: / size: 109.04 GiB used: 10.33 GiB (9.5%) fs: ext4 dev: /dev/sda2
    Sensors:
      System Temperatures: cpu: 50.5 C mobo: N/A gpu: nvidia temp: 38 C
      Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
    Info:
      Processes: 220 Uptime: 1d 4h 04m Memory: 15.67 GiB used: 1.15 GiB (7.3%)
      Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.20
      inxi: 3.0.32
    
     
  2. 1Car1_Garforth

    1Car1_Garforth New Member

    Joined:
    3 Feb 2020
    Posts:
    3
    Likes Received:
    0
    ** Update ** I have installed Windows 10 Home. The 1070 works perfectly on Windows on both computers.It works with both the old HDMI TV and the DVI monitor.
    It would be nice to have it work on Linux, though, as I dislike Windows Update.
     
    Last edited: 4 Feb 2020
  3. yuusou

    yuusou Well-Known Member

    Joined:
    5 Nov 2006
    Posts:
    2,247
    Likes Received:
    398

Share This Page