1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cases Help! - Build in Utgard fan controller not working

Discussion in 'Hardware' started by Sponge12349, 27 Aug 2010.

  1. Sponge12349

    Sponge12349 (づ。◕‿‿◕。)づ ︵ ┻━┻

    Joined:
    12 Apr 2010
    Posts:
    417
    Likes Received:
    16
    My Xigmatek Utgard Case has a built in fan controller. 2channels each with connections for up to 3 fans. I think i have connected the molex connector properly although the wires seem to move around (inside the bit at the end) and it is hard to connect to my power supply.

    Ive tried booting the computer with the knobs turnt down low, up high and in the middle.

    Whatever I change nothing happens to any of the fans. :wallbash:

    What could i be doing wrong or do you think there is a fault with the case?

    Thanks
    Sponge
     
  2. Sponge12349

    Sponge12349 (づ。◕‿‿◕。)づ ︵ ┻━┻

    Joined:
    12 Apr 2010
    Posts:
    417
    Likes Received:
    16
    anyone? :sigh:
     
  3. alex!

    alex! Kick-ass:Death ratio 93

    Joined:
    27 Jul 2010
    Posts:
    66
    Likes Received:
    0
    I may be wrong but I believe there is a little bit of movement around the wires at the molex but nothing substantial, to determine if there is something wrong with the wires is the fan controller powering up i.e are there any small LED's indicating power is being supplied to it? If no then there is a problem in the connection between the PSU and the controller, this could be due to a dodgy connection at the controller's end itself. If so i'd recommend contacting the supplier of the case and asking them to check it out/replace any parts, this will be free if you are covered by a warranty, alternatively you could snoop around the web for any utgard fan controllers and replace it yourself. If your still not sure about it there is no harm in calling the supplier or Xigmatek and asking for further adivce and a call about the PSU wouldn't go amiss.

    hope this helps,

    alex
     
  4. Guest-56605

    Guest-56605 Guest


    Being the owner of an Utgard and having had zero problems with the built in fan controller my suggestion would be to speak to the Company or site you purchased it from first, if it is defective your talking between 15 and 20 quid to return it by courier.

    A couple of questions -

    Is yours a new build and has the fan controller ever worked?

    Or is it a fault that has developed over time?
     

Share This Page