1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Storage How I fixed my *faulty\dead* Samsung F1 1TB (was showing as 33mb)

Discussion in 'Tech Support' started by FIBRE+, 1 Aug 2008.

  1. FIBRE+

    FIBRE+ Active Member

    Joined:
    27 Feb 2005
    Posts:
    1,597
    Likes Received:
    11
    A lot of people including myself have had problems with the new Samsung F1 1TB drives, unfortunately the problems started after I had copied all my files across, I was backing the files up when it failed so lost most of it.

    Here is how I fixed it (all data was still intact after the fix)...



    1: If you have a Gigabyte branded motherboard then update to the latest Bios, the Gigabyte @Bios tool is available - Here

    2: Download the latest Samsung ES Tool - Here

    3: Burn the image to CD or copy the .exe to floppy (depending on which version you download), then restart your pc

    4: The program should start after the boot sequence, once you get past the disclaimer screen select the correct drive from the list

    5: Go to "Set Max address", then "recover native size" it should then reset the drive to the correct size (I also hit "enable 48bit mode" first, I don't know if it helped though)

    6: Exit the program, restart your pc and boot up as normal

    Done! :D


    This worked for me and will hopefully work for you :)
     
    Krikkit and pimonserry like this.
  2. Zakris

    Zakris New Member

    Joined:
    19 Apr 2009
    Posts:
    1
    Likes Received:
    0
    I ended up with the same problem. I did just as FIBRE+ wrote, but it didn't work.. at first. BIOS showed 136GB. I tried it ones more, and than it showed 1TB, except the partitions were gone. I used testdisk (a freeware open source), and write the partition it found to the partition table and then the harddrive were back as normal, with all three partition and all files.

    Thanx alot FIBRE+, you saved my dag (week.. year actually)

    Be regards

    Zakris
     

Share This Page