1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PSU Interesting PSU Problem EVGA 550 GS

Discussion in 'Hardware' started by wiggles, 9 Feb 2016.

  1. wiggles

    wiggles Member

    Joined:
    9 Jun 2010
    Posts:
    227
    Likes Received:
    1
    Hello

    I brought and EVGA 550 GS. Fitted it. A HDD that has been running for 5+ years and a brand new SSD were never recognized by the system, do not show up in the BIOS or windows. I played around swapping the power lines, wire, end plugs and the ECO mode switch and nothing ever worked.

    I contacted EVGA and they sent out a new PSU.

    Unsurprisingly, imho this demonstrated exactly the same behavior. Went through all the permutations again and nothing.

    Anyone have any idea why this could be? Seems really strange to me that a PSU just would not power these two components but will power and older Crucial SSD that my OS is running off.

    I also tried removing some non-essential components like the GFX card but that did nothing either.
     
    Last edited: 9 Feb 2016
  2. aramil

    aramil One does not simply upgrade Forums

    Joined:
    10 Jul 2012
    Posts:
    961
    Likes Received:
    57
    Check/reseat/replace your sata cables. Also check the system BIOS to make sure the sata controller you connect to is enabled as it may of reset.

    If not reset the BIOS and check again.

    Sent from my Nexus 6P using Tapatalk
     
  3. Dan848

    Dan848 New Member

    Joined:
    25 Sep 2009
    Posts:
    31
    Likes Received:
    2
    You did not say what motherboard you have or how old the BIOS version is. Often hardware problems are only solved by flashing the motherboard BIOS to a newer version, and often the newest version on older motherboards.
     

Share This Page