1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Graphics New 7970 Playing up, suggestions?

Discussion in 'Hardware' started by SmilerAl, 31 Dec 2012.

  1. SmilerAl

    SmilerAl Terminate with extreme prejudice

    Joined:
    6 May 2010
    Posts:
    234
    Likes Received:
    2
    Recently got a new 7970, ran great and maxed out all my games, however a few days later I'm noticing artifacts on my screen and also according to MSI Afterburner the GPU usage jumps from 96% on start up. It then stays like this and I can't seem to fix it. I've tried reinstalling the drivers too but no success. Is this a wide problem or should I return my graphics card? Thanks.
     
  2. sniperdude

    sniperdude Minimodder

    Joined:
    8 Sep 2010
    Posts:
    541
    Likes Received:
    33
    I would return the card personally
     
  3. rollo

    rollo Modder

    Joined:
    16 May 2008
    Posts:
    7,887
    Likes Received:
    130
    Artifacts would indicate a poor overclock / unstable overclock.

    MSI have a history for this and id send it back and request a card not made by MSI.

    you can technically fix this yourself by just removing the overclock they have pre applied, its also a good way to test if it is just the overclock or if your card is fubar.
     
  4. SmilerAl

    SmilerAl Terminate with extreme prejudice

    Joined:
    6 May 2010
    Posts:
    234
    Likes Received:
    2
    Just to clarify it's not an MSI 7970, rather a Gigabyte one. Also I haven't overclocked it at all yet, it's just on default.

    For now it's sort of fixed it self, it only goes to full GPU usage when on Witcher 2 with Uber Sampling but I'm still paranoid it may **** up again any time soon.
     

Share This Page