1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Graphics New XFX Radeon 7870 Core Edition 2GB isn't working

Discussion in 'Tech Support' started by -Xp-, 22 Apr 2013.

  1. -Xp-

    -Xp- Minimodder

    Joined:
    23 Jul 2003
    Posts:
    918
    Likes Received:
    20
    I've just purchased a XFX Radeon 7870 Core Edition 2GB, new from Scan. It's going into this system:

    Gigabyte P55-UD4
    i5-750
    Tagan 380-U01 PSU
    Old card - XFX Radeon HD4890

    So, I'm upgrading from a XFX Radeon 4890 which has worked fine for 3 years. I know the PSU is underpowered compared to the recommended spec, but it's a solid unit and can output 28A on the 12v rail. It comes with 2 6-pin PCIe connectors and has had no trouble running the 4890, which I believe is more power-hungry than the 7870.

    With the 7870 I'm greeted with a blank screen, but the computer does boot into Windows, judging by the 'welcome' sounds. However the computer POSTs fine and boots into windows with both cards installed (with the monitor connected to the Radeon 4890). There's no sign of the Radeon 7870 in Windows.

    I have no means of testing this card in another computer. So, I'm not sure if the card is DOA or if my motherboard is incompatible with the card. I have updated to the latest BIOS (which was released in June 2010, so probably doesn't help much).

    I have tried VNCing into the computer while it's running with the 7870 installed and just get a black screen. It appears that windows (or, in fact, any part of the computer) has no idea that this card exists.

    Any suggestions for this? Does anyone else have an XFX 7870 GHz Edition 2GB in a similar setup?
     

Share This Page