1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Graphics Nvidia SLI crashing. - Finally Fixed!

Discussion in 'Hardware' started by .//TuNdRa, 15 May 2012.

  1. .//TuNdRa

    .//TuNdRa Resident Bulldozer Guru

    Joined:
    12 Feb 2011
    Posts:
    4,042
    Likes Received:
    109
    If I dump the GPU in the second PCI-E 16x socket; it goes to hell. It stutters, lags, sometimes completely locks up. I'm really not sure what's doing what at the moment.

    Edit; OKay. 280 drivers are still crashing if I enable SLI, (Blue-screen while the GPUs were busy messing around, didn't get to see the cause. Probably that damn NV.sys file, though.)

    Lets go back to the stoneage; 275.50 beta. The very first drivers to support SLI on my motherboard.
     
    Last edited: 23 May 2012
  2. Parge

    Parge the worst Super Moderator

    Joined:
    16 Jul 2010
    Posts:
    12,994
    Likes Received:
    609
    No, your perception of Microstutter is caused by the difference between the frames being produced (frametime).

    Vsync locks your frame rate to either 30 or 60 fps, depending on if your GPU is able to display frames at over 30 or over 60 frames per second.

    You might have a situation where your GPUs aren’t capable of displaying at 60fps so VSync automatically locks the fps at 30. This would be ok but actually, a fps measurement doesn’t tell the true story of perceived ‘smoothness’. For that we need to look at two metrics combined. First of all fps, and second of all, the regularity of frametimes, and speed of frametime delivery. If we have a situation like the above, where VSync has locked framerates to 30, combined with irregular frametime delivery (ie, the difference between frames 19 and 20 is 10ms, but the difference between 20 and 21 is 75ms), this can feel more like 15 or 20 fps in terms of perceived smoothness.

    Turning off Vsync might let your game run at 55 fps, which doesn’t help with frametime delivery (the frametime between the equivalent of 20 and 21 will still be 75ms), but might feel slightly smoother as they’ll be another 25 frames in that second.

    Or something like that..... ;)
     
  3. .//TuNdRa

    .//TuNdRa Resident Bulldozer Guru

    Joined:
    12 Feb 2011
    Posts:
    4,042
    Likes Received:
    109
    Turning off Vsync lets the game run at 90FPS. That's why I'm confused at why it feels so stuttery at 60Fps under Vertical Synchronisation. (I keep RTSS running the whole damn time, so I can usually see from the FPS readout if I'm being an idiot or if something really is wrong. Usually it's the former.)

    Anyway. 275.50 let me enable SLI, although I've lost a ton of performance compared to the later 301 drivers, I'm running at half the FPS I usually do in Furmark.

    Although Heaven just Driver Crashed on startup... Hrm...

    Okay. I can't get Heaven to run fullscreen. Not sure if it's because of the older drivers or GPU instability.
     
  4. Phalanx

    Phalanx Needs more dragons and stuff.

    Joined:
    28 Apr 2010
    Posts:
    3,712
    Likes Received:
    156
    The latest drivers might be worth a shot with Adaptive VSync, rather than just normal VSync.
     
  5. .//TuNdRa

    .//TuNdRa Resident Bulldozer Guru

    Joined:
    12 Feb 2011
    Posts:
    4,042
    Likes Received:
    109
    Not much point running that if I can't get both GPUs working, because then I'll be achieving "Only" 45FPS (Ish) Instead of 90.
     
  6. Chicken76

    Chicken76 Minimodder

    Joined:
    10 Nov 2009
    Posts:
    952
    Likes Received:
    32
    You should keep IOMMU always disabled. You're not using it anyway. And besides, it didn't seem to work properly when I tried it a few months back with ESXi. And in Windows, it didn't let me install the drivers for my Asus Xonar Essence STX. (probably because the Asus drivers are not aware of / can't handle the memory address translations IOMMU brings)
    After you disable IOMMU, you should reinstall drivers for your video cards at least. You could also reinstall your other drivers too, maybe even a complete Windows reinstall.
     
  7. Phalanx

    Phalanx Needs more dragons and stuff.

    Joined:
    28 Apr 2010
    Posts:
    3,712
    Likes Received:
    156
    I'd be inclined to do some testing to the hardware in that case rather than the software, as this isn't a common problem from some searching, unless my Google-fu has rescinded.
     
  8. .//TuNdRa

    .//TuNdRa Resident Bulldozer Guru

    Joined:
    12 Feb 2011
    Posts:
    4,042
    Likes Received:
    109
    With heaven refusing to play ball; I dragged out the only other demanding game i've really got on here; Metro 2033, gave it a quick burn through the first mission; seemed stable, a bit jittery, but I think that's down to the fact I was lucky to scrape 30FPS in places more than anything else.

    I think Heaven is just revolting against the lack of modern drivers. The 3.0 version was built around 290-295 ish drivers, not 275. I'll reboot and tweak a few things in the Bios, anyway.

    Rebooted after disabling IOMMU, Drivers crashed everywhere. Restarted into safemode, removed drivers, erased the remnants with Driver Sweeper, now waiting for the "Found new hardware!" wizard to piss off so I can install the drivers once more.

    Aaand now I can't get SLI to enable at all. I'm really annoyed at the randomness of this problem.

    Lets jump up to 301.42 to check the other end of the spectrum.
     
    Last edited: 23 May 2012
  9. Chicken76

    Chicken76 Minimodder

    Joined:
    10 Nov 2009
    Posts:
    952
    Likes Received:
    32
    Do you have a spare hdd? You could install a clean OS just for testing. Don't install all the drivers, just the video and maybe network to see if SLI is stable.
     
  10. .//TuNdRa

    .//TuNdRa Resident Bulldozer Guru

    Joined:
    12 Feb 2011
    Posts:
    4,042
    Likes Received:
    109
    Tried that trick already. Wiped my SSD and installed just Audio & graphics drivers alongside the windows default stuff and still got the same issue. I'm really starting to give up hope on this.

    In other news; 301.42 failed. Same symptoms. This is getting ridiculous. I may have to make a video of this lot and upload it to Youtube just so people can check to see if I am indeed covering all the bases.
     
  11. Chicken76

    Chicken76 Minimodder

    Joined:
    10 Nov 2009
    Posts:
    952
    Likes Received:
    32
    Was this before you disabled IOMMU or after?
     
  12. .//TuNdRa

    .//TuNdRa Resident Bulldozer Guru

    Joined:
    12 Feb 2011
    Posts:
    4,042
    Likes Received:
    109
    After. I reset bios to defaults then did that, with the exception of flipping the sata controller back to AHCI after resetting the bios.
     
  13. .//TuNdRa

    .//TuNdRa Resident Bulldozer Guru

    Joined:
    12 Feb 2011
    Posts:
    4,042
    Likes Received:
    109
    I know double-posting is very bad form, but I figured i'd update with a couple of new bits of information I just found.

    Firstly; Both 550's now suddenly seem to suffer from Clock skewing. Secondly; if I dared Overclock the memory by 1mhz while in SLI; it'd crash.

    Stock clocks on these cards are 2300 on the memory. Both now attempt to run at 2302. With the SLI issues; it's possible that could be causing the issue. I'm going to go edit the Bios, flash it to both cards, then check and see if that worked.

    Nope. Flashed both cards to 2200mhz on memory as of stock, still the same issue. I'm really thinking it's the motherboard now, but i've tried absolutely everything I can to identify if it's that or not. I'm shafted, basically, till I can afford a whole new motherboard, then I can RMA this one and not get caught up for up to six weeks waiting for them to pull their finger out.
     
    Last edited: 26 May 2012

Share This Page