1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Overclocking Overclock not applying in Windows 10.

Discussion in 'Tech Support' started by NeiltheDruid, 18 Feb 2016.

  1. NeiltheDruid

    NeiltheDruid Member

    Joined:
    20 May 2009
    Posts:
    147
    Likes Received:
    4
    Hi folks hope you're all having a top day,

    I've just upgraded to Windows 10 and got everything installed - lovely. However, I've noticed in CPU-Z that my 2500k doesn't have its overclock applied. I've left everything in the BIOS as it should be, CPU-Z is reporting a multiplier range of 16-42 which is fine, but no matter what load I put on the cpu the speed sits at 3.7Ghz. I have the power settings in windows all set to high performance, which doesn't seem to make a difference.

    Has anyone else encountered this?
     
  2. alfizzle

    alfizzle Well-Known Member

    Joined:
    3 Apr 2013
    Posts:
    1,999
    Likes Received:
    108
    Hi, in task manager it should report your overclock (probably not correctly tho) under system it will report that your cpu is at stock.

    The above is all normal and nothing to worry about, if CPUZ is reporting the set clock speed and multiplier correctly then your cpu is overclocked.

    For your issue, try turning speed step off in bios and see if cpuz reports the right speed. if it does re enable it and see if its fixed the issue.
     

Share This Page