1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Storage Unable to Delete Files from External Disk?

Discussion in 'Hardware' started by logan'srun, 13 Aug 2010.

  1. logan'srun

    logan'srun following the footsteps of giants

    Joined:
    22 Apr 2008
    Posts:
    553
    Likes Received:
    42
    I have a MyBook Pro that I've been running Norton Ghost on and now that it's full, I'm unable to delete any files?

    Like any files. Right Clicking on a folder doesn't present me with the option of deleting , nor can I just use the delete key on a folder.

    What's preventing me from being able to delete? I need to clean out some old files so I have room on the disk for my backups, and I can't get rid of anything.

    I don't know if this is a hardware or software question, but I'll leave it here. If it's a software issue, please move Mods.
     
  2. IanW

    IanW Grumpy Old Git

    Joined:
    2 Aug 2003
    Posts:
    7,115
    Likes Received:
    792
    Check your drive permissions (usually right click/properties), and ensure the drive is owned by your current username.
    If not, you need to log in as root/admin/whatever Apple call it in order to delete the files.
     
  3. logan'srun

    logan'srun following the footsteps of giants

    Joined:
    22 Apr 2008
    Posts:
    553
    Likes Received:
    42
    thanks, but it's a PC. The My Book Pro is a WD external disk.

    I had Admin rights, but it was something strange anyway. Instead of wasting time trying to figure it out, I've already moved important docs off of it (I could copy but that was it) and am now in the process of re-formatting the disk itself.
     
  4. Burnout21

    Burnout21 Is the daddy!

    Joined:
    9 Sep 2005
    Posts:
    8,614
    Likes Received:
    197
    Pretty much the most hassle free option is to just take what you want and hit the format button.

    I imagine Norton Ghost had a protect feature in place to prevent accidental deletion.
     

Share This Page