1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Displays What's keeping my monitor awake?

Discussion in 'Tech Support' started by Salty Wagyu, 3 Aug 2010.

  1. Salty Wagyu

    Salty Wagyu moo

    Joined:
    5 Jul 2010
    Posts:
    454
    Likes Received:
    17
    Over the last few days something has been preventing my monitor from going into standby. I have set Windows to turn off the display after 1minute of idle time and have tested it a lot but the monitor simply won't turn off. Other days it works just fine, and I haven't been able to find the cause of this odd problem.

    I have run powercfg with the -requests switch and got:

    Code:
    DISPLAY:
    None.
    
    SYSTEM:
    None.
    
    AWAYMODE:
    None.
    Whereas, when running Media Player Classic which prevents screensavers/standby from kicking in, shows:

    Code:
    DISPLAY:
    [PROCESS] \Device\HarddiskVolume2\Program Files (x86)\Combined Community Codec Pack\MPC\mpc-hc.exe
    
    SYSTEM:
    [DRIVER] VIA High Definition Audio (HDAUDIO\FUNC_01&VEN_1106&DEV_4441&SUBSYS_104383CF&REV_1001\4&2ba
    06080&0&0001)
    An audio stream is currently in use.
    [PROCESS] \Device\HarddiskVolume2\Program Files (x86)\Combined Community Codec Pack\MPC\mpc-hc.exe
    
    AWAYMODE:
    [PROCESS] \Device\HarddiskVolume2\Program Files (x86)\Combined Community Codec Pack\MPC\mpc-hc.exe
    
    powercfg with the -energy switch doesn't show anything abnormal other than some warnings about not being able to suspend some USB devices but that appears to be common. I have also pulled out the mouse cord and waited 1 minute but the monitor does not go into standby.

    The only major hardware change I've done is a bios update, and there is nothing over at ASUS P7P55D forums to suggest any issues with power savings.

    Any ideas?
     
  2. outlawaol

    outlawaol Geeked since 1982

    Joined:
    18 Jul 2007
    Posts:
    1,935
    Likes Received:
    65
    Push the power button when you walk away? ;)

    Actually you may want to check to see if the monitor itself does not have some standby mode that is disabled/off enabled/on or similar. May want to cycle the off time, save and move around to ensure the settings are being taken. Other then that I couldnt say more without seeing it. :)
     
  3. Phalanx

    Phalanx Needs more dragons and stuff.

    Joined:
    28 Apr 2010
    Posts:
    3,712
    Likes Received:
    156
    Are you using a Microsoft mouse perchance? Perhaps an Intellimouse? Their drivers are known to make the mouse pointer "twitch", and the OS thinks you're moving the mouse.
     
  4. Salty Wagyu

    Salty Wagyu moo

    Joined:
    5 Jul 2010
    Posts:
    454
    Likes Received:
    17
    No I use a Razer Abyssus, but I have already unplugged the mouse and tested the idle time in-case it was the high sensitivity of the mouse, but that wasn't it, monitor stayed awake.

    There's no power saving features in the Monitor's on-screen menu either as far as I can tell. It's a 22" LG Flatron L226WTQ
     
  5. Fingers66

    Fingers66 Kiwi in London

    Joined:
    30 Apr 2010
    Posts:
    8,678
    Likes Received:
    915
    Did this just start happening or has it coincided with something else?

    Have you altered the BIOS settings in any way? There are power management items in the BIOS, especially around video power saving. Does everything look the same as it was?

    I know how annoying this is. On one of my rig's, I cannot get it to go to sleep under Windows 7. It slept fine on Vista 64bit but it wakes instantly with 7 - something is keeping it awake.

    Try putting it to sleep then unplugging the monitor - does the HD shutdown etc?

    Is SMART enabled in the BIOS?

    Does the new GTX460 driver have any power saving functionality?

    That's all I can think of at the moment.
     
  6. Salty Wagyu

    Salty Wagyu moo

    Joined:
    5 Jul 2010
    Posts:
    454
    Likes Received:
    17
    Yes, I updated the BIOS recently when this started happening, around 3 revisions ahead of my old version. Made sure the power settings in the BIOS looked the same as my old setup, such as Suspend state set to [Auto] (other choices are S1 and S3), and changed ACPI 2.0 to enabled.

    Sleep works fine, I use it every night when I'm finished for the night, monitor goes into standby, fans and everything else shuts off, so nothing is on except for the RAM. I'm not sure why I need to unplug the monitor? But regardless it isn't affecting the sleep state.

    SMART is working, and this issue happened with my Geforce 260 as well (only just put in my new 460 yesterday) so that's not it.

    It's not making much sense, I could reboot, test, and the monitor would standby just fine, but over longer uptime it will choose to stop working. If the culprit really was a windows process it would show in powercfg but doesn't.
     
  7. Fingers66

    Fingers66 Kiwi in London

    Joined:
    30 Apr 2010
    Posts:
    8,678
    Likes Received:
    915
    So it sleeps fine but doesn't go into standby? The PC enters standby, just not the monitor?
     
  8. Salty Wagyu

    Salty Wagyu moo

    Joined:
    5 Jul 2010
    Posts:
    454
    Likes Received:
    17
    Sleep and Standby are both the same thing I thought? PC goes to sleep and the LED on the monitor changes to orange - the standby state, as it should.

    But the monitor isn't going into standby after 15minutes of idle time when I'm away from the PC during the day.

    To test, I change this to 1 minute:
    [​IMG]

    I leave the PC alone for 1 minute, and the display stays awake still
     
  9. Salty Wagyu

    Salty Wagyu moo

    Joined:
    5 Jul 2010
    Posts:
    454
    Likes Received:
    17
    I decided to switch to the spare monitor since my main monitor stopped going into standby again. I hooked up the spare, made it go into standby a few times, then it stopped after the 4th attempt or so.

    I also tried disabling ACPI 2.0 (since BIOS defaults has this off by default), no change there either.
     
  10. outlawaol

    outlawaol Geeked since 1982

    Joined:
    18 Jul 2007
    Posts:
    1,935
    Likes Received:
    65
    Does it see the monitor in device manager as the actual model or a generic display? If it sees it as the model force it to use generic drivers. Its worth a try, but it looks like its bios update that is messing with it for some reason.
     
  11. Salty Wagyu

    Salty Wagyu moo

    Joined:
    5 Jul 2010
    Posts:
    454
    Likes Received:
    17
    It's seen as a Generic PnP Monitor. My LG Flatron L226WTQ has never shown its actual name in Device Manager in XP/7 in the 2-3 years I've had it afaik.
     
  12. bulldogjeff

    bulldogjeff The modding head is firmly back on.

    Joined:
    2 Mar 2010
    Posts:
    8,403
    Likes Received:
    634
    Chane the box marked NEVER to 1 minute and I think you'll find it works

    mind you that'll put the system to sleep
     
  13. Cerberus90

    Cerberus90 Car Spannerer

    Joined:
    23 Apr 2009
    Posts:
    7,586
    Likes Received:
    150
    he doesn't want to put the computer to sleep though, just turn the monitor off.
     
  14. paisa666

    paisa666 I WILL END YOU!!!

    Joined:
    4 Mar 2009
    Posts:
    810
    Likes Received:
    42
    check the taskbar (bottom right) maybe active task prevent the display from goin to standby (antiviruses, the razor task icon, maybe other software you have)
     
  15. Salty Wagyu

    Salty Wagyu moo

    Joined:
    5 Jul 2010
    Posts:
    454
    Likes Received:
    17
    7 month old problem solved. Uninstalled the Razer Abyssus mouse drivers (would never have guessed) and the screensaver/display standby has kicked in without fail for 24+ hours so far.
     

Share This Page