1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Networks WOL trouble using magic packets...

Discussion in 'Tech Support' started by Wicked_Sludge, 11 Jun 2013.

  1. Wicked_Sludge

    Wicked_Sludge My eyes! The goggles do nothing!

    Joined:
    15 Aug 2010
    Posts:
    2,232
    Likes Received:
    80
    I am having troubles getting my GA-P55A-UD3 (using the on board LAN controller) to WOL using magic packets. I am trying to wake it via my android phone over the internet (not LAN). With my current settings and using a packet sniffer, the PC seems to be receiving 100% of the packets I send from the phone. At first the PC would only wake from sleep (I'd like to it wake from hibernate), but now it won't even wake from sleep. I am starting to think maybe I have a hardware problem but I'd like a second opinion.

    So far I have:

    -Checked "Allow the computer to turn this device off to save power" (required in order to check the following: ), "Allow this device to wake the computer" and "Only allow a magic packet to wake this computer". All found under my LAN controller properties under the Power Management tab.

    -Enabled the "Wake on Magic Packet" property under the advanced tab of my controller properties.

    -Forwarded port 9 in my router to my PCs internal IP and set a static IP for my PC in my network.

    -Set an exception for port 9 in Windows Firewall.*

    -Started the Windows service "Simple TCP/IP services" *

    -Enabled WOL and S3 states in my Power saving features in BIOS (I forget exactly what they are called, but something to that effect.)

    * Recommended from a few sites when googling the problem.

    If I deselect "Only allow a magic packet to wake this computer" under my LAN controller properties under the Power Management tab, The PC will wake from sleep or hibernate when I send a packet, but of course with this setup the computer also wakes randomly whenever there is network activity, which won't do.

    Thoughts?
     
  2. qualalol

    qualalol What's a Dremel?

    Joined:
    24 Aug 2011
    Posts:
    74
    Likes Received:
    4
    When the computer is off then the IP addresses are completely irrelevant -- WOL works with MAC addresses -- you send the magic packet containing the mac address on a broadcast address -- thus the packet is sent to every single NIC that is connected to the network, your NIC then checks if this is the magic packet containing the correct mac address and then switches on.

    The IP address you send to is the broadcast address (i.e. send to everyone on the network): 255.255.255.255 can be used to send to the local network (although if you have a home network in the 192.168.0.* range you can use 192.168.0.255, similarly for 192.168.1.* you can use 192.168.1.255).
    If you're trying to connect from outside you'll need to check the router for details, but it doesn't look like a simple option ( https://en.wikipedia.org/wiki/Wake_on_lan#Subnet_directed_broadcasts might help ). One option is possibly to use a VPN to connect into your home network (not sure about broadcasts being transmitted there), or just ssh into another computer to send the command on the local network (where "another computer" could easily be a cheap raspberry pi).
     
    Wicked_Sludge likes this.
  3. Wicked_Sludge

    Wicked_Sludge My eyes! The goggles do nothing!

    Joined:
    15 Aug 2010
    Posts:
    2,232
    Likes Received:
    80
    The app I'm using on my phone does require the MAC address for the computer you wish to wake, which I've provided it. I am using a DDNS service to contact my router from outside the network. The app broadcasts on port 9 which was the reason for the port forwarding and static IP.


    The packet sniffer I'm using shows the packets arriving on the PC, so that should mean the problem isn't network related, correct? Either a settings somewhere that I've missed or hardware problems?

    My router is running DD-WRT and so far I haven't been able to verify if I can do subnet directed broadcasts with it...but assumedly not.

    I do have a server on the network I could VNC into to wake my main PC but that adds a lot of time consuming steps. The app on my phone is literally one touch to send packets to my network.
     
  4. qualalol

    qualalol What's a Dremel?

    Joined:
    24 Aug 2011
    Posts:
    74
    Likes Received:
    4
    The problem is that the computer DOESN'T have an IP address when it's turned off -- the computer's IP address is completely irrelevant here. You need to send the packet to the broadcast address for the network (meaning the packet is sent to every NIC that is connected even if it has no IP address), not the computers IP address since that will just redirect to nowhere. I've found a better description of things on the DD-WRT wiki along with how to set things up:
    http://www.dd-wrt.com/wiki/index.php/WOL
    I'd recommend not port forwarding though as that could be insecure though, and is quite a lot more complicated to set up.

    Also you should try sniffing the network with another device when the PC is turned off, if the magic packet doesn't arrive there then you're not sending the correct magic packet -- it has to be sent to every single device on the network.

    And good luck: it did take me quite some experimenting to get WOL working for me! :)
     
  5. Wicked_Sludge

    Wicked_Sludge My eyes! The goggles do nothing!

    Joined:
    15 Aug 2010
    Posts:
    2,232
    Likes Received:
    80
    Right....I'm an idiot. What's strange is the tutorial on the DD-WRT wiki says I still need a static IP for the PC to be woken.

    At any rate, I think I got it working using port forwarding and entering the command line into my routers config to have it broadcast the packets to the network. The way I had it set up before was close, so it only took tweaking a few settings (entering a subnet address to the app in my phone and entering the command line to my router).

    The static IP I assigned to the computer and the IP I entered into the command line don't match, because the wiki says the command line IP shouldn't be one that is assigned to any device on the network. But it also says it "should correspond with the IP address you used in the previous step"....which sounds like a complete contradiction to me. So I just tried it this way and so far it has worked a grand total of one (1) times :hehe:

    What's strange is that the way I had it set up before would wake the PC but after messing with it some last night it seemed to only wake it during the first 5 minutes or so after I put it to sleep. Beyond that it wouldn't respond. I think that is what lead me to believe the WOL had stopped working; I just happened to try it after that ~5 minute window.
     
  6. qualalol

    qualalol What's a Dremel?

    Joined:
    24 Aug 2011
    Posts:
    74
    Likes Received:
    4
    I'm not too sure why they mention a static IP there -- but you'll probably still want one so you can access the computer once it's on? (It might be working for the first 5 minutes since the router still associates the Mac address with the IP address, and so the packet gets through anyway, after that it'll forget the MAC for the IP address since the device hasn't communicated in that time? Not got much of an idea though...)

    Apparently someone in another thread just logs in to DD-WRT and uses the WOL page there, but admittedly that's a bit more of a hassle.
     
  7. Wicked_Sludge

    Wicked_Sludge My eyes! The goggles do nothing!

    Joined:
    15 Aug 2010
    Posts:
    2,232
    Likes Received:
    80
    Well I've woken the computer several times with these settings now and it seems to be working good. I still get to use my one-touch app on my phone so I'm happy.

    As an additional bonus, turns out my system will wake from a completely off state which is nice.

    Thanks for your help and +rep'd accordingly.
     

Share This Page