1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Other Installing XP on a second HDD

Discussion in 'Hardware' started by MarkW7, 27 Feb 2009.

  1. MarkW7

    MarkW7 Total Noob

    Joined:
    30 Nov 2008
    Posts:
    1,795
    Likes Received:
    32
    Hi all,

    Can i get xp onto my second hdd, ive tried putting it in and booting from the disk but it says NTLRD is missing.
    I was thinking maybe i can install xp when its a secondary drive.

    Any ideas?

    Thanks.


    Please ignore the below [problem solved]

    I have two harddrives a 40gb and a 10gb IDE.

    Both work ok. (did)

    I had XP loaded on the 40gb for ages and was using it fine but today i got some parts and decided i want to installed xp on the 10gb so i can test other bits.

    So i put it in my pc as a second drive - put the xp disk in and installed. seemed ok.

    untill i turned my pc off and put my 40gb back in by itself.
    Booted up and it said it cannot read my hardware configuration.

    So i thought great!
    Tried the 10gb and now that says something is missing press Ctrl + alt + del to restart.

    But..

    When i put the 40gb and 10gb in together it boots into the new install (10gb) and the 40gb is showing up and i can see all my files ect.

    Any ideas?

    Thank you.
     
    Last edited: 1 Mar 2009
  2. azrael-

    azrael- I'm special...

    Joined:
    18 May 2008
    Posts:
    3,852
    Likes Received:
    124
    You had both drives connected, with the 40GB being the first drive and having Windows on it already? And then you installed XP on the 10GB drive that was connected as the second drive?

    If that is indeed the scenario, then the boot files, which always go on the first drive, have been altered to point to the Windows installation on the second drive. The smart thing would have been to disconnect the 40GB drive and install the 10GB drive as the first drive. Or you could presumably have cloned the Windows installation from the 40GB drive.

    I'm not sure if the installation on your 10GB drive is salvagable without putting way too much work into it. All drive letters will point to the wrong drive for one, including lots of settings in the Windows registry. Also the boot initialization points to the second drive, yet resides on the first drive.

    As it stands you should, like previously mentioned, disconnect the 40GB drive and install the 10GB drive instead and just do another Windows installation.
     
  3. MarkW7

    MarkW7 Total Noob

    Joined:
    30 Nov 2008
    Posts:
    1,795
    Likes Received:
    32
    Is there anyway i can get the 40gb to work without reinstalling it all.

    10gb doesnt bother me having to do again.
     
  4. azrael-

    azrael- I'm special...

    Joined:
    18 May 2008
    Posts:
    3,852
    Likes Received:
    124
    Put both drives in so they work in the new configuration. I'd guess that would make the old 40GB drive show up as drive C:. Correct?

    If so, make sure you can see all files in Explorer or start a command prompt ("cmd.exe" from Run...), then type "C:", then "cd \" and then "attrib -s -h -r boot.ini". Now type "notepad boot.ini". (don't enter the quotes in any of the previous or following cases)

    You should have a line reading a bit like this:

    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS

    and also a line reading like this:

    multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional" /fastdetect

    The interesting bit here are the values for multi, disk, rdisk and partition. My settings show that my Windows is on the second partition of the first drive.

    I'd say your entries would probably have either multi, disk or rdisk show up as 1 and partition also show up as 1. Leave the partition value alone, since I believe that Windows is installed on the first (or only) partition on both drives. However, if any of the other three values says 1, then set that value to 0, meaning that the Windows loader should look on the first drive.

    When you've made the changes, save the file, exit notepad, then type "attrib +s +h +r boot.ini". Then close the command prompt.

    Now you should have access to Windows on the first drive again.
     
    mvagusta likes this.
  5. Dozer42

    Dozer42 New Member

    Joined:
    22 Feb 2009
    Posts:
    29
    Likes Received:
    2
    I know this might sound simple, but have you set the slave/master/CS jumpers properly?

    Also, a good way to test the drives to make sure they're fine is to connect them to an external USB to IDE adapter. We've done tons of drive recoveries this way when the system isn't bootable.

    But like the above person said, it's possible that the MBR & boot.ini files have become a bit pooched. Both of which you can take a look at when they're connected as an external drive, or when booting off something like the UBCD (google it, download and burn). =]

    Sorry if some of this seems overly obvious, we often find the obvious has been overlooked.
     
  6. MarkW7

    MarkW7 Total Noob

    Joined:
    30 Nov 2008
    Posts:
    1,795
    Likes Received:
    32
    azrael-

    Yep when both dirves are in it shows the 40.

    Will try the rest now.
     
  7. MarkW7

    MarkW7 Total Noob

    Joined:
    30 Nov 2008
    Posts:
    1,795
    Likes Received:
    32
    this is what i've got;

    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(1)partition(1)\WINDOWS=''Microsoft windows XP Professional'' /noexecute=opt in /fast detect
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS=''Microsoft windows XP Professional'' /noexecute=opt in /fast detect
     
  8. MarkW7

    MarkW7 Total Noob

    Joined:
    30 Nov 2008
    Posts:
    1,795
    Likes Received:
    32
    I changed that into;

    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(1)partition(1)\WINDOW S
    [operating systems]
    multi(0)disk(0)rdisk(0)<< that to a 0 partition(1)\WINDOWS=''Micr osoft windows XP Professional'' /noexecute=opt in /fast detect
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS=''Micr osoft windows XP Professional'' /noexecute=opt in /fast detect
     
  9. MarkW7

    MarkW7 Total Noob

    Joined:
    30 Nov 2008
    Posts:
    1,795
    Likes Received:
    32
    it lets me boot into the first 40gb by itsself but a screen comes up saying choose

    windows xp pro
    windows xp pro

    and i cant move anything then it just loads it.
     
  10. azrael-

    azrael- I'm special...

    Joined:
    18 May 2008
    Posts:
    3,852
    Likes Received:
    124
    Basing this on the original content of the boot.ini file, you could simply change the value for rdisk to 0 and then delete the last entry.

    Essentially, what it says in the boot.ini file is this.
    For [boot loader]:
    The timeout parameter determines how long the boot menu is supposed to be shown in case there is more than 1 entry.

    The default parameter determines which OS is supposed to be loaded as default. This is also the OS loaded, if you don't respond before the timeout times out.

    For [operating systems]
    The first parameter these days will always read multi. It *could* be scsi, but that's extremely rare to non-existent these days. The value is always 0 for multi.

    The parameter value, disk, will always be 0 if the first parameter is multi.

    The third parameter, rdisk, denotes the physical hard drive the OS is located on and is counted from 0 as the first drive. If you have only 1 drive in your system, this value will always be 0. As you noted yourself after installing a second drive and installing Windows on it that value changes to 1.

    The fourth parameter, partition, refers to the partition number the OS is located on. Contrary to the other parameters counting starts at 1, so the first partition isn't 0, but 1, which is also the usual value for most installations.

    The "\WINDOWS" parameter denotes that the OS is Windows and following in quotes (not citation marks!) is the name shown on the boot menu. The name isn't used for anything else.

    Following the name are a number of options. The one called /fastdetect should always be present. You should also keep /noexecute=optin. Notice, that there are no spaces in the option names nor their values.

    After editing your boot.ini should contain this:

    (the text seems to get formatted incorrectly by the forum software)

    As for not being able to choose anything, your keyboard is probably connected via USB and the BIOS probably doesn't handle "legacy mode", so the keyboard is first detected in Windows.
     
  11. MarkW7

    MarkW7 Total Noob

    Joined:
    30 Nov 2008
    Posts:
    1,795
    Likes Received:
    32
    i tried to reopen the same thing and it said boot.ini not found - do you want to create one, so i said yes, put in;

    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOW S
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Micro soft Windows XP Professional" /noexecute=optin /fastdetect

    then saved, restarting now.
     
  12. azrael-

    azrael- I'm special...

    Joined:
    18 May 2008
    Posts:
    3,852
    Likes Received:
    124
    The file needs to go on the 40GB hard drive and on that drive's first partition. Also, I don't like it when you say that notepad claimed no such file exists. Either you looked in the wrong place or you haven't disabled the "Hide file extensions" option in Explorer. If the latter is the case you might end up with a file that actually is called boot.ini.txt, but is shown as boot.ini. Windows will not find the file unless it is named correctly. You might want to save the file as type "All files (*.*)".
     
  13. MarkW7

    MarkW7 Total Noob

    Joined:
    30 Nov 2008
    Posts:
    1,795
    Likes Received:
    32
    Where should the boot file be saved.

    tried all above and still saying choose a version of xp when booting.
     
  14. azrael-

    azrael- I'm special...

    Joined:
    18 May 2008
    Posts:
    3,852
    Likes Received:
    124
    It needs to go in the root on what is probably labeled drive C:.
     
  15. MarkW7

    MarkW7 Total Noob

    Joined:
    30 Nov 2008
    Posts:
    1,795
    Likes Received:
    32
    at the moment it's in;

    C: , documents and setting, markw , then in there.
     
  16. MarkW7

    MarkW7 Total Noob

    Joined:
    30 Nov 2008
    Posts:
    1,795
    Likes Received:
    32
    Woo, done it -

    I went into my computer > right cliked > properties > advanced > edit boot.

    Then put the right ones to 0
    and deleted the second line.

    restarted and it's fine.

    Now how can i get xp on the 10gb.

    thanks all.
     
  17. MarkW7

    MarkW7 Total Noob

    Joined:
    30 Nov 2008
    Posts:
    1,795
    Likes Received:
    32
    Anyone know how i can get xp on the 10gb, just telling me NTLRD is missing.
     
  18. azrael-

    azrael- I'm special...

    Joined:
    18 May 2008
    Posts:
    3,852
    Likes Received:
    124
    You could start by reading my PM... :)
     
  19. MarkW7

    MarkW7 Total Noob

    Joined:
    30 Nov 2008
    Posts:
    1,795
    Likes Received:
    32
    tried all still same problem.
     
  20. azrael-

    azrael- I'm special...

    Joined:
    18 May 2008
    Posts:
    3,852
    Likes Received:
    124
    Then you're doing something wrong. You're certainly not preventing the BIOS from booting on the hard drive instead of from the installation CD.

    Since you previously installed Windows on the 10GB drive while still having the 40GB drive as the first drive in the system NTLDR, NTDETECT.COM, as well as BOOT.INI were placed on that drive and not on the 10GB drive.

    Now that you've disconnected the 40GB drive the Windows version trying to boot off the 10GB drive naturally cannot find these files. Even if the files *could* be found Windows was installed with an incorrect drive letter (probably D: if the 40GB drive only contains one partition), so you couldn't possibly run it.

    So, once again, you need to make sure that BIOS doesn't try to boot the hard drive as the first device, then make sure to have the Windows installation CD in your CD/DVD drive. There is a very slight chance that either your motherboard or your CD/DVD drive is unable to boot from a bootable CD. That happens with some very old hardware. Another reason for not being able to boot from the Windows installation CD would be that the CD isn't bootable, but that would make it a very odd Windows installation CD. :)
     

Share This Page