1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Other screen blanking !!!

Discussion in 'Hardware' started by stormbringer500, 24 Apr 2014.

  1. stormbringer500

    stormbringer500 What's a Dremel?

    Joined:
    6 Jan 2010
    Posts:
    400
    Likes Received:
    2
    Hi there I have just installed a Intel Core i5 2500 and booting from the USB to install windows 8 and screen goes blank, the pc is still running but no screen. Just wondering if anyone has any ideas.
     
  2. stormbringer500

    stormbringer500 What's a Dremel?

    Joined:
    6 Jan 2010
    Posts:
    400
    Likes Received:
    2
    The setup consists off a p8p67 pro, core i5 2500, 8gb kingston ram, HD5770 and a corsair 450w.
     
  3. GoodBytes

    GoodBytes How many wifi's does it have?

    Joined:
    20 Jan 2007
    Posts:
    12,300
    Likes Received:
    710
    - Make sure you are not using the VGA plug to run the display, or HDMI. Use DVI, or Displayport. Does that work?

    - If your graphics card have multiple inputs, try using another one (even if it's VGA or HDMI). I am thinking that the other output is set to default.

    - You may want to re-install the drivers. To do this, go to Safe Mode. TO do this in Windows 8, as you don't see the screen: Start the system, then hit the restart button the moment Windows 8 loads. DO this 3 times. The fourth time you should get to a screen allowing you to go to Safe Mode. There is no F8 key trick, because modern fast system boots the system from power to desktop in 6sec or even less. So you just can't hit F8 on time.

    From there, once in Safe mode, download the latest drivers, uninstall the current ones, and install the new ones.
     
  4. stormbringer500

    stormbringer500 What's a Dremel?

    Joined:
    6 Jan 2010
    Posts:
    400
    Likes Received:
    2
    I cannot re-install any drivers cause I do not have a windows version installed to do that.
     
  5. GoodBytes

    GoodBytes How many wifi's does it have?

    Joined:
    20 Jan 2007
    Posts:
    12,300
    Likes Received:
    710
    Oh you are installing it, I taught you just installed it. My bad.

    Ok, well try the different video outputs connection on your computers. It probably uses VGA as the primary one. For the install, do it over that main connector, once done, install the drivers, and now you should be able to use the the video output of your choice. If the computer has a dedicated GPU and integrated graphics, it probably defaults to the wrong graphics solution at the setup due to lack of drivers.

    If that does not work, then probably it is waiting for a device to response and not.
    So unplug all extra hardware inside the computer (example: dedicated sound card TV Tuner, Wireless card), and all USB peripherals, except keyboard and mouse and obviously your USB flash drive. And now try.

    Make sure that AHCI mode is set for the SATA Controller, and not RAID or IDE (can also be called: Safe Mode, or Compatibility or Legacy).
    The option is in the BIOS.

    In the BIOS, make sure that Floppy Drive is set to Disabled (Windows setup might be waiting for the device to respond, but you don't have one). I had this problem with Windows 7 on my old system.


    Does any of this help?
     
  6. stormbringer500

    stormbringer500 What's a Dremel?

    Joined:
    6 Jan 2010
    Posts:
    400
    Likes Received:
    2
    Well I have the computer connected through a DVI to VGA adapter on the 5770, I cannot use onboard cause does not have. I shall try the AHCI setting and unplugging extra hard drive and wifi card etc.
     
  7. stormbringer500

    stormbringer500 What's a Dremel?

    Joined:
    6 Jan 2010
    Posts:
    400
    Likes Received:
    2
    Ok have tried booting with the pc connected through dvi to hdmi and just one hard drive plugged in and it still cuts the display.
     
  8. stormbringer500

    stormbringer500 What's a Dremel?

    Joined:
    6 Jan 2010
    Posts:
    400
    Likes Received:
    2
    A thought did occur to me could it be the case not getting enough air it is a Coolermaster elite mid tower.
     
  9. aramil

    aramil One does not simply upgrade Forums

    Joined:
    10 Jul 2012
    Posts:
    961
    Likes Received:
    57
    In the BIOS you may need to set the display priority to PCI and disable the internal (cpu)graphics [if my memory is correct it is stated as multi monitor/GPU. Lucid virtu]

    I have had this a few times on Asus boards with both igpu & GPU setups. Is you get the BIOS/ splash screens but when you go to OS/install it drops to default ( usually the igpu even without an output)

    Oh and make sure the BIOS is the latest.
     
  10. lancer778544

    lancer778544 Multimodder

    Joined:
    5 Jan 2011
    Posts:
    2,883
    Likes Received:
    376
    OP is using a P67 based board so no onboard GPU capabilities I believe.

    Have you got another GPU to test with temporarily?
     
  11. stormbringer500

    stormbringer500 What's a Dremel?

    Joined:
    6 Jan 2010
    Posts:
    400
    Likes Received:
    2
    I do have a 6970 but believe that would fry psu, also the 5770 is working as I used to have it jsut been stored away in a box.
     
  12. lancer778544

    lancer778544 Multimodder

    Joined:
    5 Jan 2011
    Posts:
    2,883
    Likes Received:
    376
    How long do you leave it on the blank screen? And does the screen actually switch off or does it just go blank?
     
  13. stormbringer500

    stormbringer500 What's a Dremel?

    Joined:
    6 Jan 2010
    Posts:
    400
    Likes Received:
    2
    Well left for hour or so and the screen goes to "No signal is being received"
     
  14. lancer778544

    lancer778544 Multimodder

    Joined:
    5 Jan 2011
    Posts:
    2,883
    Likes Received:
    376
    Might be worth installing Windows 7 first and then if it installs fine, you could upgrade to 8 from within it. You can download a legitimate Windows 7 ISO here then use the Windows 7 USB/DVD download tool to put the ISO onto your USB drive. If the install works and you get to the point where it asks for a key, leave the field blank and it'll give you 30 days before it'll require activation.
     
  15. stormbringer500

    stormbringer500 What's a Dremel?

    Joined:
    6 Jan 2010
    Posts:
    400
    Likes Received:
    2
    Ok ill try that, another thing could it be graphics card not getting enough heat if so would it be an idea to move everything from a coolermaster elite to a HAF 932. I will try windows 7 though.
     
  16. stormbringer500

    stormbringer500 What's a Dremel?

    Joined:
    6 Jan 2010
    Posts:
    400
    Likes Received:
    2
    Just thought I would let you know problem solved, it was dust clogging up the graphics card so after a good blow at each end worked like a charm.
     
  17. GoodBytes

    GoodBytes How many wifi's does it have?

    Joined:
    20 Jan 2007
    Posts:
    12,300
    Likes Received:
    710
    how much dust you had to actually cause such a big problem?
    You know what, I don't want to know.... :|

    A clean PC is a happy PC.
     
  18. lancer778544

    lancer778544 Multimodder

    Joined:
    5 Jan 2011
    Posts:
    2,883
    Likes Received:
    376
    If it was that bad it might be worth taking the shroud/fan off and giving it a good proper clean out or even taking the heatsink off and reapplying some new thermal paste.
     
  19. stormbringer500

    stormbringer500 What's a Dremel?

    Joined:
    6 Jan 2010
    Posts:
    400
    Likes Received:
    2
    Well may have to look at some youtube video cause I have to say I have never done that before.
     

Share This Page